[PATCH] gnu: cheese: Update to 44.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 1 years ago
(address . guix-patches@gnu.org)
7741da681eb728c6c70653ca4142c8e84b92b7f0.1699961846.git.vivien@planete-kraus.eu
The build system changed how it disables icon-theme.cache.

* gnu/packages/gnome.scm (cheese): Update to 44.1.
[#:phase 'skip-gtk-update-icon-cache]: Update.

Change-Id: I95044d29da019345d14b5fe8f1671f0f7046fba3
---
gnu/packages/gnome.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2958da2cd9..69212ca0ef 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11344,7 +11344,7 @@ (define-public gnome-video-effects
(define-public cheese
(package
(name "cheese")
- (version "43.0")
+ (version "44.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -11352,7 +11352,7 @@ (define-public cheese
version ".tar.xz"))
(sha256
(base32
- "02vzcvk2s6cwvdw6v6qmlq3znamy6zwv7l6nlbqjfwrj7i54qmvl"))))
+ "13pnz35yvwvmk1iyhcp1a94yal4rh610rxmsp3rdsm4yr728a8az"))))
(arguments
(list #:glib-or-gtk? #t
#:phases
@@ -11360,8 +11360,9 @@ (define-public cheese
(add-after 'unpack 'skip-gtk-update-icon-cache
(lambda _
;; Don't create 'icon-theme.cache'.
- (substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") (which "true")))))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
(add-after 'install 'wrap-cheese
(lambda* (#:key inputs outputs #:allow-other-keys)
(wrap-program (search-input-file outputs "bin/cheese")

base-commit: 72e886328c14c832b2ed71c400069b63852ee18d
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v2] gnu: cheese: Update to 44.1.
(address . 67165@debbugs.gnu.org)
8741da681eb728c6c70653ca4142c8e84b92b7f0.1699961846.git.vivien@planete-kraus.eu
The build system changed how it disables icon-theme.cache.

* gnu/packages/gnome.scm (cheese): Update to 44.1.
[#:phase 'skip-gtk-update-icon-cache]: Update.

Change-Id: I95044d29da019345d14b5fe8f1671f0f7046fba3
---
gnu/packages/gnome.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2958da2cd9..69212ca0ef 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11344,7 +11344,7 @@ (define-public gnome-video-effects
(define-public cheese
(package
(name "cheese")
- (version "43.0")
+ (version "44.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -11352,7 +11352,7 @@ (define-public cheese
version ".tar.xz"))
(sha256
(base32
- "02vzcvk2s6cwvdw6v6qmlq3znamy6zwv7l6nlbqjfwrj7i54qmvl"))))
+ "13pnz35yvwvmk1iyhcp1a94yal4rh610rxmsp3rdsm4yr728a8az"))))
(arguments
(list #:glib-or-gtk? #t
#:phases
@@ -11360,8 +11360,9 @@ (define-public cheese
(add-after 'unpack 'skip-gtk-update-icon-cache
(lambda _
;; Don't create 'icon-theme.cache'.
- (substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") (which "true")))))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
(add-after 'install 'wrap-cheese
(lambda* (#:key inputs outputs #:allow-other-keys)
(wrap-program (search-input-file outputs "bin/cheese")

base-commit: 72e886328c14c832b2ed71c400069b63852ee18d
--
2.41.0
Liliana Marie Prikler wrote 1 years ago
5967ed5baba89ce2e4c748323f9dcf37a1449055.camel@gmail.com
Am Dienstag, dem 14.11.2023 um 01:01 +0100 schrieb Vivien Kraus:
Toggle quote (4 lines)
> The build system changed how it disables icon-theme.cache.
>
> * gnu/packages/gnome.scm (cheese): Update to 44.1.
> [#:phase 'skip-gtk-update-icon-cache]: Update.
I personally prefer [#:phases]<the-phase>. (I don't think #:phase
'the-phase is used anywhere.) Instead of "Update" you might want to
say "Adjust accordingly."


Cheers
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v3] gnu: cheese: Update to 44.1.
(address . 67165@debbugs.gnu.org)
f2bffe29e49dd33af990c4a27fbd1aff2b1e9974.1700116672.git.vivien@planete-kraus.eu
The build system changed how it disables icon-theme.cache.

* gnu/packages/gnome.scm (cheese): Update to 44.1.
[#:phases]<skip-gtk-update-icon-cache>: Update.

Change-Id: I95044d29da019345d14b5fe8f1671f0f7046fba3
---
gnu/packages/gnome.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2958da2cd9..69212ca0ef 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11344,7 +11344,7 @@ (define-public gnome-video-effects
(define-public cheese
(package
(name "cheese")
- (version "43.0")
+ (version "44.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -11352,7 +11352,7 @@ (define-public cheese
version ".tar.xz"))
(sha256
(base32
- "02vzcvk2s6cwvdw6v6qmlq3znamy6zwv7l6nlbqjfwrj7i54qmvl"))))
+ "13pnz35yvwvmk1iyhcp1a94yal4rh610rxmsp3rdsm4yr728a8az"))))
(arguments
(list #:glib-or-gtk? #t
#:phases
@@ -11360,8 +11360,9 @@ (define-public cheese
(add-after 'unpack 'skip-gtk-update-icon-cache
(lambda _
;; Don't create 'icon-theme.cache'.
- (substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") (which "true")))))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
(add-after 'install 'wrap-cheese
(lambda* (#:key inputs outputs #:allow-other-keys)
(wrap-program (search-input-file outputs "bin/cheese")

base-commit: 72e886328c14c832b2ed71c400069b63852ee18d
--
2.41.0
Liliana Marie Prikler wrote 1 years ago
(address . control@debbugs.gnu.org)
9a6f459f39e1148bc052b8a091ed426659ddc4a3.camel@gmail.com
close 67165 67354 67223 67167 67163 67413 67353 67348
thanks
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67165@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67165
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help