Vivien Kraus wrote 1 years ago
(address . guix-patches@gnu.org)
The build system changed how it disables icon-theme.cache.
* gnu/packages/gnome.scm (cheese): Update to 44.1.
[#:phase 'skip-gtk-update-icon-cache]: Update.
Change-Id: I95044d29da019345d14b5fe8f1671f0f7046fba3
---
gnu/packages/gnome.scm | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
Toggle diff (38 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2958da2cd9..69212ca0ef 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11344,7 +11344,7 @@ (define-public gnome-video-effects
(define-public cheese
(package
(name "cheese")
- (version "43.0")
+ (version "44.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -11352,7 +11352,7 @@ (define-public cheese
version ".tar.xz"))
(sha256
(base32
- "02vzcvk2s6cwvdw6v6qmlq3znamy6zwv7l6nlbqjfwrj7i54qmvl"))))
+ "13pnz35yvwvmk1iyhcp1a94yal4rh610rxmsp3rdsm4yr728a8az"))))
(arguments
(list #:glib-or-gtk? #t
#:phases
@@ -11360,8 +11360,9 @@ (define-public cheese
(add-after 'unpack 'skip-gtk-update-icon-cache
(lambda _
;; Don't create 'icon-theme.cache'.
- (substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") (which "true")))))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
(add-after 'install 'wrap-cheese
(lambda* (#:key inputs outputs #:allow-other-keys)
(wrap-program (search-input-file outputs "bin/cheese")
base-commit: 72e886328c14c832b2ed71c400069b63852ee18d
--
2.41.0