[PATCH] gnu: epiphany: Update to 44.7.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 1 years ago
(address . guix-patches@gnu.org)
300a45bb9a56e9d6dd73cc53b7295cf26981bc75.1699961910.git.vivien@planete-kraus.eu
Soup2 is not supported anymore, we do not need to disable it explicitely.

* gnu/packages/gnome.scm (epiphany): Update to 44.7.
[#:phase 'skip-gtk-update-icon-cache]: Update for build system changes.
[#:phase 'disable-failing-tests]: Partially disable web_view_test.
[#:phase 'pre-check]: Remove.
[#:phase 'check]: Replace with a new phase.
[#:phase 'wrap-epiphany]: New phase.
[#:configure-flags]: Remove soup2.
[native-inputs]: Add bash-minimal.
[inputs]: Replace gcr-3 with gcr and webkitgtk-for-gtk3 with webkitgtk. Add
gstreamer, gst-plugins-base, gst-plugins-good, libadwaita. Remove libdazzle
and libhandy.

Change-Id: I95ab6551a1b38254191801549be9dba0abb04593
---
gnu/packages/gnome.scm | 63 ++++++++++++++++++++++++++++++------------
1 file changed, 46 insertions(+), 17 deletions(-)

Toggle diff (124 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2958da2cd9..5fd98b336d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7095,7 +7095,7 @@ (define-public simple-scan
(define-public epiphany
(package
(name "epiphany")
- (version "42.5")
+ (version "44.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/epiphany/"
@@ -7103,7 +7103,7 @@ (define-public epiphany
"epiphany-" version ".tar.xz"))
(sha256
(base32
- "0mln4iym0fqkri959650cccdhq3r4d4kfn8yld0vvdmzskmak4a6"))))
+ "1srdbn2rls4c0dvrjk0djfmxxnrd012jbji8aavslgkf8cs5mya4"))))
(build-system meson-build-system)
(arguments
(list
@@ -7113,8 +7113,9 @@ (define-public epiphany
(add-after 'unpack 'skip-gtk-update-icon-cache
;; Don't create 'icon-theme.cache'.
(lambda _
- (substitute* "post_install.py"
- (("gtk-update-icon-cache") "true"))))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
(add-after 'unpack 'disable-failing-tests
(lambda _
(substitute* "tests/meson.build"
@@ -7122,20 +7123,46 @@ (define-public epiphany
;; supports overriding the ftp schema web_app_utils fails due
;; to missing network access.
(("(embed_shell|web_app_utils)_test,")
- "find_program('sh'), args: ['-c', 'exit 77'],"))))
- (add-before 'check 'pre-check
- (lambda _
- ;; Tests require a running X server.
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1"))))
+ "find_program('sh'), args: ['-c', 'exit 77'],")
+ ;; web_view_test partially fails, because it can’t run bwrap.
+ (("web_view_test,")
+ (string-append
+ "web_view_test, args: ["
+ (string-join
+ (map (lambda (test)
+ (string-append "'-s', '/embed/ephy-web-view/" test "'"))
+ '("load_url"
+ "provisional_load_failure_updates_back_forward_list"
+ "error-pages-not-stored-in-history"))
+ ", ")
+ "],")))))
+ (replace 'check
+ (lambda* (#:key parallel-tests? tests? #:allow-other-keys)
+ (when tests?
+ (setenv "MESON_TESTTHREADS"
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1"))
+ (setenv "XDG_CACHE_HOME" (getcwd))
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ (invoke "dbus-run-session" "--"
+ "meson" "test" "--print-errorlogs" "-t" "0"))))
+ (add-after 'install 'wrap-epiphany
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program (string-append out "/bin/epiphany")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path)))))))
#:configure-flags
;; Otherwise, the RUNPATH will lack the final 'epiphany' path component.
#~(list (string-append "-Dc_link_args=-Wl,-rpath="
- #$output "/lib/epiphany")
- "-Dsoup2=disabled"))) ;use libsoup 3
+ #$output "/lib/epiphany"))))
(propagated-inputs (list dconf))
(native-inputs
- (list desktop-file-utils ; for update-desktop-database
+ (list bash-minimal ; for wrap-program
+ desktop-file-utils ; for update-desktop-database
gettext-minimal
`(,glib "bin") ; for glib-mkenums
itstool
@@ -7144,15 +7171,17 @@ (define-public epiphany
xorg-server-for-tests))
(inputs
(list avahi
- gcr-3
+ gcr
glib-networking
gnome-desktop
gsettings-desktop-schemas
+ gst-plugins-base
+ gst-plugins-good
+ gstreamer
iso-codes
json-glib
+ libadwaita
libarchive
- libdazzle
- libhandy
libnotify
libportal
(librsvg-for-system) ; for loading SVG files
@@ -7161,7 +7190,7 @@ (define-public epiphany
libxslt
nettle ; for hogweed
sqlite
- webkitgtk-for-gtk3))
+ webkitgtk))
(home-page "https://wiki.gnome.org/Apps/Web")
(synopsis "GNOME web browser")
(description

base-commit: 72e886328c14c832b2ed71c400069b63852ee18d
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v2] gnu: epiphany: Update to 44.7.
(address . 67162@debbugs.gnu.org)
400a45bb9a56e9d6dd73cc53b7295cf26981bc75.1699961910.git.vivien@planete-kraus.eu
Soup2 is not supported anymore, we do not need to disable it explicitely.

* gnu/packages/gnome.scm (epiphany): Update to 44.7.
[#:phase 'skip-gtk-update-icon-cache]: Update for build system changes.
[#:phase 'disable-failing-tests]: Partially disable web_view_test.
[#:phase 'pre-check]: Remove.
[#:phase 'check]: Replace with a new phase.
[#:phase 'wrap-epiphany]: New phase.
[#:configure-flags]: Remove soup2.
[native-inputs]: Add bash-minimal.
[inputs]: Replace gcr-3 with gcr and webkitgtk-for-gtk3 with webkitgtk. Add
gstreamer, gst-plugins-base, gst-plugins-good, libadwaita. Remove libdazzle
and libhandy.

Change-Id: I95ab6551a1b38254191801549be9dba0abb04593
---
gnu/packages/gnome.scm | 63 ++++++++++++++++++++++++++++++------------
1 file changed, 46 insertions(+), 17 deletions(-)

Toggle diff (124 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2958da2cd9..5fd98b336d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7095,7 +7095,7 @@ (define-public simple-scan
(define-public epiphany
(package
(name "epiphany")
- (version "42.5")
+ (version "44.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/epiphany/"
@@ -7103,7 +7103,7 @@ (define-public epiphany
"epiphany-" version ".tar.xz"))
(sha256
(base32
- "0mln4iym0fqkri959650cccdhq3r4d4kfn8yld0vvdmzskmak4a6"))))
+ "1srdbn2rls4c0dvrjk0djfmxxnrd012jbji8aavslgkf8cs5mya4"))))
(build-system meson-build-system)
(arguments
(list
@@ -7113,8 +7113,9 @@ (define-public epiphany
(add-after 'unpack 'skip-gtk-update-icon-cache
;; Don't create 'icon-theme.cache'.
(lambda _
- (substitute* "post_install.py"
- (("gtk-update-icon-cache") "true"))))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
(add-after 'unpack 'disable-failing-tests
(lambda _
(substitute* "tests/meson.build"
@@ -7122,20 +7123,46 @@ (define-public epiphany
;; supports overriding the ftp schema web_app_utils fails due
;; to missing network access.
(("(embed_shell|web_app_utils)_test,")
- "find_program('sh'), args: ['-c', 'exit 77'],"))))
- (add-before 'check 'pre-check
- (lambda _
- ;; Tests require a running X server.
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1"))))
+ "find_program('sh'), args: ['-c', 'exit 77'],")
+ ;; web_view_test partially fails, because it can’t run bwrap.
+ (("web_view_test,")
+ (string-append
+ "web_view_test, args: ["
+ (string-join
+ (map (lambda (test)
+ (string-append "'-s', '/embed/ephy-web-view/" test "'"))
+ '("load_url"
+ "provisional_load_failure_updates_back_forward_list"
+ "error-pages-not-stored-in-history"))
+ ", ")
+ "],")))))
+ (replace 'check
+ (lambda* (#:key parallel-tests? tests? #:allow-other-keys)
+ (when tests?
+ (setenv "MESON_TESTTHREADS"
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1"))
+ (setenv "XDG_CACHE_HOME" (getcwd))
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ (invoke "dbus-run-session" "--"
+ "meson" "test" "--print-errorlogs" "-t" "0"))))
+ (add-after 'install 'wrap-epiphany
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program (string-append out "/bin/epiphany")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path)))))))
#:configure-flags
;; Otherwise, the RUNPATH will lack the final 'epiphany' path component.
#~(list (string-append "-Dc_link_args=-Wl,-rpath="
- #$output "/lib/epiphany")
- "-Dsoup2=disabled"))) ;use libsoup 3
+ #$output "/lib/epiphany"))))
(propagated-inputs (list dconf))
(native-inputs
- (list desktop-file-utils ; for update-desktop-database
+ (list bash-minimal ; for wrap-program
+ desktop-file-utils ; for update-desktop-database
gettext-minimal
`(,glib "bin") ; for glib-mkenums
itstool
@@ -7144,15 +7171,17 @@ (define-public epiphany
xorg-server-for-tests))
(inputs
(list avahi
- gcr-3
+ gcr
glib-networking
gnome-desktop
gsettings-desktop-schemas
+ gst-plugins-base
+ gst-plugins-good
+ gstreamer
iso-codes
json-glib
+ libadwaita
libarchive
- libdazzle
- libhandy
libnotify
libportal
(librsvg-for-system) ; for loading SVG files
@@ -7161,7 +7190,7 @@ (define-public epiphany
libxslt
nettle ; for hogweed
sqlite
- webkitgtk-for-gtk3))
+ webkitgtk))
(home-page "https://wiki.gnome.org/Apps/Web")
(synopsis "GNOME web browser")
(description

base-commit: 72e886328c14c832b2ed71c400069b63852ee18d
--
2.41.0
Liliana Marie Prikler wrote 1 years ago
cf23b564ce5f7c77618b0b7a0c2f67bb6c48e164.camel@gmail.com
Am Dienstag, dem 14.11.2023 um 12:03 +0100 schrieb Vivien Kraus:
Toggle quote (110 lines)
> Soup2 is not supported anymore, we do not need to disable it
> explicitely.
>
> * gnu/packages/gnome.scm (epiphany): Update to 44.7.
> [#:phase 'skip-gtk-update-icon-cache]: Update for build system
> changes.
> [#:phase 'disable-failing-tests]: Partially disable web_view_test.
> [#:phase 'pre-check]: Remove.
> [#:phase 'check]: Replace with a new phase.
> [#:phase 'wrap-epiphany]: New phase.
> [#:configure-flags]: Remove soup2.
> [native-inputs]: Add bash-minimal.
> [inputs]: Replace gcr-3 with gcr and webkitgtk-for-gtk3 with
> webkitgtk.  Add
> gstreamer, gst-plugins-base, gst-plugins-good, libadwaita.  Remove
> libdazzle
> and libhandy.
>
> Change-Id: I95ab6551a1b38254191801549be9dba0abb04593
> ---
>  gnu/packages/gnome.scm | 63 ++++++++++++++++++++++++++++++----------
> --
>  1 file changed, 46 insertions(+), 17 deletions(-)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 2958da2cd9..5fd98b336d 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -7095,7 +7095,7 @@ (define-public simple-scan
>  (define-public epiphany
>    (package
>      (name "epiphany")
> -    (version "42.5")
> +    (version "44.7")
>      (source (origin
>                (method url-fetch)
>                (uri (string-append "mirror://gnome/sources/epiphany/"
> @@ -7103,7 +7103,7 @@ (define-public epiphany
>                                    "epiphany-" version ".tar.xz"))
>                (sha256
>                 (base32
> -               
> "0mln4iym0fqkri959650cccdhq3r4d4kfn8yld0vvdmzskmak4a6"))))
> +               
> "1srdbn2rls4c0dvrjk0djfmxxnrd012jbji8aavslgkf8cs5mya4"))))
>      (build-system meson-build-system)
>      (arguments
>       (list
> @@ -7113,8 +7113,9 @@ (define-public epiphany
>            (add-after 'unpack 'skip-gtk-update-icon-cache
>              ;; Don't create 'icon-theme.cache'.
>              (lambda _
> -              (substitute* "post_install.py"
> -                (("gtk-update-icon-cache") "true"))))
> +              (substitute* "meson.build"
> +                (("gtk_update_icon_cache: true")
> +                 "gtk_update_icon_cache: false"))))
>            (add-after 'unpack 'disable-failing-tests
>              (lambda _
>                (substitute* "tests/meson.build"
> @@ -7122,20 +7123,46 @@ (define-public epiphany
>                  ;; supports overriding the ftp schema web_app_utils
> fails due
>                  ;; to missing network access.
>                  (("(embed_shell|web_app_utils)_test,")
> -                 "find_program('sh'), args: ['-c', 'exit 77'],"))))
> -          (add-before 'check 'pre-check
> -            (lambda _
> -              ;; Tests require a running X server.
> -              (system "Xvfb :1 &")
> -              (setenv "DISPLAY" ":1"))))
> +                 "find_program('sh'), args: ['-c', 'exit 77'],")
> +                ;; web_view_test partially fails, because it can’t
> run bwrap.
> +                (("web_view_test,")
> +                 (string-append
> +                  "web_view_test, args: ["
> +                  (string-join
> +                   (map (lambda (test)
> +                          (string-append "'-s', '/embed/ephy-web-
> view/" test "'"))
> +                        '("load_url"
> +                         
> "provisional_load_failure_updates_back_forward_list"
> +                          "error-pages-not-stored-in-history"))
> +                   ", ")
> +                  "],")))))
> +          (replace 'check
> +            (lambda* (#:key parallel-tests? tests? #:allow-other-
> keys)
> +              (when tests?
> +                (setenv "MESON_TESTTHREADS"
> +                        (if parallel-tests?
> +                            (number->string (parallel-job-count))
> +                            "1"))
> +                (setenv "XDG_CACHE_HOME" (getcwd))
> +                ;; Tests require a running X server.
> +                (system "Xvfb :1 &")
> +                (setenv "DISPLAY" ":1")
> +                (invoke "dbus-run-session" "--"
> +                        "meson" "test" "--print-errorlogs" "-t"
> "0"))))
> +         (add-after 'install 'wrap-epiphany
> +           (lambda* (#:key inputs outputs #:allow-other-keys)
> +             (let ((out             (assoc-ref outputs "out"))
> +                   (gst-plugin-path (getenv
> "GST_PLUGIN_SYSTEM_PATH")))
> +               (wrap-program (string-append out "/bin/epiphany")
> +                 `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-
> path)))))))
In this case it appears harmless, but I prefer suffix wraps for
GStreamer, as they allow user plugins (which use the same variable) to
be prepended.
There are some phases that already add GST_PLUGIN_SYSTEM_PATH to
inspire naming, but analogous to glib-or-gtk-wrap, we should probably
name this gst-wrap.
Toggle quote (29 lines)
>        #:configure-flags
>        ;; Otherwise, the RUNPATH will lack the final 'epiphany' path
> component.
>        #~(list (string-append "-Dc_link_args=-Wl,-rpath="
> -                             #$output "/lib/epiphany")
> -              "-Dsoup2=disabled")))     ;use libsoup 3
> +                             #$output "/lib/epiphany"))))
>      (propagated-inputs (list dconf))
>      (native-inputs
> -     (list desktop-file-utils           ; for update-desktop-
> database
> +     (list bash-minimal                 ; for wrap-program
> +           desktop-file-utils           ; for update-desktop-
> database
>             gettext-minimal
>             `(,glib "bin")               ; for glib-mkenums
>             itstool
> @@ -7144,15 +7171,17 @@ (define-public epiphany
>             xorg-server-for-tests))
>      (inputs
>       (list avahi
> -           gcr-3
> +           gcr
>             glib-networking
>             gnome-desktop
>             gsettings-desktop-schemas
> +           gst-plugins-base
> +           gst-plugins-good
> +           gstreamer
Any reason why those now became necessary? You might have to split
this into two parts if it's not related to the update.
Toggle quote (20 lines)
>             iso-codes
>             json-glib
> +           libadwaita
>             libarchive
> -           libdazzle
> -           libhandy
>             libnotify
>             libportal
>             (librsvg-for-system)         ; for loading SVG files
> @@ -7161,7 +7190,7 @@ (define-public epiphany
>             libxslt
>             nettle                       ; for hogweed
>             sqlite
> -           webkitgtk-for-gtk3))
> +           webkitgtk))
>      (home-page "https://wiki.gnome.org/Apps/Web")
>      (synopsis "GNOME web browser")
>      (description
>
> base-commit: 72e886328c14c832b2ed71c400069b63852ee18d
Cheers
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v3] gnu: epiphany: Update to 44.7.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
ea83c972678418372f138e28859f0212c70d1751.1700116779.git.vivien@planete-kraus.eu
Soup2 is not supported anymore, we do not need to disable it explicitely.

* gnu/packages/gnome.scm (epiphany): Update to 44.7.
[#:phases]<skip-gtk-update-icon-cache>: Update for build system changes.
<disable-failing-tests>: Partially disable web_view_test.
<pre-check>: Remove.
<check>: Replace with a new phase.
<wrap-epiphany>: New phase.
[#:configure-flags]: Remove soup2.
[native-inputs]: Add bash-minimal.
[inputs]: Replace gcr-3 with gcr and webkitgtk-for-gtk3 with webkitgtk. Add
gstreamer, gst-plugins-base, gst-plugins-good, libadwaita. Remove libdazzle
and libhandy.

Change-Id: I95ab6551a1b38254191801549be9dba0abb04593
---

The new gstreamer dependency is actually checked at configure time.

gnu/packages/gnome.scm | 63 ++++++++++++++++++++++++++++++------------
1 file changed, 46 insertions(+), 17 deletions(-)

Toggle diff (124 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2958da2cd9..0837edc360 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7095,7 +7095,7 @@ (define-public simple-scan
(define-public epiphany
(package
(name "epiphany")
- (version "42.5")
+ (version "44.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/epiphany/"
@@ -7103,7 +7103,7 @@ (define-public epiphany
"epiphany-" version ".tar.xz"))
(sha256
(base32
- "0mln4iym0fqkri959650cccdhq3r4d4kfn8yld0vvdmzskmak4a6"))))
+ "1srdbn2rls4c0dvrjk0djfmxxnrd012jbji8aavslgkf8cs5mya4"))))
(build-system meson-build-system)
(arguments
(list
@@ -7113,8 +7113,9 @@ (define-public epiphany
(add-after 'unpack 'skip-gtk-update-icon-cache
;; Don't create 'icon-theme.cache'.
(lambda _
- (substitute* "post_install.py"
- (("gtk-update-icon-cache") "true"))))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
(add-after 'unpack 'disable-failing-tests
(lambda _
(substitute* "tests/meson.build"
@@ -7122,20 +7123,46 @@ (define-public epiphany
;; supports overriding the ftp schema web_app_utils fails due
;; to missing network access.
(("(embed_shell|web_app_utils)_test,")
- "find_program('sh'), args: ['-c', 'exit 77'],"))))
- (add-before 'check 'pre-check
- (lambda _
- ;; Tests require a running X server.
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1"))))
+ "find_program('sh'), args: ['-c', 'exit 77'],")
+ ;; web_view_test partially fails, because it can’t run bwrap.
+ (("web_view_test,")
+ (string-append
+ "web_view_test, args: ["
+ (string-join
+ (map (lambda (test)
+ (string-append "'-s', '/embed/ephy-web-view/" test "'"))
+ '("load_url"
+ "provisional_load_failure_updates_back_forward_list"
+ "error-pages-not-stored-in-history"))
+ ", ")
+ "],")))))
+ (replace 'check
+ (lambda* (#:key parallel-tests? tests? #:allow-other-keys)
+ (when tests?
+ (setenv "MESON_TESTTHREADS"
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1"))
+ (setenv "XDG_CACHE_HOME" (getcwd))
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ (invoke "dbus-run-session" "--"
+ "meson" "test" "--print-errorlogs" "-t" "0"))))
+ (add-after 'install 'gst-wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program (string-append out "/bin/epiphany")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" suffix (,gst-plugin-path)))))))
#:configure-flags
;; Otherwise, the RUNPATH will lack the final 'epiphany' path component.
#~(list (string-append "-Dc_link_args=-Wl,-rpath="
- #$output "/lib/epiphany")
- "-Dsoup2=disabled"))) ;use libsoup 3
+ #$output "/lib/epiphany"))))
(propagated-inputs (list dconf))
(native-inputs
- (list desktop-file-utils ; for update-desktop-database
+ (list bash-minimal ; for wrap-program
+ desktop-file-utils ; for update-desktop-database
gettext-minimal
`(,glib "bin") ; for glib-mkenums
itstool
@@ -7144,15 +7171,17 @@ (define-public epiphany
xorg-server-for-tests))
(inputs
(list avahi
- gcr-3
+ gcr
glib-networking
gnome-desktop
gsettings-desktop-schemas
+ gst-plugins-base
+ gst-plugins-good
+ gstreamer
iso-codes
json-glib
+ libadwaita
libarchive
- libdazzle
- libhandy
libnotify
libportal
(librsvg-for-system) ; for loading SVG files
@@ -7161,7 +7190,7 @@ (define-public epiphany
libxslt
nettle ; for hogweed
sqlite
- webkitgtk-for-gtk3))
+ webkitgtk))
(home-page "https://wiki.gnome.org/Apps/Web")
(synopsis "GNOME web browser")
(description

base-commit: 72e886328c14c832b2ed71c400069b63852ee18d
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v4] gnu: epiphany: Update to 44.7.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
a2714ee58716e146c2d3b8432f1d9b0784cb6267.1700117446.git.vivien@planete-kraus.eu
Soup2 is not supported anymore, we do not need to disable it explicitely.

* gnu/packages/gnome.scm (epiphany): Update to 44.7.
[#:phases]<skip-gtk-update-icon-cache>: Update for build system changes.
<disable-failing-tests>: Partially disable web_view_test.
<pre-check>: Remove.
<check>: Replace with a new phase.
<wrap-epiphany>: New phase.
[#:configure-flags]: Remove soup2.
[inputs]: Replace gcr-3 with gcr and webkitgtk-for-gtk3 with webkitgtk. Add
bash-minimal, gstreamer, gst-plugins-base, gst-plugins-good, libadwaita.
Remove libdazzle and libhandy.

Change-Id: I95ab6551a1b38254191801549be9dba0abb04593
---
Sorry for the noise, I had to fix a lint issue.

Vivien

gnu/packages/gnome.scm | 61 +++++++++++++++++++++++++++++++-----------
1 file changed, 45 insertions(+), 16 deletions(-)

Toggle diff (120 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2958da2cd9..92648810eb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7095,7 +7095,7 @@ (define-public simple-scan
(define-public epiphany
(package
(name "epiphany")
- (version "42.5")
+ (version "44.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/epiphany/"
@@ -7103,7 +7103,7 @@ (define-public epiphany
"epiphany-" version ".tar.xz"))
(sha256
(base32
- "0mln4iym0fqkri959650cccdhq3r4d4kfn8yld0vvdmzskmak4a6"))))
+ "1srdbn2rls4c0dvrjk0djfmxxnrd012jbji8aavslgkf8cs5mya4"))))
(build-system meson-build-system)
(arguments
(list
@@ -7113,8 +7113,9 @@ (define-public epiphany
(add-after 'unpack 'skip-gtk-update-icon-cache
;; Don't create 'icon-theme.cache'.
(lambda _
- (substitute* "post_install.py"
- (("gtk-update-icon-cache") "true"))))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
(add-after 'unpack 'disable-failing-tests
(lambda _
(substitute* "tests/meson.build"
@@ -7122,17 +7123,42 @@ (define-public epiphany
;; supports overriding the ftp schema web_app_utils fails due
;; to missing network access.
(("(embed_shell|web_app_utils)_test,")
- "find_program('sh'), args: ['-c', 'exit 77'],"))))
- (add-before 'check 'pre-check
- (lambda _
- ;; Tests require a running X server.
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1"))))
+ "find_program('sh'), args: ['-c', 'exit 77'],")
+ ;; web_view_test partially fails, because it can’t run bwrap.
+ (("web_view_test,")
+ (string-append
+ "web_view_test, args: ["
+ (string-join
+ (map (lambda (test)
+ (string-append "'-s', '/embed/ephy-web-view/" test "'"))
+ '("load_url"
+ "provisional_load_failure_updates_back_forward_list"
+ "error-pages-not-stored-in-history"))
+ ", ")
+ "],")))))
+ (replace 'check
+ (lambda* (#:key parallel-tests? tests? #:allow-other-keys)
+ (when tests?
+ (setenv "MESON_TESTTHREADS"
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1"))
+ (setenv "XDG_CACHE_HOME" (getcwd))
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ (invoke "dbus-run-session" "--"
+ "meson" "test" "--print-errorlogs" "-t" "0"))))
+ (add-after 'install 'gst-wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program (string-append out "/bin/epiphany")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" suffix (,gst-plugin-path)))))))
#:configure-flags
;; Otherwise, the RUNPATH will lack the final 'epiphany' path component.
#~(list (string-append "-Dc_link_args=-Wl,-rpath="
- #$output "/lib/epiphany")
- "-Dsoup2=disabled"))) ;use libsoup 3
+ #$output "/lib/epiphany"))))
(propagated-inputs (list dconf))
(native-inputs
(list desktop-file-utils ; for update-desktop-database
@@ -7144,15 +7170,18 @@ (define-public epiphany
xorg-server-for-tests))
(inputs
(list avahi
- gcr-3
+ bash-minimal ; for wrap-program
+ gcr
glib-networking
gnome-desktop
gsettings-desktop-schemas
+ gst-plugins-base
+ gst-plugins-good
+ gstreamer
iso-codes
json-glib
+ libadwaita
libarchive
- libdazzle
- libhandy
libnotify
libportal
(librsvg-for-system) ; for loading SVG files
@@ -7161,7 +7190,7 @@ (define-public epiphany
libxslt
nettle ; for hogweed
sqlite
- webkitgtk-for-gtk3))
+ webkitgtk))
(home-page "https://wiki.gnome.org/Apps/Web")
(synopsis "GNOME web browser")
(description

base-commit: 72e886328c14c832b2ed71c400069b63852ee18d
--
2.41.0
Liliana Marie Prikler wrote 1 years ago
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)
c48a5a88b9ae5be08f8abe116e6e0e9d3d9e97ad.camel@gmail.com
Am Dienstag, dem 14.11.2023 um 12:03 +0100 schrieb Vivien Kraus:
Toggle quote (16 lines)
> Soup2 is not supported anymore, we do not need to disable it
> explicitely.
>
> * gnu/packages/gnome.scm (epiphany): Update to 44.7.
> [#:phases]<skip-gtk-update-icon-cache>: Update for build system
> changes.
> <disable-failing-tests>: Partially disable web_view_test.
> <pre-check>: Remove.
> <check>: Replace with a new phase.
> <wrap-epiphany>: New phase.
> [#:configure-flags]: Remove soup2.
> [inputs]: Replace gcr-3 with gcr and webkitgtk-for-gtk3 with
> webkitgtk.  Add
> bash-minimal, gstreamer, gst-plugins-base, gst-plugins-good,
> libadwaita.
> Remove libdazzle and libhandy.
Don't forget to update your ChangeLogs :)
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v5] gnu: epiphany: Update to 44.7.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
a6c73c9aca5fde8c218a0c41a78a68f86c6d0fdc.1700167242.git.vivien@planete-kraus.eu
Soup2 is not supported anymore, we do not need to disable it explicitely.

* gnu/packages/gnome.scm (epiphany): Update to 44.7.
[#:phases]<skip-gtk-update-icon-cache>: Update for build system changes.
<disable-failing-tests>: Partially disable web_view_test.
<pre-check>: Remove.
<check>: Replace with a new phase.
<gst-wrap>: New phase.
[#:configure-flags]: Remove soup2.
[inputs]: Replace gcr-3 with gcr and webkitgtk-for-gtk3 with webkitgtk. Add
bash-minimal, gstreamer, gst-plugins-base, gst-plugins-good, libadwaita.
Remove libdazzle and libhandy.

Change-Id: I95ab6551a1b38254191801549be9dba0abb04593
---

Right, I forgot to rename my wrapping phase in the commit message, sorry!

Thanks for pointing it out.

Best regards,

Vivien

gnu/packages/gnome.scm | 61 +++++++++++++++++++++++++++++++-----------
1 file changed, 45 insertions(+), 16 deletions(-)

Toggle diff (120 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2958da2cd9..92648810eb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7095,7 +7095,7 @@ (define-public simple-scan
(define-public epiphany
(package
(name "epiphany")
- (version "42.5")
+ (version "44.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/epiphany/"
@@ -7103,7 +7103,7 @@ (define-public epiphany
"epiphany-" version ".tar.xz"))
(sha256
(base32
- "0mln4iym0fqkri959650cccdhq3r4d4kfn8yld0vvdmzskmak4a6"))))
+ "1srdbn2rls4c0dvrjk0djfmxxnrd012jbji8aavslgkf8cs5mya4"))))
(build-system meson-build-system)
(arguments
(list
@@ -7113,8 +7113,9 @@ (define-public epiphany
(add-after 'unpack 'skip-gtk-update-icon-cache
;; Don't create 'icon-theme.cache'.
(lambda _
- (substitute* "post_install.py"
- (("gtk-update-icon-cache") "true"))))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
(add-after 'unpack 'disable-failing-tests
(lambda _
(substitute* "tests/meson.build"
@@ -7122,17 +7123,42 @@ (define-public epiphany
;; supports overriding the ftp schema web_app_utils fails due
;; to missing network access.
(("(embed_shell|web_app_utils)_test,")
- "find_program('sh'), args: ['-c', 'exit 77'],"))))
- (add-before 'check 'pre-check
- (lambda _
- ;; Tests require a running X server.
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1"))))
+ "find_program('sh'), args: ['-c', 'exit 77'],")
+ ;; web_view_test partially fails, because it can’t run bwrap.
+ (("web_view_test,")
+ (string-append
+ "web_view_test, args: ["
+ (string-join
+ (map (lambda (test)
+ (string-append "'-s', '/embed/ephy-web-view/" test "'"))
+ '("load_url"
+ "provisional_load_failure_updates_back_forward_list"
+ "error-pages-not-stored-in-history"))
+ ", ")
+ "],")))))
+ (replace 'check
+ (lambda* (#:key parallel-tests? tests? #:allow-other-keys)
+ (when tests?
+ (setenv "MESON_TESTTHREADS"
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1"))
+ (setenv "XDG_CACHE_HOME" (getcwd))
+ ;; Tests require a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ (invoke "dbus-run-session" "--"
+ "meson" "test" "--print-errorlogs" "-t" "0"))))
+ (add-after 'install 'gst-wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program (string-append out "/bin/epiphany")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" suffix (,gst-plugin-path)))))))
#:configure-flags
;; Otherwise, the RUNPATH will lack the final 'epiphany' path component.
#~(list (string-append "-Dc_link_args=-Wl,-rpath="
- #$output "/lib/epiphany")
- "-Dsoup2=disabled"))) ;use libsoup 3
+ #$output "/lib/epiphany"))))
(propagated-inputs (list dconf))
(native-inputs
(list desktop-file-utils ; for update-desktop-database
@@ -7144,15 +7170,18 @@ (define-public epiphany
xorg-server-for-tests))
(inputs
(list avahi
- gcr-3
+ bash-minimal ; for wrap-program
+ gcr
glib-networking
gnome-desktop
gsettings-desktop-schemas
+ gst-plugins-base
+ gst-plugins-good
+ gstreamer
iso-codes
json-glib
+ libadwaita
libarchive
- libdazzle
- libhandy
libnotify
libportal
(librsvg-for-system) ; for loading SVG files
@@ -7161,7 +7190,7 @@ (define-public epiphany
libxslt
nettle ; for hogweed
sqlite
- webkitgtk-for-gtk3))
+ webkitgtk))
(home-page "https://wiki.gnome.org/Apps/Web")
(synopsis "GNOME web browser")
(description

base-commit: 72e886328c14c832b2ed71c400069b63852ee18d
--
2.41.0
Liliana Marie Prikler wrote 1 years ago
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)
b546f0f4bcc284fa52cc2d78b1bad8bb5d21f982.camel@gmail.com
Am Dienstag, dem 14.11.2023 um 12:03 +0100 schrieb Vivien Kraus:
Toggle quote (19 lines)
> Soup2 is not supported anymore, we do not need to disable it
> explicitely.
>
> * gnu/packages/gnome.scm (epiphany): Update to 44.7.
> [#:phases]<skip-gtk-update-icon-cache>: Update for build system
> changes.
> <disable-failing-tests>: Partially disable web_view_test.
> <pre-check>: Remove.
> <check>: Replace with a new phase.
> <gst-wrap>: New phase.
> [#:configure-flags]: Remove soup2.
> [inputs]: Replace gcr-3 with gcr and webkitgtk-for-gtk3 with
> webkitgtk.  Add
> bash-minimal, gstreamer, gst-plugins-base, gst-plugins-good,
> libadwaita.
> Remove libdazzle and libhandy.
>
> Change-Id: I95ab6551a1b38254191801549be9dba0abb04593
> ---
Pushed at last, with only minor changes to the commit message.

Sorry for taking so long.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67162@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67162
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help