(address . bug-guix@gnu.org)
Hi, I am new Guix user.
So far, I've been using Guix to create one-of environments with
different versions of GCC and clang. My first goal is to compile a C++
project with different compiler versions and to check that everything is
ok. For instance:
guix shell gcc-toolchain@13
It works great, except for GCC 4.8.5 (the oldest version I aim to
support for my C++ project). That version seems to be the only
gcc-toolchain version not available on the official substitute servers
(need to compile/build), and compilation fails on my machine.
Is the absence of a x86-64 GNU Linux GCC 4.8.5 build deliberate? I can
imagine that this old version is not a priority anymore. Nonetheless, it
is still very frequent in the wild, at least until the end-of-support of
CentOS 7 next year.
Thanks for your help,
Here are the command used and the complete log:
guix shell gcc-toolchain@4.8
hint: Consider passing the `--check' option once to make sure your shell
does not clobber environment variables.
The following derivations will be built:
/gnu/store/3rh345dldg1r19mx6rwdx5nzskz5ixv4-gcc-toolchain-4.8.5.drv
/gnu/store/4y2s5l1hhdvxzws1s0gshb5jdf7rl1gr-gcc-4.8.5.drv
building /gnu/store/4y2s5l1hhdvxzws1s0gshb5jdf7rl1gr-gcc-4.8.5.drv...
| 'build' phase?@ build-log 346394 4096
? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_ISLESSEQUAL? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_ISLESSGREATER? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_ISUNORDERED? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_LABS? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_LLABS? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_LONGJMP? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_MALLOC? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_NEXT_ARG? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_PARITY? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_PARITYIMAX? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_PARITYL? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_PARITYLL? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_POPCOUNT? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_POPCOUNTIMAX? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_POPCOUNTL? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_POPCOUNTLL? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_PREFETCH? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_REALLOC? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_RETURN? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_RETURN_ADDRESS? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SAVEREGS? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SETJMP? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STRFMON? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STRFTIME? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_TRAP? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_UNREACHABLE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_UNWIND_INIT? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_UPDATE_SETJMP_BUF? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VA_COPY? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VA_END? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VA_START? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VA_ARG_PACK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VA_ARG_PACK_LEN? not handle@ build-log 346394 4096
d in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN__EXIT? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN__EXIT2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_INIT_TRAMPOLINE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_INIT_HEAP_TRAMPOLINE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_ADJUST_TRAMPOLINE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_NONLOCAL_GOTO? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SETJMP_SETUP? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SETJMP_DISPATCHER? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SETJMP_RECEIVER? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STACK_SAVE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STACK_RESTORE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_ALLOCA_WITH_ALIGN? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_OBJECT_SIZE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_MEMCPY_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_MEMMOVE_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_MEMPCPY_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_MEMSET_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STPCPY_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STPNCPY_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STRCAT_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STRCPY_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STRNCAT_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STRNCPY_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SNPRINTF_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SPRINTF_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VSNPRINTF_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VSPRINTF_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_FPRINTF_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_PRINTF_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VFPRINTF_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VPRINTF_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_PROFILE_FUNC_ENTER? not handled in switch [-Wswitch]
../../g@ build-log 346394 4096
cc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_PROFILE_FUNC_EXIT? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_THREAD_POINTER? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SET_THREAD_POINTER? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_EMUTLS_GET_ADDRESS? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_EMUTLS_REGISTER_COMMON? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_UNWIND_RESUME? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_CXA_END_CLEANUP? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_EH_POINTER? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_EH_FILTER? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_EH_COPY_VALUES? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_FILE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_FUNCTION? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_LINE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_ADD_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_ADD_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_ADD_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_ADD_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_ADD_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_ADD_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_SUB_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_SUB_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_SUB_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_SUB_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_SUB_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_SUB_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_OR_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_OR_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_OR_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_OR_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_OR_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_OR_16? not handled in switch [-Wswitch]
../../gcc-4.8.5@ build-log 346394 4096
/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_AND_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_AND_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_AND_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_AND_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_AND_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_AND_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_XOR_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_XOR_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_XOR_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_XOR_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_XOR_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_XOR_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_NAND_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_NAND_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_NAND_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_NAND_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_NAND_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_NAND_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_ADD_AND_FETCH_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_ADD_AND_FETCH_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_ADD_AND_FETCH_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_ADD_AND_FETCH_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_ADD_AND_FETCH_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_ADD_AND_FETCH_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_SUB_AND_FETCH_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_SUB_AND_FETCH_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_SUB_AND_FETCH_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_SUB_AND_FETCH_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_SUB_AND_FETCH_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_SUB_AND_FETCH_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: en@ build-log 346394 4096
umeration value ?BUILT_IN_SYNC_OR_AND_FETCH_N? not handled in switch
[-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_OR_AND_FETCH_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_OR_AND_FETCH_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_OR_AND_FETCH_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_OR_AND_FETCH_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_OR_AND_FETCH_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_AND_AND_FETCH_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_AND_AND_FETCH_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_AND_AND_FETCH_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_AND_AND_FETCH_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_AND_AND_FETCH_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_AND_AND_FETCH_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_XOR_AND_FETCH_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_XOR_AND_FETCH_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_XOR_AND_FETCH_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_XOR_AND_FETCH_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_XOR_AND_FETCH_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_XOR_AND_FETCH_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_NAND_AND_FETCH_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_NAND_AND_FETCH_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gc
This message was truncated. Download the full message here.