gcc-toolchain@4.8.5 not available on the official substitute servers

  • Open
  • quality assurance status badge
Details
3 participants
  • Frédéric Mahé
  • Thomas Schwinge
  • Simon Tournier
Owner
unassigned
Submitted by
Frédéric Mahé
Severity
normal
F
F
Frédéric Mahé wrote on 13 Nov 2023 20:19
(address . bug-guix@gnu.org)
c2110f92-4338-4562-9c61-414a54547fb8@cirad.fr
Hi, I am new Guix user.

So far, I've been using Guix to create one-of environments with
different versions of GCC and clang. My first goal is to compile a C++
project with different compiler versions and to check that everything is
ok. For instance:

guix shell gcc-toolchain@13

It works great, except for GCC 4.8.5 (the oldest version I aim to
support for my C++ project). That version seems to be the only
gcc-toolchain version not available on the official substitute servers
(need to compile/build), and compilation fails on my machine.

Is the absence of a x86-64 GNU Linux GCC 4.8.5 build deliberate? I can
imagine that this old version is not a priority anymore. Nonetheless, it
is still very frequent in the wild, at least until the end-of-support of
CentOS 7 next year.

Thanks for your help,

Here are the command used and the complete log:

guix shell gcc-toolchain@4.8
hint: Consider passing the `--check' option once to make sure your shell
does not clobber environment variables.

The following derivations will be built:
/gnu/store/3rh345dldg1r19mx6rwdx5nzskz5ixv4-gcc-toolchain-4.8.5.drv
/gnu/store/4y2s5l1hhdvxzws1s0gshb5jdf7rl1gr-gcc-4.8.5.drv

building /gnu/store/4y2s5l1hhdvxzws1s0gshb5jdf7rl1gr-gcc-4.8.5.drv...
| 'build' phase?@ build-log 346394 4096
? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_ISLESSEQUAL? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_ISLESSGREATER? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_ISUNORDERED? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_LABS? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_LLABS? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_LONGJMP? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_MALLOC? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_NEXT_ARG? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_PARITY? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_PARITYIMAX? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_PARITYL? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_PARITYLL? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_POPCOUNT? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_POPCOUNTIMAX? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_POPCOUNTL? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_POPCOUNTLL? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_PREFETCH? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_REALLOC? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_RETURN? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_RETURN_ADDRESS? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SAVEREGS? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SETJMP? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STRFMON? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STRFTIME? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_TRAP? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_UNREACHABLE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_UNWIND_INIT? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_UPDATE_SETJMP_BUF? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VA_COPY? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VA_END? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VA_START? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VA_ARG_PACK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VA_ARG_PACK_LEN? not handle@ build-log 346394 4096
d in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN__EXIT? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN__EXIT2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_INIT_TRAMPOLINE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_INIT_HEAP_TRAMPOLINE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_ADJUST_TRAMPOLINE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_NONLOCAL_GOTO? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SETJMP_SETUP? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SETJMP_DISPATCHER? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SETJMP_RECEIVER? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STACK_SAVE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STACK_RESTORE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_ALLOCA_WITH_ALIGN? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_OBJECT_SIZE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_MEMCPY_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_MEMMOVE_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_MEMPCPY_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_MEMSET_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STPCPY_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STPNCPY_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STRCAT_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STRCPY_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STRNCAT_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_STRNCPY_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SNPRINTF_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SPRINTF_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VSNPRINTF_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VSPRINTF_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_FPRINTF_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_PRINTF_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VFPRINTF_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_VPRINTF_CHK? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_PROFILE_FUNC_ENTER? not handled in switch [-Wswitch]
../../g@ build-log 346394 4096
cc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_PROFILE_FUNC_EXIT? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_THREAD_POINTER? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SET_THREAD_POINTER? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_EMUTLS_GET_ADDRESS? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_EMUTLS_REGISTER_COMMON? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_UNWIND_RESUME? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_CXA_END_CLEANUP? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_EH_POINTER? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_EH_FILTER? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_EH_COPY_VALUES? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_FILE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_FUNCTION? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_LINE? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_ADD_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_ADD_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_ADD_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_ADD_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_ADD_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_ADD_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_SUB_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_SUB_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_SUB_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_SUB_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_SUB_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_SUB_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_OR_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_OR_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_OR_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_OR_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_OR_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_OR_16? not handled in switch [-Wswitch]
../../gcc-4.8.5@ build-log 346394 4096
/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_AND_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_AND_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_AND_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_AND_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_AND_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_AND_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_XOR_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_XOR_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_XOR_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_XOR_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_XOR_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_XOR_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_NAND_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_NAND_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_NAND_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_NAND_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_NAND_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_FETCH_AND_NAND_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_ADD_AND_FETCH_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_ADD_AND_FETCH_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_ADD_AND_FETCH_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_ADD_AND_FETCH_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_ADD_AND_FETCH_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_ADD_AND_FETCH_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_SUB_AND_FETCH_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_SUB_AND_FETCH_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_SUB_AND_FETCH_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_SUB_AND_FETCH_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_SUB_AND_FETCH_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_SUB_AND_FETCH_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: en@ build-log 346394 4096
umeration value ?BUILT_IN_SYNC_OR_AND_FETCH_N? not handled in switch
[-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_OR_AND_FETCH_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_OR_AND_FETCH_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_OR_AND_FETCH_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_OR_AND_FETCH_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_OR_AND_FETCH_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_AND_AND_FETCH_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_AND_AND_FETCH_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_AND_AND_FETCH_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_AND_AND_FETCH_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_AND_AND_FETCH_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_AND_AND_FETCH_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_XOR_AND_FETCH_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_XOR_AND_FETCH_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_XOR_AND_FETCH_2? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_XOR_AND_FETCH_4? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_XOR_AND_FETCH_8? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_XOR_AND_FETCH_16? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_NAND_AND_FETCH_N? not handled in switch [-Wswitch]
../../gcc-4.8.5/gcc/predict.c:1788:20: warning: enumeration value
?BUILT_IN_SYNC_NAND_AND_FETCH_1? not handled in switch [-Wswitch]
../../gcc-4.8.5/gc
This message was truncated. Download the full message here.
S
S
Simon Tournier wrote on 16 Nov 2023 11:25
868r6yvvu9.fsf@gmail.com
Hi,

Thanks for the report.

On Mon, 13 Nov 2023 at 20:19, Frédéric Mahé <frederic.mahe@cirad.fr> wrote:

Toggle quote (5 lines)
> Is the absence of a x86-64 GNU Linux GCC 4.8.5 build deliberate? I can
> imagine that this old version is not a priority anymore. Nonetheless, it
> is still very frequent in the wild, at least until the end-of-support of
> CentOS 7 next year.

No, it is not deliberate, sadly. Well, I have tried to find a past
revision when gcc-toolchain@4.8.5 builds but I fail.

The Guix Data Service shows that gcc-toolchain@4.8.5 is not available
for the build farm named Bordeaux. And the substitutes are also missing
on the other build farm named Berlin.

Well, my guess is the issue is related to an update of GCC. Therefore,
I am trying this commit:

27322ac30be6816eca33ee946a04d3b0ab32896f
CommitDate: Thu Sep 8 21:40:00 2022 +0200

which is right before the update to GCC 11 as default.

guix time-machine --commit=27322ac30be6816eca33ee946a04d3b0ab32896f \
-- build gcc-toolchain@4.8.5 --no-grafts

Wait and see…

Cheers,
simon
T
T
Thomas Schwinge wrote on 18 Jan 20:39 +0100
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87bk9icty3.fsf@euler.schwinge.homeip.net
I ran into the same issue.

On 2023-11-16T11:25:18+0100, Simon Tournier <zimon.toutoune@gmail.com> wrote:
Toggle quote (23 lines)
> On Mon, 13 Nov 2023 at 20:19, Frédéric Mahé <frederic.mahe@cirad.fr> wrote:
>> Is the absence of a x86-64 GNU Linux GCC 4.8.5 build deliberate?

> No, it is not deliberate, sadly. Well, I have tried to find a past
> revision when gcc-toolchain@4.8.5 builds but I fail.
>
> The Guix Data Service shows that gcc-toolchain@4.8.5 is not available
> for the build farm named Bordeaux. And the substitutes are also missing
> on the other build farm named Berlin.
>
> Well, my guess is the issue is related to an update of GCC. Therefore,
> I am trying this commit:
>
> 27322ac30be6816eca33ee946a04d3b0ab32896f
> CommitDate: Thu Sep 8 21:40:00 2022 +0200
>
> which is right before the update to GCC 11 as default.
>
> guix time-machine --commit=27322ac30be6816eca33ee946a04d3b0ab32896f \
> -- build gcc-toolchain@4.8.5 --no-grafts
>
> Wait and see…

I tried this, but after quite a long time, it failed, too. :-|

In file included from ../../gcc-4.8.5/gcc/cp/except.c:1008:
cfns.gperf: At global scope:
cfns.gperf:101:1: error: ‘const char* libc_name_p(const char*, unsigned int)’ redeclared inline with ‘gnu_inline’ attribute
cfns.gperf:26:14: note: ‘const char* libc_name_p(const char*, unsigned int)’ previously declared here

If I'm understanding things right, Ricardo actually has addressed this
issue in commit e6994d7e3f3f4a69f984c9e67df27abe1bc07c1c
"gnu: gcc-arm-none-eabi-4.9: Fix incompatible redeclaration"
('gnu/packages/patches/gcc-4.9-inline.patch'), and similarly a number of
years earlier in commit db90eb8c2bd447ab53bed80e5b0ea5105a928cdf
"gnu: Add propeller-gcc-4" -- both not applied to the GCC 4.8 sources
we're trying to build here. Anyway, putting Ricardo in CC, in case
you've got any input to this one here, too? :-)

The latter commit's 'gnu/packages/patches/gcc-4.6-gnu-inline.patch'
indicates that "the 3.0.3 release of gperf" may be when this started, so
I'll try to invoke the time-machine for older than that, as a first
(hopefully simple) try.
T
T
Thomas Schwinge wrote on 18 Jan 21:03 +0100
87v87qbe9t.fsf@euler.schwinge.homeip.net
On 2024-01-18T20:39:16+0100, I wrote:
Toggle quote (14 lines)
> In file included from ../../gcc-4.8.5/gcc/cp/except.c:1008:
> cfns.gperf: At global scope:
> cfns.gperf:101:1: error: ‘const char* libc_name_p(const char*, unsigned int)’ redeclared inline with ‘gnu_inline’ attribute
> cfns.gperf:26:14: note: ‘const char* libc_name_p(const char*, unsigned int)’ previously declared here
>
> If I'm understanding things right, Ricardo actually has addressed this
> issue in commit e6994d7e3f3f4a69f984c9e67df27abe1bc07c1c
> "gnu: gcc-arm-none-eabi-4.9: Fix incompatible redeclaration"
> ('gnu/packages/patches/gcc-4.9-inline.patch'), and similarly a number of
> years earlier in commit db90eb8c2bd447ab53bed80e5b0ea5105a928cdf
> "gnu: Add propeller-gcc-4" -- both not applied to the GCC 4.8 sources
> we're trying to build here. Anyway, putting Ricardo in CC, in case
> you've got any input to this one here, too? :-)

Actually, also years-old commit 625492ee1a5a8e515b97d4b76734584c1b420243
"gnu: gcc-4.7: Resurrect building with gcc-5.4.0" (Janneke CCed), and
"gcc-4.8 fails to build with recent GCC versions" (Thiago CCed), and
"build failure: gcc-4.8.5 (gcc-toolchain-4.8.5)" (Christopher CCed), for
example.

"GCC 6.3.1 errors compiling GCC 4.8.5 - error: ‘const char* libc_name_p(const char*, unsigned int)’ redeclared inline with ‘gnu_inline’ attribute",
or https://gcc.gnu.org/PR69959 "gcc-6 doesn't build gcc-5 anymore",
for example, Jakub suggested building with '-std=gnu++98' as another
option. (Maybe that can be achieved by using a build GCC where this is
implicit?)

I suppose more instances of this issue can be found if searching more
thoroughly. ;-)

Toggle quote (4 lines)
> The latter commit's 'gnu/packages/patches/gcc-4.6-gnu-inline.patch'
> indicates that "the 3.0.3 release of gperf" may be when this started, so
> I'll try to invoke the time-machine for older than that, as a first
> (hopefully simple) try.
?