[PATCH] gnu: kicad: Update to 7.0.9.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • peter
Owner
unassigned
Submitted by
peter
Severity
normal
P
(address . guix-patches@gnu.org)(name . Peter Polidoro)(address . peter@polidoro.io)
9753decb770b403e2ff73bdbad79bb7a1889a144.1699905738.git.peter@polidoro.io
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/engineering.scm (kicad): Update to 7.0.9.

Change-Id: I83c232958e29f38134454efcac25d2e2cfb8e500
---
gnu/packages/engineering.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index b43e058af4..c533997027 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1092,7 +1092,7 @@ (define-public inspekt3d
(define-public kicad
(package
(name "kicad")
- (version "7.0.8")
+ (version "7.0.9")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1100,7 +1100,7 @@ (define-public kicad
(commit version)))
(sha256
(base32
- "1gaj833hm3avyb7gyjnl4jk9cckcmj8084y6q45ysjvh283rxsy4"))
+ "1hq9rba1gcks14zwbr8nbicpsil4imslgfch6ll33fhizbks3fq4"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
@@ -1200,7 +1200,7 @@ (define-public kicad-doc
(file-name (git-file-name name version))
(sha256
(base32
- "1ya9kwcbsh8cqbinjr1hr14sd0g6rls1awmvw8hwd7715f97x8fg"))))
+ "14dg99fvl6av9sn6gig6d6k1sdcf2svxy4fipqcz994z2khhz1sj"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags (list "-DBUILD_FORMATS=html")
@@ -1234,7 +1234,7 @@ (define-public kicad-symbols
(file-name (git-file-name name version))
(sha256
(base32
- "176zb7df25vz3wbhs94plmpabcgzxsnzbqmpdyssqr7m2wb2424a"))))
+ "0ynsnjq3z126cjkgm1fjbjvdvpc0walnr42ya9dv46l27kxy2j77"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ; no tests exist
@@ -1263,7 +1263,7 @@ (define-public kicad-footprints
(file-name (git-file-name name version))
(sha256
(base32
- "1560m5mwwq0jrjhr8zdh2xrm1w7pgr250p81xzhdc4wj7zsb0rrp"))))
+ "16a4c2xs4i8wbm01a901yxabxk0qdsjkzlccfawddv82bkh4b87h"))))
(synopsis "Official KiCad footprint libraries")
(description "This package contains the official KiCad footprint libraries.")))
@@ -1280,7 +1280,7 @@ (define-public kicad-packages3d
(file-name (git-file-name name version))
(sha256
(base32
- "1ypy2nzs1x8i98jr5kmlxfd6y592qs22aq73yl8nq0s6640fc4kk"))))
+ "1cly28vc07i54v487zbb8d1h70nrd3naxvq146b0xnbrjwnd2q28"))))
(synopsis "Official KiCad 3D model libraries")
(description "This package contains the official KiCad 3D model libraries.")))

base-commit: a0d337e79c87d7c38c79d0291974f490cb137a52
--
2.41.0
P
P
Peter Polidoro wrote on 15 Nov 2023 15:58
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 67151@debbugs.gnu.org)
A70A2FE8-A1CA-4D6D-A188-126236A0F0C6@polidoro.io
Hi,
It built for me the day I submitted it. I can try again though after rebasing. I have never seen that error before.

Toggle quote (11 lines)
> On Nov 15, 2023, at 09:15, Guillaume Le Vaillant <glv@posteo.net> wrote:
>
> ?Hi.
> When trying to build the updated kicad, I get an error when trying to
> build the psm2 dependency:
>
> --8<---------------cut here---------------start------------->8---
> error: pathspec 'PSM2_12.0' did not match any file(s) known to git
> --8<---------------cut here---------------end--------------->8---
>
> Did the build work for you?
G
G
Guillaume Le Vaillant wrote on 15 Nov 2023 15:10
(address . peter@polidoro.io)(address . 67151@debbugs.gnu.org)
87jzqjhzl5.fsf@kitej
Hi.
When trying to build the updated kicad, I get an error when trying to
build the psm2 dependency:

Toggle snippet (3 lines)
error: pathspec 'PSM2_12.0' did not match any file(s) known to git

Did the build work for you?
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZVTSlg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j89qwD6Aj6q1332SQyYM3rOy1bfem2CztADSgHH5YnO
xg5BxfUBAI9auAiwFAxPvs88RH8PDPE4jVxO+5TiaDGDGsP567oC
=1+RX
-----END PGP SIGNATURE-----

P
P
Peter Polidoro wrote on 15 Nov 2023 17:46
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 67151@debbugs.gnu.org)
878r6zotcy.fsf@polidoro.io
Yes it fails for me now too.

Fixing psm2 is probably beyond my packaging skills. Should I just
wait and try submitting it again later after someone fixes the
issue?

Guillaume Le Vaillant <glv@posteo.net> writes:

Toggle quote (15 lines)
> [[PGP Signed Part:Undecided]]
> [1. text/plain]
> Hi.
> When trying to build the updated kicad, I get an error when
> trying to
> build the psm2 dependency:
>
> [2. text/x-verbatim]
> error: pathspec 'PSM2_12.0' did not match any file(s) known to
> git
>
> [3. text/plain]
> Did the build work for you?
>
> [[End of PGP Signed Part]]
G
G
Guillaume Le Vaillant wrote on 16 Nov 2023 15:56
(name . Peter Polidoro)(address . peter@polidoro.io)(address . 67151-done@debbugs.gnu.org)
87jzqhrbia.fsf@kitej
Peter Polidoro <peter@polidoro.io> skribis:

Toggle quote (5 lines)
> Yes it fails for me now too.
>
> Fixing psm2 is probably beyond my packaging skills. Should I just wait and try
> submitting it again later after someone fixes the issue?

Ludo fixed psm2, so I could check that the updated kicad builds fine.
Patch applied as fc6bdaad57bf91609849623c5f485403c030cb49.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZVYt/Q8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+geAD9Hh/dInzcPz0czTywc1e6J8OxdXGe1JFdlcK5
kNSB2CsBAJNzt4oFQ6oAl+LGiDFE4LxEnDeTDifyhkuB8j8R2SzM
=7wCP
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67151@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67151
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch