Use CDN instead of mirrors for Apache httpd

  • Open
  • quality assurance status badge
Details
2 participants
  • Greg Hogan
  • glaz
Owner
unassigned
Submitted by
glaz
Severity
normal
G
(address . guix-patches@gnu.org)
40a1d032b44eee8421d68cb0faf69502@zho.pa
Hello fellow guixers.

I've found that I cannot build httpd package because of download issues.

downloading from

sha256 hash mismatch for
/gnu/store/sil2xmw01qmyygdbhvrsvyvmaviha2dy-httpd-2.4.58.tar.bz2:
expected hash: 1id45r2ccgkbjm9i998997ch32lvicpyynyx8x6aa4420wmdf5ps
actual hash: 0mdqa9w1p6cmli6976v4wi0sw9r4p5prkj7lzfd1877wk11c9c73

On the other hand, Apache web site states clearly that it doesn't use
mirror system anymore:
"As of the third quarter of 2021, the ASF stopped using its download
mirror system. It is now using a global content distribution network
(CDN)."

So I've made a patch that disables Apache mirrors for httpd@2.4.58 and
httpd/pinned@2.4.52 packages.

Dmitry Nikolaev
Toggle diff (22 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 66d09700db..0fef4fb928 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -281,7 +281,7 @@ (define-public httpd
(version "2.4.58")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://apache/httpd/httpd-"
+ (uri (string-append "https://dlcdn.apache.org/httpd/httpd-"
version ".tar.bz2"))
(sha256
(base32
@@ -319,7 +319,7 @@ (define-public httpd/pinned
(version "2.4.52")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://apache/httpd/httpd-"
+ (uri (string-append "https://dlcdn.apache.org/httpd/httpd-"
version ".tar.bz2"))
(sha256
(base32
G
G
Greg Hogan wrote on 14 Nov 2023 14:57
(address . glaz@zho.pa)(address . 67128@debbugs.gnu.org)
CA+3U0Zkqz-3kV-xQFotzNb_4NrmSQ_qTTcHcXG=GL97fK5GBoQ@mail.gmail.com
On Sun, Nov 12, 2023 at 8:39?AM glaz--- via Guix-patches via
<guix-patches@gnu.org> wrote:
Toggle quote (25 lines)
>
> Hello fellow guixers.
>
> I've found that I cannot build httpd package because of download issues.
>
> downloading from
> http://www.eu.apache.org/dist/httpd/httpd-2.4.58.tar.bz2 ...
>
> sha256 hash mismatch for
> /gnu/store/sil2xmw01qmyygdbhvrsvyvmaviha2dy-httpd-2.4.58.tar.bz2:
> expected hash: 1id45r2ccgkbjm9i998997ch32lvicpyynyx8x6aa4420wmdf5ps
> actual hash: 0mdqa9w1p6cmli6976v4wi0sw9r4p5prkj7lzfd1877wk11c9c73
>
> On the other hand, Apache web site states clearly that it doesn't use
> mirror system anymore:
> "As of the third quarter of 2021, the ASF stopped using its download
> mirror system. It is now using a global content distribution network
> (CDN)."
> https://www.apache.org/mirrors.html
>
> So I've made a patch that disables Apache mirrors for httpd@2.4.58 and
> httpd/pinned@2.4.52 packages.
>
> Dmitry Nikolaev

This looks to duplicate #63068, which instead fixes the list of
mirrors for all packages. Though, as noted in that thread, the linked
documentation lists downloads.apache.org rather than dlcdn.apache.org
G
Re: Use CDN instead of mirrors for Apache httpd
(address . guix-patches@gnu.org)
140775282bd86625289a841d2cf01f32@zho.pa
On 2023-11-12 15:10, glaz@zho.pa wrote:
Toggle quote (5 lines)
> Hello fellow guixers.
>
> I've found that I cannot build httpd package because of download
> issues.

Previous patch was wrong. Here's better one.
httpd-2.4.58 is Ok. The problem is httpd-2.4.52 could not be downloaded
from Apache mirrors, only from Apache archive site.

Dmitry
Toggle diff (13 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 822f0e7612..0359b36a42 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -320,7 +320,7 @@ (define-public httpd/pinned
(version "2.4.52")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://apache/httpd/httpd-"
+ (uri (string-append "https://archive.apache.org/dist/httpd/httpd-"
version ".tar.bz2"))
(sha256
(base32
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67128@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67128
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch