[PATCH] gnu: Add python-tdda.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Troy Figiel
Owner
unassigned
Submitted by
Troy Figiel
Severity
normal

Debbugs page

Troy Figiel wrote 1 years ago
(address . guix-patches@gnu.org)
87ttps118k.fsf@troyfigiel.com
* gnu/packages/python-science.scm (python-tdda): New variable.

Change-Id: I456aa236b3348e5b990289d8a381c2d5276a12f1
---
gnu/packages/python-science.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 4063797a30..949cd11929 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2022 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -349,6 +350,38 @@ (define-public python-scikit-optimize
@code{skopt} aims to be accessible and easy to use in many contexts.")
(license license:bsd-3)))
+(define-public python-tdda
+ (package
+ (name "python-tdda")
+ (version "2.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "tdda" version))
+ (sha256
+ (base32 "1xs91s8b7cshjcqw88qsrjh10xly799k5rf2ycawqfz2mw8sy3br"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("pandas>=1.5.2")
+ "pandas"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "tdda" "test")))))))
+ (native-inputs (list python-numpy python-pandas))
+ (home-page "https://www.stochasticsolutions.com")
+ (synopsis "Test-driven data analysis library for Python")
+ (description
+ "The TDDA Python module provides command-line and Python API support
+for the overall process of data analysis, through tools that peform
+reference testing, constraint discovery for data, automatic inference
+of regular expressions from text data and automatic test generation.")
+ (license license:expat))) ; MIT License
+
(define-public python-trimesh
(package
(name "python-trimesh")
--
2.40.1
Ludovic Courtès wrote 1 years ago
(name . Troy Figiel)(address . troy@troyfigiel.com)(address . 67125-done@debbugs.gnu.org)
87v8a36i6c.fsf@gnu.org
Troy Figiel <troy@troyfigiel.com> skribis:

Toggle quote (4 lines)
> * gnu/packages/python-science.scm (python-tdda): New variable.
>
> Change-Id: I456aa236b3348e5b990289d8a381c2d5276a12f1

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67125@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67125
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help