(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
* gnu/packages/mpd.scm (mympd): Update to 13.0.4.
[native-inputs]: Add jekyll.
[outputs]: Add 'doc.
[arguments]<#:configure-flags>: Install HTML documentation. Set correct value
for localstatedir.
<#:phases>: Add 'move-doc.
Change-Id: Icadf6c2268a1ecbe928c3ba7ff5157b139a8b1df
---
gnu/packages/mpd.scm | 22 +++++++++++++++-------
1 file changed, 15 insertions(+), 7 deletions(-)
Toggle diff (61 lines)
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 0e762144a1..e4a36de5f1 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -57,6 +57,7 @@ (define-module (gnu packages mpd)
#:use-module (gnu packages libusb)
#:use-module (gnu packages lua)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
@@ -622,7 +623,7 @@ (define-public mpdevil
(define-public mympd
(package
(name "mympd")
- (version "12.1.1")
+ (version "13.0.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -631,22 +632,29 @@ (define-public mympd
(file-name (git-file-name name version))
(sha256
(base32
- "1bal31xmdmq46bi0qmia07sqcwy695vcz5y5hxwkz71rcfywbsf9"))))
+ "1jlmpjs4a2sr0kxqp4crnq9jzagdmn5ggdd8x44wl1cdw38glrfn"))))
+ (outputs '("out" "doc"))
(build-system cmake-build-system)
(arguments
(list
#:configure-flags
- #~(list "-DMYMPD_BUILD_TESTING=ON"
- ;; Handled by 'strip' phase.
- "-DMYMPD_STRIP_BINARY=OFF")
+ #~(list "-DCMAKE_INSTALL_LOCALSTATEDIR=/var"
+ "-DMYMPD_BUILD_TESTING=ON"
+ "-DMYMPD_DOC_HTML=ON")
#:phases
#~(modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
;; The following test requires network connectivity.
- (invoke "ctest" "--exclude-regex" "test_http_client")))))))
- (native-inputs (list jq perl pkg-config))
+ (invoke "ctest" "--exclude-regex" "test_http_client"))))
+ (add-after 'install 'move-doc
+ (lambda _
+ (let ((old (string-append #$output "/share/doc"))
+ (new (string-append #$output:doc "/share/doc")))
+ (mkdir-p (dirname new))
+ (rename-file old new)))))))
+ (native-inputs (list jekyll jq perl pkg-config))
(inputs (list flac libid3tag lua openssl pcre2))
(home-page "https://jcorporation.github.io/")
(synopsis "Web-based MPD client")
base-commit: af6105afc67a15a491a0a4fd18a28c9f801a0b94
--
2.41.0