[PATCH] gnu: mympd: Update to 13.0.4.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Bruno Victal
Owner
unassigned
Submitted by
Bruno Victal
Severity
normal
B
B
Bruno Victal wrote on 11 Nov 2023 17:45
(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
a380f19dd410aec2e211e005d37ee323dceef4a5.1699721141.git.mirai@makinata.eu
* gnu/packages/mpd.scm (mympd): Update to 13.0.4.
[native-inputs]: Add jekyll.
[outputs]: Add 'doc.
[arguments]<#:configure-flags>: Install HTML documentation. Set correct value
for localstatedir.
<#:phases>: Add 'move-doc.

Change-Id: Icadf6c2268a1ecbe928c3ba7ff5157b139a8b1df
---
gnu/packages/mpd.scm | 22 +++++++++++++++-------
1 file changed, 15 insertions(+), 7 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 0e762144a1..e4a36de5f1 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -57,6 +57,7 @@ (define-module (gnu packages mpd)
#:use-module (gnu packages libusb)
#:use-module (gnu packages lua)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
@@ -622,7 +623,7 @@ (define-public mpdevil
(define-public mympd
(package
(name "mympd")
- (version "12.1.1")
+ (version "13.0.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -631,22 +632,29 @@ (define-public mympd
(file-name (git-file-name name version))
(sha256
(base32
- "1bal31xmdmq46bi0qmia07sqcwy695vcz5y5hxwkz71rcfywbsf9"))))
+ "1jlmpjs4a2sr0kxqp4crnq9jzagdmn5ggdd8x44wl1cdw38glrfn"))))
+ (outputs '("out" "doc"))
(build-system cmake-build-system)
(arguments
(list
#:configure-flags
- #~(list "-DMYMPD_BUILD_TESTING=ON"
- ;; Handled by 'strip' phase.
- "-DMYMPD_STRIP_BINARY=OFF")
+ #~(list "-DCMAKE_INSTALL_LOCALSTATEDIR=/var"
+ "-DMYMPD_BUILD_TESTING=ON"
+ "-DMYMPD_DOC_HTML=ON")
#:phases
#~(modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
;; The following test requires network connectivity.
- (invoke "ctest" "--exclude-regex" "test_http_client")))))))
- (native-inputs (list jq perl pkg-config))
+ (invoke "ctest" "--exclude-regex" "test_http_client"))))
+ (add-after 'install 'move-doc
+ (lambda _
+ (let ((old (string-append #$output "/share/doc"))
+ (new (string-append #$output:doc "/share/doc")))
+ (mkdir-p (dirname new))
+ (rename-file old new)))))))
+ (native-inputs (list jekyll jq perl pkg-config))
(inputs (list flac libid3tag lua openssl pcre2))
(home-page "https://jcorporation.github.io/")
(synopsis "Web-based MPD client")

base-commit: af6105afc67a15a491a0a4fd18a28c9f801a0b94
--
2.41.0
B
B
Bruno Victal wrote on 20 Nov 2023 18:33
[PATCH v2] gnu: mympd: Update to 13.0.5.
(address . 67110@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
6fef32a0128bdd36b2f4a18234f98a17e3e73cb5.1700501588.git.mirai@makinata.eu
* gnu/packages/mpd.scm (mympd): Update to 13.0.5.
[native-inputs]: Add jekyll.
[outputs]: Add 'doc.
[arguments]<#:configure-flags>: Install HTML documentation. Set correct value
for localstatedir.
<#:phases>: Add 'move-doc.

Change-Id: I0f1ab4295b7bc03876ad1bbeff6154b4da6adc9a
---
gnu/packages/mpd.scm | 22 +++++++++++++++-------
1 file changed, 15 insertions(+), 7 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 0e762144a1..e59397ea3a 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -57,6 +57,7 @@ (define-module (gnu packages mpd)
#:use-module (gnu packages libusb)
#:use-module (gnu packages lua)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
@@ -622,7 +623,7 @@ (define-public mpdevil
(define-public mympd
(package
(name "mympd")
- (version "12.1.1")
+ (version "13.0.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -631,22 +632,29 @@ (define-public mympd
(file-name (git-file-name name version))
(sha256
(base32
- "1bal31xmdmq46bi0qmia07sqcwy695vcz5y5hxwkz71rcfywbsf9"))))
+ "1ly3iw4irybfxyafgrldldwc28a879wwnd1pg32m2sgrwyhr0czm"))))
+ (outputs '("out" "doc"))
(build-system cmake-build-system)
(arguments
(list
#:configure-flags
- #~(list "-DMYMPD_BUILD_TESTING=ON"
- ;; Handled by 'strip' phase.
- "-DMYMPD_STRIP_BINARY=OFF")
+ #~(list "-DCMAKE_INSTALL_LOCALSTATEDIR=/var"
+ "-DMYMPD_BUILD_TESTING=ON"
+ "-DMYMPD_DOC_HTML=ON")
#:phases
#~(modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
;; The following test requires network connectivity.
- (invoke "ctest" "--exclude-regex" "test_http_client")))))))
- (native-inputs (list jq perl pkg-config))
+ (invoke "ctest" "--exclude-regex" "test_http_client"))))
+ (add-after 'install 'move-doc
+ (lambda _
+ (let ((old (string-append #$output "/share/doc"))
+ (new (string-append #$output:doc "/share/doc")))
+ (mkdir-p (dirname new))
+ (rename-file old new)))))))
+ (native-inputs (list jekyll jq perl pkg-config))
(inputs (list flac libid3tag lua openssl pcre2))
(home-page "https://jcorporation.github.io/")
(synopsis "Web-based MPD client")

base-commit: c07a5f050f67fa9054e93479cdda2f298c567460
--
2.41.0
C
C
Christopher Baines wrote on 23 Nov 2023 15:35
(name . Bruno Victal)(address . mirai@makinata.eu)
877cm8v8c3.fsf@cbaines.net
Bruno Victal <mirai@makinata.eu> writes:

Toggle quote (12 lines)
> * gnu/packages/mpd.scm (mympd): Update to 13.0.5.
> [native-inputs]: Add jekyll.
> [outputs]: Add 'doc.
> [arguments]<#:configure-flags>: Install HTML documentation. Set correct value
> for localstatedir.
> <#:phases>: Add 'move-doc.
>
> Change-Id: I0f1ab4295b7bc03876ad1bbeff6154b4da6adc9a
> ---
> gnu/packages/mpd.scm | 22 +++++++++++++++-------
> 1 file changed, 15 insertions(+), 7 deletions(-)

Thanks for the patch, I've pushed it to master as
dbc02656cf4804821e68d655fc871e2365150f43.

It would be good to record in the commit message the motivation for
changes like splitting the doc stuff in to a separate output. I had a
look at the doc output is larger than the main output, so maybe that's
justification enough.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmVfZQxfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeMAg/+MBjbBj+xgxuKVWrsqM79Nm3HMh3gbISn
GU4Vci28FXP4T6OwzD5cBUpY7VPRS8G76TSdaorF2syrIenUtoE31DAD7lBajjdT
LY0bpn74Sq4ls1InoRf1tHa7cAkQWB0TcBUgUT/2UOCym7tfYyboiFRGDdDAYIxf
F7P5Cztjys7cRj+nWuJhJiPBpo4/CyG9nZdKKNNx4TIXhkbZzmgm8hNMnmg3YtEP
RlK/KwVSzUPDJxkMER0HCPxHTsk2BXOlM6ej2JcDfQsOLb0XLvlbItsXazuok0qt
s8hj4xixyoluuS5dok2D/Bf3Z2XpseU5PBg6GZ6yJmINfjHOEoKMhaXjvO0eFdz5
dqOXoVG9BzigQR3AIWxFqZQJe9u6/RgPqvRZhdusZHO7vCjVYrFontztaxr+PXcb
qd1CvPdcG+GtOdm4y4pGpCntAwNXHOhL6DkWzh3XjDkqkDrb/s6YII3EIJ1c18IR
2T5FBAlgz19L7NFYoa7V55Z5fubAUu/Xo43KzKcuxI/G14++1yW7nNQ/Zp1KSP0s
EILPWaKhuwaplEzRFRTJLPqc5pSpN8HDzq6FFCWvqYNd6EOjQj2vGbcfXy7yTlGH
XOXGv9OoP5V9BmGuReFxYhf1KSFqgBUfwt2HdXLYEE4t9FbCZoN0HYfwbJHwATsw
i/TlbsZXkI0=
=g0Uh
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 67110@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67110
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch