librecast 0.8.x and lcsync 0.3.x

  • Done
  • quality assurance status badge
Details
One participant
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 1 years ago
(address . guix-patches@gnu.org)
87zfzltlme.fsf@wireframe
I will be submitting patches to update librecast to 0.8.0 and lcsync to 0.3.0 which
were recently released.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZU6OSQAKCRDcUY/If5cW
qtIRAP4sOZaVX3nPfhRvUdIG9e1NiRhzT0ixzQXfXkflXXEntQEAgXC/rKkq0i35
KBQ7UhO279nOMGl+sOfAEFrmJLcRUQg=
=8+LW
-----END PGP SIGNATURE-----

vagrant wrote 1 years ago
[PATCH 1/2] gnu: librecast: Update to 0.8.0.
(address . 67052@debbugs.gnu.org)(address . vagrant@debian.org)
20231110201622.510091-1-vagrant@debian.org
From: Vagrant Cascadian <vagrant@debian.org>

* gnu/packages/networking.scm (librecast): Update to 0.8.0.
[inputs]: Add libbsd.
---
gnu/packages/networking.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 1a8912ac87..03222a67d0 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -127,6 +127,7 @@ (define-module (gnu packages networking)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages libbsd)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libusb)
@@ -522,7 +523,7 @@ (define-public libnice
(define-public librecast
(package
(name "librecast")
- (version "0.7.0")
+ (version "0.8.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -531,7 +532,7 @@ (define-public librecast
(file-name (git-file-name name version))
(sha256
(base32
- "0y0km0fv39m3i227pyg7fcr7d94gbji51fkcywqyrjgmk4j1hp1n"))))
+ "01m0q4n2hy3csbzil8ivjyzb1mh4w9jlh9iiv6z53kasl7aas27i"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f
@@ -541,7 +542,7 @@ (define-public librecast
(string-append "PREFIX="
(assoc-ref %outputs "out"))))
#:test-target "test"))
- (inputs (list libsodium lcrq))
+ (inputs (list libsodium lcrq libbsd))
(synopsis "IPv6 multicast library")
(description "Librecast is a C library which supports IPv6 multicast
networking.")

base-commit: bb3ab24a296ffa5273b2e82a02ed057e90c095f3
--
2.39.2
vagrant wrote 1 years ago
[PATCH 2/2] gnu: lcsync: Update to 0.3.0.
(address . 67052@debbugs.gnu.org)(address . vagrant@debian.org)
20231110201622.510091-2-vagrant@debian.org
From: Vagrant Cascadian <vagrant@debian.org>

* gnu/packages/networking.scm (lcsync): Update to 0.3.0.
[inputs]: Add libbsd.
---
gnu/packages/networking.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 03222a67d0..aac4e09c91 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -327,7 +327,7 @@ (define-public netperf
(define-public lcsync
(package
(name "lcsync")
- (version "0.2.1")
+ (version "0.3.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -336,7 +336,7 @@ (define-public lcsync
(file-name (git-file-name name version))
(sha256
(base32
- "0bsd3dkir2i647nmrmyb7skbv16v0f6f3gfwkpxz8g42978dlms5"))))
+ "1rhk80ybd2zranay76z1ysifnnm786lg9kiiijcwv76qy95in9ks"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f
@@ -362,7 +362,7 @@ (define-public lcsync
(substitute* (list "./src/Makefile" "./test/Makefile")
(("-llibrecast")
(string-append "-L" librecast "/lib -llibrecast")))))))))
- (inputs (list lcrq librecast libsodium))
+ (inputs (list lcrq librecast libsodium libbsd))
(home-page "https://librecast.net/lcsync.html")
(synopsis "Librecast file and data syncing tool")
(description
--
2.39.2
vagrant wrote 1 years ago
[PATCH v2 1/2] gnu: librecast: Update to 0.8.0.
(address . 67052@debbugs.gnu.org)(address . vagrant@debian.org)
20231110210310.512492-1-vagrant@debian.org
From: Vagrant Cascadian <vagrant@debian.org>

* gnu/packages/networking.scm (librecast): Update to 0.8.0.
[inputs]: Add libbsd.
[source]: Apply guix style.
---
gnu/packages/networking.scm | 23 ++++++++++++-----------
1 file changed, 12 insertions(+), 11 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 1a8912ac87..103c3aa97f 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -127,6 +127,7 @@ (define-module (gnu packages networking)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages libbsd)
#:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libusb)
@@ -522,16 +523,16 @@ (define-public libnice
(define-public librecast
(package
(name "librecast")
- (version "0.7.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://codeberg.org/librecast/librecast")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0y0km0fv39m3i227pyg7fcr7d94gbji51fkcywqyrjgmk4j1hp1n"))))
+ (version "0.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/librecast/librecast")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01m0q4n2hy3csbzil8ivjyzb1mh4w9jlh9iiv6z53kasl7aas27i"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f
@@ -541,7 +542,7 @@ (define-public librecast
(string-append "PREFIX="
(assoc-ref %outputs "out"))))
#:test-target "test"))
- (inputs (list libsodium lcrq))
+ (inputs (list libsodium lcrq libbsd))
(synopsis "IPv6 multicast library")
(description "Librecast is a C library which supports IPv6 multicast
networking.")

base-commit: bb3ab24a296ffa5273b2e82a02ed057e90c095f3
--
2.39.2
vagrant wrote 1 years ago
[PATCH v2 2/2] gnu: lcsync: Update to 0.3.0.
(address . 67052@debbugs.gnu.org)(address . vagrant@debian.org)
20231110210310.512492-2-vagrant@debian.org
From: Vagrant Cascadian <vagrant@debian.org>

Apply guix style.

* gnu/packages/networking.scm (lcsync): Update to 0.3.0.
[inputs]: Add libbsd.
[arguments]<phases>: Drop 'use-prefix-from-configure-in-doc-makefile and
'add-library-paths.
---
gnu/packages/networking.scm | 44 ++++++++++++-------------------------
1 file changed, 14 insertions(+), 30 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 103c3aa97f..0dfda60bf9 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -327,42 +327,26 @@ (define-public netperf
(define-public lcsync
(package
(name "lcsync")
- (version "0.2.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://codeberg.org/librecast/lcsync")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0bsd3dkir2i647nmrmyb7skbv16v0f6f3gfwkpxz8g42978dlms5"))))
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/librecast/lcsync")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rhk80ybd2zranay76z1ysifnnm786lg9kiiijcwv76qy95in9ks"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f
- #:configure-flags
- (list
- (string-append "--prefix="
- (assoc-ref %outputs "out")))
+ #:configure-flags (list (string-append "--prefix="
+ (assoc-ref %outputs "out")))
#:make-flags (let ((target ,(%current-target-system)))
(list ,(string-append "CC="
(cc-for-target))))
- #:test-target "test"
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'use-prefix-from-configure-in-doc-makefile
- ;; Use prefix from configure. Fixed upstream:
- ;; https://codeberg.org/librecast/lcsync/commit/4ba00f6
- ;; XXX: Remove for 0.2.2+
- (lambda _
- (substitute* "doc/Makefile.in"
- (("PREFIX .= /usr/local") "PREFIX ?= @prefix@"))))
- (add-before 'build 'add-library-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((librecast (assoc-ref inputs "librecast")))
- (substitute* (list "./src/Makefile" "./test/Makefile")
- (("-llibrecast")
- (string-append "-L" librecast "/lib -llibrecast")))))))))
- (inputs (list lcrq librecast libsodium))
+ #:test-target "test"))
+ (inputs (list lcrq librecast libsodium libbsd))
(home-page "https://librecast.net/lcsync.html")
(synopsis "Librecast file and data syncing tool")
(description
--
2.39.2
Vagrant Cascadian wrote 1 years ago
Re: [PATCH v2 1/2] gnu: librecast: Update to 0.8.0.
(address . 67052-done@debbugs.gnu.org)
875y1qsuie.fsf@wireframe
On 2023-11-10, vagrant@debian.org wrote:
Toggle quote (7 lines)
> * gnu/packages/networking.scm (librecast): Update to 0.8.0.
> [inputs]: Add libbsd.
> [source]: Apply guix style.
> ---
> gnu/packages/networking.scm | 23 ++++++++++++-----------
> 1 file changed, 12 insertions(+), 11 deletions(-)

Pushed as:

369c1782c77be0c68cc5cdd66184c33ca8b89d6c gnu: librecast: Update to 0.8.0.
4ec8724c77c031e3ec94b3583c5b3cfc101fac61 gnu: lcsync: Update to 0.3.0.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZWEXigAKCRDcUY/If5cW
qkXpAP9YpCP7yRE2JOHI7Ad5vlxFeJRxbcw7XArl3cb6l77fPAEAvaeDD3Z6zGah
VFopl3UXvDr5aKE9g22ashvdiTttOQw=
=bSmz
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 67052@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67052
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help