(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
* gnu/packages/kde-utils.scm (krename): New variable.
Change-Id: I004f1fffa269f6182f89481970bd223aeec48bc4
---
gnu/packages/kde-utils.scm | 63 ++++++++++++++++++++++++++++++++++++++
1 file changed, 63 insertions(+)
Toggle diff (90 lines)
diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
index 4e665da599..719139a320 100644
--- a/gnu/packages/kde-utils.scm
+++ b/gnu/packages/kde-utils.scm
@@ -35,11 +35,15 @@ (define-module (gnu packages kde-utils)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
#:use-module (gnu packages cups)
+ #:use-module (gnu packages fontutils)
#:use-module (gnu packages glib) ; dbus for tests
#:use-module (gnu packages gnome)
#:use-module (gnu packages gstreamer)
+ #:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages mp3)
#:use-module (gnu packages multiprecision)
+ #:use-module (gnu packages pdf)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages kde)
#:use-module (gnu packages kde-frameworks)
@@ -887,6 +891,65 @@ (define-public kmouth
(license ;; GPL for programs, FDL for documentation
(list license:gpl2+ license:fdl1.2+))))
+(define-public krename
+ (package
+ (name "krename")
+ (version "5.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/krename/" version
+ "/src/krename-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1v935xlsy7lyp1fgmy5ad3x5i9d8rigwanpmsx6xpxnrvnkn0g5j"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list extra-cmake-modules pkg-config))
+ (inputs
+ (list exiv2
+ freetype
+ karchive
+ kcompletion
+ kconfig
+ kcoreaddons
+ kcrash
+ ki18n
+ kiconthemes
+ kio
+ kitemviews
+ kjobwidgets
+ kjs
+ kservice
+ kwidgetsaddons
+ kxmlgui
+ podofo
+ taglib))
+ (home-page "https://userbase.kde.org/KRename")
+ (synopsis "Utility to handle specialized file renames")
+ (description "KRename is a batch file renamer by KDE. It allows you to
+easily rename hundreds or even more files in one go. The filenames can be
+created by parts of the original filename, numbering the files or accessing
+hundreds of information about the file, like creation date or Exif information
+of an image.
+
+Its features include:
+
+@itemize
+@item renaming a list of files based on a set of expressions,
+@item copying/moving a list of files to another directory,
+@item converting filenames to upper/lower case,
+@item adding numbers to filenames,
+@item finding and replacing parts of the filename,
+@item rename Mp3/Ogg Vorbis files based on their ID3 tags,
+@item setting access and modification dates, permissions and file ownership,
+@item a plug-in API which allows you to extend KRename's features,
+@item renaming directories recursively,
+@item support for KFilePlugins,
+@item creating undo file
+@item and many more...
+@end itemize")
+ (license license:gpl3+)))
+
(define-public kronometer
(package
(name "kronometer")
base-commit: 857c1996129e32f41cd7e1d4c04420b47563daed
--
2.41.0