(address . guix-patches@gnu.org)
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-paperwm): Update to 44.13.1.
Change-Id: I1a03211cf11604a52de1b49a5b69a1d1b7030c0f
---
gnu/packages/gnome-xyz.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
Toggle diff (51 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 6b66658215..3b608512f5 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2022 Sughosha <sughosha@proton.me>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2023 Eidvilas Markevi?ius <markeviciuseidvilas@gmail.com>
+;;; Copyright © 2023 Stefan <stefan-guix@vodafonemail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1016,7 +1017,7 @@ (define-public gnome-shell-extension-noannoyance
(define-public gnome-shell-extension-paperwm
(package
(name "gnome-shell-extension-paperwm")
- (version "36.0")
+ (version "v44.13.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1025,13 +1026,13 @@ (define-public gnome-shell-extension-paperwm
(file-name (git-file-name name version))
(sha256
(base32
- "1ssnabwxrns36c61ppspjkr9i3qifv08pf2jpwl7cjv3pvyn4kly"))
+ "10aqyrwz4x91j4mlzjzg8g7r0ga35217iiywa1a77bipad0jbbjr"))
(snippet
'(begin (delete-file "schemas/gschemas.compiled")))))
(build-system copy-build-system)
(arguments
'(#:install-plan
- '(("." "share/gnome-shell/extensions/paperwm@hedning:matrix.org"
+ '(("." "share/gnome-shell/extensions/paperwm@paperwm.github.com"
#:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
"\\.xml$" "\\.compiled$")))
#:phases
@@ -1039,8 +1040,7 @@ (define-public gnome-shell-extension-paperwm
(add-before 'install 'compile-schemas
(lambda _
(with-directory-excursion "schemas"
- (invoke "make"))
- #t)))))
+ (invoke "make")))))))
(native-inputs
`(("glib:bin" ,glib "bin"))) ; for glib-compile-schemas
(home-page "https://github.com/paperwm/PaperWM")
base-commit: 42bec70a91d2205371c96287bcf565dcc5f5dd74
--
2.41.0