(address . guix-patches@gnu.org)
This function is defined in guix/build/node-build-system.scm.
* .dir-locals.el (scheme-mode): Indent
'with-atomic-json-file-replacement' like 'with-output-to-file'.
---
.dir-locals.el | 1 +
1 file changed, 1 insertion(+)
Toggle diff (16 lines)
diff --git a/.dir-locals.el b/.dir-locals.el
index d18e6ba760..2426b3449b 100644
--- a/.dir-locals.el
+++ b/.dir-locals.el
@@ -91,6 +91,7 @@
(eval . (put 'with-error-handling 'scheme-indent-function 0))
(eval . (put 'with-mutex 'scheme-indent-function 1))
(eval . (put 'with-atomic-file-output 'scheme-indent-function 1))
+ (eval . (put 'with-atomic-json-file-replacement 'scheme-indent-function 1))
(eval . (put 'call-with-compressed-output-port 'scheme-indent-function 2))
(eval . (put 'call-with-decompressed-port 'scheme-indent-function 2))
(eval . (put 'call-with-gzip-input-port 'scheme-indent-function 1))
base-commit: 19fe24c5b978a16cbca3cddbfa3ab9d1ee2c68f2
--
2.41.0