[PATCH] .dir-locals.el: Indent with-atomic-json-file-replacement.

  • Open
  • quality assurance status badge
Details
One participant
  • Philip McGrath
Owner
unassigned
Submitted by
Philip McGrath
Severity
normal

Debbugs page

Philip McGrath wrote 1 years ago
(address . guix-patches@gnu.org)
1ef078f5e6d23d0c1de4a328c5043c442342727e.1699547527.git.philip@philipmcgrath.com
This function is defined in guix/build/node-build-system.scm.

* .dir-locals.el (scheme-mode): Indent
'with-atomic-json-file-replacement' like 'with-output-to-file'.
---
.dir-locals.el | 1 +
1 file changed, 1 insertion(+)

Toggle diff (16 lines)
diff --git a/.dir-locals.el b/.dir-locals.el
index d18e6ba760..2426b3449b 100644
--- a/.dir-locals.el
+++ b/.dir-locals.el
@@ -91,6 +91,7 @@
(eval . (put 'with-error-handling 'scheme-indent-function 0))
(eval . (put 'with-mutex 'scheme-indent-function 1))
(eval . (put 'with-atomic-file-output 'scheme-indent-function 1))
+ (eval . (put 'with-atomic-json-file-replacement 'scheme-indent-function 1))
(eval . (put 'call-with-compressed-output-port 'scheme-indent-function 2))
(eval . (put 'call-with-decompressed-port 'scheme-indent-function 2))
(eval . (put 'call-with-gzip-input-port 'scheme-indent-function 1))

base-commit: 19fe24c5b978a16cbca3cddbfa3ab9d1ee2c68f2
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67020@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67020
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help