[PATCH] gnu: Add rust-dyn-iter-1.

  • Open
  • quality assurance status badge
Details
One participant
  • woshilapin
Owner
unassigned
Submitted by
woshilapin
Severity
normal
W
W
woshilapin wrote on 8 Nov 2023 16:46
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
xsKxFKce_x9jT26MTyceWNUxihjftXoZZg_98a-LrqVu5RDLsE0bL9Y-tdqB6rUsam2OBbzIYHruolUQruobqTR6E7g7pX84VG64Gi5TcZM=@tuziwo.info
* gnu/packages/crates-io.scm (rust-dyn-iter-1): New variable.
From 07cdbbf408e64dd934d1de95361540f1df17b8ca Mon Sep 17 00:00:00 2001
From: Jean SIMARD <woshilapin@tuziwo.info>
Date: Wed, 8 Nov 2023 16:26:44 +0100
Subject: [PATCH] gnu: Add rust-dyn-iter-1.

* gnu/packages/crates-io.scm (rust-dyn-iter-1): New variable.
---
gnu/packages/crates-io.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d42ff60a20..8b27511d3a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2022 Paul Alesius <paul@unnservice.com>
;;; Copyright © 2023 Arnav Andrew Jose <arnav.jose@gmail.com>
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
+;;; Copyright © 2023 Jean Simard <woshilapin@tuziwo.info>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22592,6 +22593,23 @@ (define-public rust-dyn-clone-1
(description "Clone trait that is object-safe")
(license (list license:expat license:asl2.0))))
+(define-public rust-dyn-iter-1
+ (package
+ (name "rust-dyn-iter")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "dyn-iter" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "109b69c2a57zhzsipkcb8gjjjbs8xi1xdb3b86r0vr5jz7v876g4"))))
+ (build-system cargo-build-system)
+ (home-page "https://gitlab.com/woshilapin/dyn-iter")
+ (synopsis "Helper to handle non-describable 'Iterator'")
+ (description "Wrapper around `Box<dyn Iterator<Item = V> + 'iter>` to simplify your code")
+ (license license:expat)))
+
(define-public rust-dwrote-0.11
(package
(name "rust-dwrote")
--
2.39.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 67004@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 67004
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch