Recursive git checkout broken?

  • Done
  • quality assurance status badge
Details
2 participants
  • Janneke Nieuwenhuizen
  • Simon Tournier
Owner
unassigned
Submitted by
Janneke Nieuwenhuizen
Severity
normal
J
J
Janneke Nieuwenhuizen wrote on 7 Nov 2023 16:44
(address . bug-guix@gnu.org)
87il6d4lh6.fsf@gnu.org
Hi,

I tried to upgrade m2-planet to 1.10.0 (well, actually I tried to
downgrade from 1.11.0 which cannot build mes, as reported by apterix via
IRC) using this description

Toggle snippet (18 lines)
(define-public m2-planet-1.10.0
(package
(inherit m2-planet)
(name "m2-planet")
(version "1.10.0")
(native-inputs (list coreutils mescc-tools sed))
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/oriansj/m2-planet")
(commit (string-append "Release_" version))
(recursive? #t))) ;for M2libc
(file-name (git-file-name name version))
(sha256
(base32
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"))))))

but that fails with

Toggle snippet (39 lines)
Initialized empty Git repository in /gnu/store/2janx5qgr2lv0hm5czzhiff4yz9p0nmg-m2-planet-1.10.0-checkout/.git/
From https://github.com/oriansj/m2-planet
* tag Release_1.10.0 -> FETCH_HEAD
Note: switching to 'FETCH_HEAD'.

You are in 'detached HEAD' state. You can look around, make experimental
changes and commit them, and you can discard any commits you make in this
state without impacting any branches by switching back to a branch.

If you want to create a new branch to retain commits you create, you may
do so (now or later) by using -c with the switch command. Example:

git switch -c <new-branch-name>

Or undo this operation with:

git switch -

Turn off this advice by setting config variable advice.detachedHead to false

HEAD is now at c9b9920 Release_1.10.0
/gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-submodule: line 7: basename: command not found
/gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-submodule: line 7: sed: command not found
/gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-sh-setup: line 77: basename: command not found
/gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-sh-setup: line 77: sed: command not found
/gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-sh-setup: line 292: uname: command not found
/gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-submodule: line 613: sed: command not found
/gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-submodule: line 613: cmd_: command not found
git-fetch: '/gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/bin/git submodule update --init --recursive' failed with exit code 127
Trying content-addressed mirror at bordeaux.guix.gnu.org...
Unable to fetch from bordeaux.guix.gnu.org, misc-error: (#f download failed ~S ~S ~S (http://bordeaux.guix.gnu.org/nar/lzip/2janx5qgr2lv0hm5czzhiff4yz9p0nmg-m2-planet-1.10.0-checkout 404 Not Found) #f)
Trying content-addressed mirror at ci.guix.gnu.org...
Unable to fetch from ci.guix.gnu.org, misc-error: (#f download failed ~S ~S ~S (http://ci.guix.gnu.org/nar/lzip/2janx5qgr2lv0hm5czzhiff4yz9p0nmg-m2-planet-1.10.0-checkout 404 Not Found) #f)
Trying content-addressed mirror at bordeaux.guix.gnu.org...
Unable to fetch from bordeaux.guix.gnu.org, misc-error: (#f download failed ~S ~S ~S (http://bordeaux.guix.gnu.org/nar/2janx5qgr2lv0hm5czzhiff4yz9p0nmg-m2-planet-1.10.0-checkout 404 Not Found) #f)
Trying content-addressed mirror at ci.guix.gnu.org...
Unable to fetch from ci.guix.gnu.org, misc-error: (#f download failed ~S ~S ~S (http://ci.guix.gnu.org/nar/2janx5qgr2lv0hm5czzhiff4yz9p0nmg-m2-planet-1.10.0-checkout 404 Not Found) #f)

Ideas?

I reverted to m2-planet-1.9.0 as that will also build mes, and we've got
its source already built...

Greetings,
Janneke

--
Janneke Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond https://LilyPond.org
Freelance IT https://www.JoyOfSource.com| Avatar® https://AvatarAcademy.com
S
S
Simon Tournier wrote on 9 Nov 2023 01:18
86fs1fkce4.fsf@gmail.com
Hi,

On Tue, 07 Nov 2023 at 16:44, Janneke Nieuwenhuizen <janneke@gnu.org> wrote:

Toggle quote (9 lines)
> /gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-submodule: line 7: basename: command not found
> /gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-submodule: line 7: sed: command not found
> /gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-sh-setup: line 77: basename: command not found
> /gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-sh-setup: line 77: sed: command not found
> /gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-sh-setup: line 292: uname: command not found
> /gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-submodule: line 613: sed: command not found
> /gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-submodule: line 613: cmd_: command not found
> git-fetch: '/gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/bin/git submodule update --init --recursive' failed with exit code 127

This looks very similar as https://issues.guix.gnu.org/66305. And I
guess it comes from https://issues.guix.gnu.org/65924 coupled with
f651a35969. Well, both had been fixed.
ab9a88e355165025f7b4719017c0a40264167b22 fixes #65924 and
762fdbdef52b4c17df578478cadc8655d56171a4 fixes #66305.

What is your guix-daemon revision and your Guix revision?

Does it mean that /run/current-system/profile/bin does have all these
(basename, sed, uname, sed)?

Cheers,
simon
J
J
Janneke Nieuwenhuizen wrote on 9 Nov 2023 07:45
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)(address . 66987-done@debbugs.gnu.org)
871qcz4e7x.fsf@gnu.org
Simon Tournier writes:

Hi!

Toggle quote (19 lines)
> On Tue, 07 Nov 2023 at 16:44, Janneke Nieuwenhuizen <janneke@gnu.org> wrote:
>
>> /gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-submodule: line 7: basename: command not found
>> /gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-submodule: line 7: sed: command not found
>> /gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-sh-setup: line 77: basename: command not found
>> /gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-sh-setup: line 77: sed: command not found
>> /gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-sh-setup: line 292: uname: command not found
>> /gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-submodule: line 613: sed: command not found
>> /gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/libexec/git-core/git-submodule: line 613: cmd_: command not found
>> git-fetch: '/gnu/store/y3vdq2pdkljrw63xxnc2vb6lz07ycar6-git-minimal-2.41.0/bin/git submodule update --init --recursive' failed with exit code 127
>
> This looks very similar as <https://issues.guix.gnu.org/66305>. And I
> guess it comes from <https://issues.guix.gnu.org/65924> coupled with
> f651a35969. Well, both had been fixed.
> ab9a88e355165025f7b4719017c0a40264167b22 fixes #65924 and
> 762fdbdef52b4c17df578478cadc8655d56171a4 fixes #66305.
>
> What is your guix-daemon revision and your Guix revision?

Yeah, my guix-deamon is 63dbcec93d99b082477f51f44428a19d802eece4.

After doing

Toggle snippet (4 lines)
sudo herd stop guix-daemon
sudo -E ./pre-inst-env guix-daemon --build-users-group=guixbuild &

it just works. Closing, and thanks!

Toggle quote (3 lines)
> Does it mean that /run/current-system/profile/bin does have all these
> (basename, sed, uname, sed)?

I guess it's pretty hard to build a system without those in the system
profile?

Greetings,
Janneke

--
Janneke Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond https://LilyPond.org
Freelance IT https://www.JoyOfSource.com| Avatar® https://AvatarAcademy.com
Closed
?