[PATCH] build: Require scripts/guix in pre-inst-env.

  • Open
  • quality assurance status badge
Details
One participant
  • Sergey Trofimov
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal
S
S
Sergey Trofimov wrote on 5 Nov 2023 19:43
(address . guix-patches@gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
cb42811c2d68263ddbbae5105366da7c359af3d9.1699209770.git.sarg@sarg.org.ru
* Makefile.am: Make scripts/guix depend on local guile.
* build-aux/pre-inst-env.in: Require scripts/guix.
---
Makefile.am | 2 +-
build-aux/pre-inst-env.in | 7 +++++++
2 files changed, 8 insertions(+), 1 deletion(-)

Toggle diff (40 lines)
diff --git a/Makefile.am b/Makefile.am
index c99f2f2911..d7f14b8962 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,7 +46,7 @@ do_subst = $(SED) \
-e 's,[@]abs_top_builddir[@],$(abs_top_builddir),g' \
-e 's,[@]localedir[@],$(localedir),g'
-scripts/guix: scripts/guix.in Makefile
+scripts/guix: scripts/guix.in Makefile guile$(EXEEXT)
$(AM_V_at)rm -f $@ $@-t
$(AM_V_at)$(MKDIR_P) "$(@D)"
$(AM_V_GEN)$(do_subst) < "$(srcdir)/$@.in" > "$@-t"
diff --git a/build-aux/pre-inst-env.in b/build-aux/pre-inst-env.in
index cd90a06cbc..4063b46a4b 100644
--- a/build-aux/pre-inst-env.in
+++ b/build-aux/pre-inst-env.in
@@ -37,11 +37,18 @@ GUILE_LOAD_COMPILED_PATH="$abs_top_builddir${GUILE_LOAD_COMPILED_PATH:+:}$GUILE_
GUILE_LOAD_PATH="$abs_top_builddir:$abs_top_srcdir${GUILE_LOAD_PATH:+:}$GUILE_LOAD_PATH"
export GUILE_LOAD_COMPILED_PATH GUILE_LOAD_PATH
+CURRENT_GUIX=$(which guix)
# Define $PATH so that `guix' and friends are easily found.
PATH="$abs_top_builddir/scripts:$abs_top_builddir:$PATH"
export PATH
+# sanity check
+if [ "$CURRENT_GUIX" = "`which guix`" ]; then
+ echo "$abs_top_builddir/scripts/guix is not built. Please run make scripts/guix"
+ exit 1
+fi
+
# The daemon invokes 'guix'; tell it which one to use.
GUIX="$abs_top_builddir/scripts/guix"
export GUIX

base-commit: 286639c9af49dc56dce68a5483fd8ca3aeaecdb0
--
2.41.0
S
S
Sergey Trofimov wrote on 19 Nov 2023 14:34
[PATCH v1] build: Require scripts/guix in pre-inst-env.
(address . 66958@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
5582e9962cde25dcbb66ee35527aff565a94795d.1700400821.git.sarg@sarg.org.ru
* Makefile.am: Make scripts/guix depend on local guile.
* build-aux/pre-inst-env.in: Require scripts/guix.
---
Makefile.am | 2 +-
build-aux/pre-inst-env.in | 6 ++++++
2 files changed, 7 insertions(+), 1 deletion(-)

Toggle diff (32 lines)
diff --git a/Makefile.am b/Makefile.am
index cbc3191dfc..34574c3a0e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,7 +47,7 @@ do_subst = $(SED) \
-e 's,[@]abs_top_builddir[@],$(abs_top_builddir),g' \
-e 's,[@]localedir[@],$(localedir),g'
-scripts/guix: scripts/guix.in Makefile
+scripts/guix: scripts/guix.in Makefile guile$(EXEEXT)
$(AM_V_at)rm -f $@ $@-t
$(AM_V_at)$(MKDIR_P) "$(@D)"
$(AM_V_GEN)$(do_subst) < "$(srcdir)/$@.in" > "$@-t"
diff --git a/build-aux/pre-inst-env.in b/build-aux/pre-inst-env.in
index cd90a06cbc..7c1d5aa09b 100644
--- a/build-aux/pre-inst-env.in
+++ b/build-aux/pre-inst-env.in
@@ -46,6 +46,12 @@ export PATH
GUIX="$abs_top_builddir/scripts/guix"
export GUIX
+# sanity check
+if [ ! -f "$GUIX" ]; then
+ echo "$GUIX is not built. Please run make scripts/guix"
+ exit 1
+fi
+
# Define $GUIX_UNINSTALLED to prevent `guix' from
# prepending @guilemoduledir@ to the Guile load paths.

base-commit: 761810d32a0550912b5bb36a0c9f60141bcb7d20
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 66958@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66958
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch