(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
* gnu/packages/kde-utils.scm (partitionmanager): New variable.
Change-Id: I77cfe8d730ae4bb8293b2a2c461c7f483359f082
---
gnu/packages/kde-utils.scm | 39 ++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)
Toggle diff (61 lines)
diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
index 4e665da599..4e1dc4d1f6 100644
--- a/gnu/packages/kde-utils.scm
+++ b/gnu/packages/kde-utils.scm
@@ -41,6 +41,7 @@ (define-module (gnu packages kde-utils)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages polkit)
#:use-module (gnu packages kde)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages kde-plasma)
@@ -1065,6 +1066,44 @@ (define-public okteta
(license ;; GPL for programs, LGPL for libraries, FDL for documentation
(list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+(define-public partitionmanager
+ (package
+ (name "partitionmanager")
+ (version "23.04.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/partitionmanager-" version ".tar.xz"))
+ (sha256
+ (base32 "03xx3nh2grkgkjn8dixy529lb4gnrdhlzhzsry82g64f8c6sfqqm"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list extra-cmake-modules kdoctools))
+ (inputs
+ (list kconfig
+ kconfigwidgets
+ kcoreaddons
+ kcrash
+ kdbusaddons
+ ki18n
+ kio
+ kjobwidgets
+ kwidgetsaddons
+ kwindowsystem
+ kxmlgui
+ polkit-qt))
+ (propagated-inputs
+ (list kpmcore))
+ (home-page "https://apps.kde.org/partitionmanager/")
+ (synopsis "Disk device, partition and file system manager")
+ (description "KDE Partition Manager is a utility to help you manage the
+disks, partitions, and file systems. It allows you to easily create, copy,
+move, delete, back up, restore, and resize them without losing data. It
+supports a large number of file systems, including ext2/3/4, btrfs, reiserfs,
+NTFS, FAT16/32, JFS, XFS and more.")
+ (license license:gpl3+)))
+
(define-public print-manager
(package
(name "print-manager")
base-commit: c0895371c5759c7d9edb330774e90f192cc4cf2c
--
2.41.0