[PATCH] gnu: Add partitionmanager.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal

Debbugs page

Sughosha wrote 1 years ago
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
4300d8e7305798f3110adff0fdbda099ba5a1560.1699193663.git.sughosha@disroot.org
* gnu/packages/kde-utils.scm (partitionmanager): New variable.

Change-Id: I77cfe8d730ae4bb8293b2a2c461c7f483359f082
---
gnu/packages/kde-utils.scm | 39 ++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
index 4e665da599..4e1dc4d1f6 100644
--- a/gnu/packages/kde-utils.scm
+++ b/gnu/packages/kde-utils.scm
@@ -41,6 +41,7 @@ (define-module (gnu packages kde-utils)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages polkit)
#:use-module (gnu packages kde)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages kde-plasma)
@@ -1065,6 +1066,44 @@ (define-public okteta
(license ;; GPL for programs, LGPL for libraries, FDL for documentation
(list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+(define-public partitionmanager
+ (package
+ (name "partitionmanager")
+ (version "23.04.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/partitionmanager-" version ".tar.xz"))
+ (sha256
+ (base32 "03xx3nh2grkgkjn8dixy529lb4gnrdhlzhzsry82g64f8c6sfqqm"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list extra-cmake-modules kdoctools))
+ (inputs
+ (list kconfig
+ kconfigwidgets
+ kcoreaddons
+ kcrash
+ kdbusaddons
+ ki18n
+ kio
+ kjobwidgets
+ kwidgetsaddons
+ kwindowsystem
+ kxmlgui
+ polkit-qt))
+ (propagated-inputs
+ (list kpmcore))
+ (home-page "https://apps.kde.org/partitionmanager/")
+ (synopsis "Disk device, partition and file system manager")
+ (description "KDE Partition Manager is a utility to help you manage the
+disks, partitions, and file systems. It allows you to easily create, copy,
+move, delete, back up, restore, and resize them without losing data. It
+supports a large number of file systems, including ext2/3/4, btrfs, reiserfs,
+NTFS, FAT16/32, JFS, XFS and more.")
+ (license license:gpl3+)))
+
(define-public print-manager
(package
(name "print-manager")

base-commit: c0895371c5759c7d9edb330774e90f192cc4cf2c
--
2.41.0
Sughosha wrote 1 years ago
[PATCH v2] gnu: Add partitionmanager.
(address . 66951@debbugs.gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
e61ed7e6b325946677270d8b0bebba7e4dc0db3d.1699251261.git.sughosha@disroot.org
* gnu/packages/kde-utils.scm (partitionmanager): New variable.

Change-Id: I77cfe8d730ae4bb8293b2a2c461c7f483359f082
---
gnu/packages/kde-utils.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (60 lines)
diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
index 4e665da599..12604049ae 100644
--- a/gnu/packages/kde-utils.scm
+++ b/gnu/packages/kde-utils.scm
@@ -41,6 +41,7 @@ (define-module (gnu packages kde-utils)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages polkit)
#:use-module (gnu packages kde)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages kde-plasma)
@@ -1065,6 +1066,43 @@ (define-public okteta
(license ;; GPL for programs, LGPL for libraries, FDL for documentation
(list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+(define-public partitionmanager
+ (package
+ (name "partitionmanager")
+ (version "23.04.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/partitionmanager-" version ".tar.xz"))
+ (sha256
+ (base32 "03xx3nh2grkgkjn8dixy529lb4gnrdhlzhzsry82g64f8c6sfqqm"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list extra-cmake-modules kdoctools))
+ (inputs
+ (list kconfig
+ kconfigwidgets
+ kcoreaddons
+ kcrash
+ kdbusaddons
+ ki18n
+ kio
+ kjobwidgets
+ kpmcore
+ kwidgetsaddons
+ kwindowsystem
+ kxmlgui
+ polkit-qt))
+ (home-page "https://apps.kde.org/partitionmanager/")
+ (synopsis "Disk device, partition and file system manager")
+ (description "KDE Partition Manager is a utility to help you manage the
+disks, partitions, and file systems. It allows you to easily create, copy,
+move, delete, back up, restore, and resize them without losing data. It
+supports a large number of file systems, including ext2/3/4, btrfs, reiserfs,
+NTFS, FAT16/32, JFS, XFS and more.")
+ (license license:gpl3+)))
+
(define-public print-manager
(package
(name "print-manager")

base-commit: c0895371c5759c7d9edb330774e90f192cc4cf2c
--
2.41.0
Sughosha wrote 1 years ago
[PATCH v3 2/2] gnu: Add partitionmanager.
(address . 66951@debbugs.gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
c6973a1ef5236e5c1e0bfd660433984208463d9c.1699259669.git.sughosha@disroot.org
* gnu/packages/kde-systemtools.scm (partitionmanager): New variable.

Change-Id: I4225ed9f999c0086dd1fc08ecb2937c5ba6da859
---
gnu/packages/kde-systemtools.scm | 38 ++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/kde-systemtools.scm b/gnu/packages/kde-systemtools.scm
index 56ce37fea8..1d1cfc0861 100644
--- a/gnu/packages/kde-systemtools.scm
+++ b/gnu/packages/kde-systemtools.scm
@@ -35,6 +35,7 @@ (define-module (gnu packages kde-systemtools)
#:use-module (gnu packages kde-plasma)
#:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages polkit)
#:use-module (gnu packages qt)
#:use-module (gnu packages glib)
#:use-module (gnu packages ruby)
@@ -340,6 +341,43 @@ (define-public ksystemlog
This package is part of the KDE administration module.")
(license license:gpl2+)))
+(define-public partitionmanager
+ (package
+ (name "partitionmanager")
+ (version "23.04.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/partitionmanager-" version ".tar.xz"))
+ (sha256
+ (base32 "03xx3nh2grkgkjn8dixy529lb4gnrdhlzhzsry82g64f8c6sfqqm"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list extra-cmake-modules kdoctools))
+ (inputs
+ (list kconfig
+ kconfigwidgets
+ kcoreaddons
+ kcrash
+ kdbusaddons
+ ki18n
+ kio
+ kjobwidgets
+ kpmcore
+ kwidgetsaddons
+ kwindowsystem
+ kxmlgui
+ polkit-qt))
+ (home-page "https://apps.kde.org/partitionmanager/")
+ (synopsis "Disk device, partition and file system manager")
+ (description "KDE Partition Manager is a utility to help you manage the
+disks, partitions, and file systems. It allows you to easily create, copy,
+move, delete, back up, restore, and resize them without losing data. It
+supports a large number of file systems, including ext2/3/4, btrfs, reiserfs,
+NTFS, FAT16/32, JFS, XFS and more.")
+ (license license:gpl3+)))
+
(define-public spectacle
(package
(name "spectacle")
--
2.41.0
Sughosha wrote 1 years ago
[PATCH v3 1/2] gnu: kpmcore: Fix polkit actions directory.
(address . 66951@debbugs.gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
9c0cb47d84f82f57879cf41d60823c9b3037a54e.1699259669.git.sughosha@disroot.org
* gnu/packages/kde.scm (kpmcore)[#:phases]: Modify
fix-cmake-install-directories and rename it to
fix-polkit-actions-directory.

Change-Id: Ief6e7488dd3e9153100097e2f662ff81729901b1
---
gnu/packages/kde.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 20fbb41d73..f1efc47069 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1073,11 +1073,13 @@ (define-public kpmcore
(list
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'fix-cmake-install-directories
+ (add-after 'unpack 'fix-polkit-actions-directory
(lambda _
(substitute* "src/util/CMakeLists.txt"
(("DESTINATION \\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
- "DESTINATION share/polkit-1/actions")))))))
+ "DESTINATION share/polkit-1/actions"))
+ (substitute* "src/backend/corebackend.cpp"
+ (("\\/usr") #$output)))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Library for managing partitions")
(description "Library for managing partitions.")

base-commit: c0895371c5759c7d9edb330774e90f192cc4cf2c
--
2.41.0
Nicolas Goaziou wrote 1 weeks ago
Re: [PATCH] gnu: Add partitionmanager.
(address . 66951-done@debbugs.gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
87tt8b2ije.fsf@nicolasgoaziou.fr
Hello,

This patch set was applied a while ago. Closing.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 66951@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66951
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help