[PATCH] gnu: Deprecate the "go-github-com-willf-bitset" variable; update the package.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 1 years ago
(address . guix-patches@gnu.org)
87il6h3llj.fsf@gmail.com
Hello,

this patchset replaces "go-github-com-willf-bitset" with
"go-github-com-bits-and-blooms-bitset" and updates the package.
From d6a423ea0db8651f1bd9315109b1257f1624f73c Mon Sep 17 00:00:00 2001
Message-ID: <d6a423ea0db8651f1bd9315109b1257f1624f73c.1699090499.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 4 Nov 2023 12:32:14 +0300
Subject: [PATCH 1/2] gnu: Deprecate the "go-github-com-willf-bitset" variable.

* gnu/packages/golang.scm (go-github-com-willf-bitset): Rename to
"go-github-com-bits-and-blooms-bitset".
[arguments]: Update.
[home-page]: Update.
(go-github-com-willf-bitset): Define as deprecated by
"go-github-com-bits-and-blooms-bitset".

Change-Id: Iaa31f120d1c2b18a5c916ea5e68b89bd3e534ffd
---
gnu/packages/golang.scm | 15 +++++++++------
1 file changed, 9 insertions(+), 6 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 93a375fd2f..51d563dc6a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8647,29 +8647,32 @@ (define-public go-github-com-mattn-go-sqlite3
@code{database/sql}.")
(license license:expat)))
-(define-public go-github-com-willf-bitset
+(define-public go-github-com-bits-and-blooms-bitset
(package
- (name "go-github-com-willf-bitset")
+ (name "go-github-com-bits-and-blooms-bitset")
(version "1.1.10")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/willf/bitset")
- (commit (string-append "v" version))))
+ (url "https://github.com/bits-and-blooms/bitset")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
"0wpaxg6va3qwd0hq0b8rpb1hswvzzbfm2h8sjmcsdpbkydjjx9zg"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/willf/bitset"))
+ '(#:import-path "github.com/bits-and-blooms/bitset"))
(synopsis "Bitsets in Go")
(description "This package provides a Go implementation of bitsets, which
are a mapping between non-negative integers and boolean values focused on
efficient space usage.")
- (home-page "https://github.com/willf/bitset")
+ (home-page "https://github.com/bits-and-blooms/bitset")
(license license:bsd-3)))
+(define-public go-github-com-willf-bitset
+ (deprecated-package "go-github-com-willf-bitset" go-github-com-bits-and-blooms-bitset))
+
(define-public go-github-com-willf-bloom
(package
(name "go-github-com-willf-bloom")

base-commit: c2358476e3f064b4ba512d81f8b8eea6e7b6913c
--
2.41.0
From 556e36b2f235e3c18b17b76334cf0857f42e5899 Mon Sep 17 00:00:00 2001
Message-ID: <556e36b2f235e3c18b17b76334cf0857f42e5899.1699090499.git.poptsov.artyom@gmail.com>
In-Reply-To: <d6a423ea0db8651f1bd9315109b1257f1624f73c.1699090499.git.poptsov.artyom@gmail.com>
References: <d6a423ea0db8651f1bd9315109b1257f1624f73c.1699090499.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sat, 4 Nov 2023 12:34:17 +0300
Subject: [PATCH 2/2] gnu: go-github-com-bits-and-blooms-bitset: Update to
1.11.0.

* gnu/packages/golang.scm (go-github-com-bits-and-blooms-bitset): Update to
1.11.0.

Change-Id: I36dff5e8434f736d448c4dc8918f36020d25303a
---
gnu/packages/golang.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 51d563dc6a..e326d49ebc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8650,7 +8650,7 @@ (define-public go-github-com-mattn-go-sqlite3
(define-public go-github-com-bits-and-blooms-bitset
(package
(name "go-github-com-bits-and-blooms-bitset")
- (version "1.1.10")
+ (version "1.11.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -8659,7 +8659,7 @@ (define-public go-github-com-bits-and-blooms-bitset
(file-name (git-file-name name version))
(sha256
(base32
- "0wpaxg6va3qwd0hq0b8rpb1hswvzzbfm2h8sjmcsdpbkydjjx9zg"))))
+ "1ialciixmr98p10rh61rnnkxpqi1j9hycbkv9rnjl0vnmsnpy0cy"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/bits-and-blooms/bitset"))
--
2.41.0
Thanks,

- avp

--
Artyom "avp" Poptsov <poptsov.artyom@gmail.com>
CADR Hackerspace co-founder: https://cadrspace.ru/
GPG: D0C2 EAC1 3310 822D 98DE B57C E9C5 A2D9 0898 A02F
-----BEGIN PGP SIGNATURE-----

iQJNBAEBCgA3FiEEAf2F9Bp7f4IFgwalk16+BzbchX4FAmVGEOgZHHBvcHRzb3Yu
YXJ0eW9tQGdtYWlsLmNvbQAKCRCTXr4HNtyFfoVhD/9uHmjA1I5pcTLUFLQ7FK+X
aZUkfVZ45w5Pzs5NEIBVCeT4167VcPTKB9+2dcc/c9BPLFMFXrE1JDCxrJPlrmSI
/5J2SfMOtIT8HFWztujDmSQM7CyynzH8tuyw1K1sXXSJsb+PkWnpfFtYvse+7ca/
En28ietWgmvvaolh2pO/LG0tNFz1Tf05nwZP7SnXXcqNk4WR9tyJAV3b30nlA/X9
aZ6QIUyIFM/obcYg0vz6gJrhO5BGqGBcYkP52R0a3H/zyt3z/rwJsPDLMbJfEnaz
a3NDdoweWZgoKS/zd6Xypeqd2lxigUd8rqaH0PhEzIL4zsPynVp7Ax//usvYhhyx
19V3ImEQSpLlZSaUUkwRXmrxo+fJwBugGplZWdYYhiKsqzxPaB8BgxVQuFLHzTEL
jWofYubM4sr8wcOTxu9ADF0BQh+RHN5QoxneWKxSn29W6MgJ54nXVBu7KzBV5W9R
E94H61h4ZkCMs6cn0n5BJh+8e9ZLIGzVzeut8TguF/+LnFSi6oWnZUkcQkM6jy5u
CX5jM6OegI4G3svu1q4xOBIU9QjjjPkA82MK2X62tt0arouFLo7/jB9AuHSMmVEs
wy+nIQ5lPCYTqZnY+IXMX8ZGurSDsnvR+MezmpoZD1YeUghlUE5895w5B3flrMD7
No+Z2afgBsWkww5DMnh0sg==
=mPih
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 1 years ago
control message for bug #66927
(address . control@debbugs.gnu.org)
87a5qpn0oo.fsf@gnu.org
close 66927
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66927@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66927
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help