[patch] Add r-screpertoire, r-powertcr, r-evmix, r-truncdist and r-evd

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 1 years ago
(address . guix-patches@gnu.org)
2c190d93-8086-4dc0-b492-1ea17c9874e1@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-screpertoire and r-powertcr): New
variables.

* gnu/packages/cran.scm (r-evmix, r-truncdist and r-evd): New variable.
Mădălin Ionel Patrașcu wrote 1 years ago
[PATCH 1/5] gnu: Add r-evd.
(address . 66921@debbugs.gnu.org)
295ae4566681826b406dea240db641124f1d60a0.1699029004.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-evd): New variable.

Change-Id: I1f3b2ee5829807f6f76cf87b4df43ae8005688bc
---
gnu/packages/cran.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f2a035555b..b8ae1fad14 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7112,6 +7112,28 @@ (define-public r-etrunct
which should be seen for details.")
(license license:expat)))
+(define-public r-evd
+ (package
+ (name "r-evd")
+ (version "2.3-6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "evd" version))
+ (sha256
+ (base32 "0wc95hfj0gwkyghipdrhwd3s6q2agh9x2wy6y7dr6mjw7wnmjb36"))))
+ (properties `((upstream-name . "evd")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/package=evd")
+ (synopsis "Functions for extreme value distributions")
+ (description
+ "This package extends simulation, distribution, quantile and density
+functions to univariate and multivariate parametric extreme value distributions,
+and provides fitting functions which calculate maximum likelihood estimates for
+univariate and bivariate maxima models, and for univariate and bivariate
+threshold models.")
+ (license license:gpl3)))
+
(define-public r-excelr
(package
(name "r-excelr")

base-commit: a0a377fdd6c873aeb6340afeddcd23b4ead7657d
--
2.41.0
Mădălin Ionel Patrașcu wrote 1 years ago
[PATCH 2/5] gnu: Add r-truncdist.
(address . 66921@debbugs.gnu.org)
40689c5253a6f5caa435b3aaf6844d892c35a70d.1699029004.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-truncdist): New variable.

Change-Id: Icb9f06a36e5ee5a58828dc2f496b71a850a911b9
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b8ae1fad14..d7334963ec 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8856,6 +8856,30 @@ (define-public r-truncnorm
functions, as well as a random generation function.")
(license license:gpl2)))
+(define-public r-truncdist
+ (package
+ (name "r-truncdist")
+ (version "1.0-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "truncdist" version))
+ (sha256
+ (base32 "02ihw4ixhadwr3sqm6r264i8vpcaz8pn69vkzabd8fwqvn5vcj5q"))))
+ (properties `((upstream-name . "truncdist")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-evd))
+ (home-page "https://cran.r-project.org/package=truncdist")
+ (synopsis "Truncated random variables")
+ (description
+ "This package provides a collection of tools to evaluate probability density
+functions, cumulative distribution functions, quantile functions and random
+numbers for truncated random variables. These functions are provided to also
+compute the expected value and variance. @acronym{Q-Q, quantile–quantile} plots
+can be produced. All the probability functions in the stats, stats4 and evd
+packages are automatically available for truncation.")
+ (license license:gpl2+)))
+
(define-public r-rsolnp
(package
(name "r-rsolnp")
--
2.41.0
Mădălin Ionel Patrașcu wrote 1 years ago
[PATCH 4/5] gnu: Add r-powertcr.
(address . 66921@debbugs.gnu.org)
a0a6740a9dd6042f0184388005eebd85b7e40172.1699029004.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-powertcr): New variable.

Change-Id: I75fc30a7021d6199b768318da3afcfeaaafcf027
---
gnu/packages/bioconductor.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d79236ea26..b683868df5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9236,6 +9236,37 @@ (define-public r-piano
set analyses.")
(license license:gpl2+)))
+(define-public r-powertcr
+ (package
+ (name "r-powertcr")
+ (version "1.22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "powerTCR" version))
+ (sha256
+ (base32 "06fmphdq95pjbbvm8m8h1wajbp3vhl0zj7ddbzks9fy7ankp1n3i"))))
+ (properties `((upstream-name . "powerTCR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-cubature
+ r-doparallel
+ r-evmix
+ r-foreach
+ r-magrittr
+ r-purrr
+ r-truncdist
+ r-vegan
+ r-vgam))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/powerTCR")
+ (synopsis "Model-based comparative analysis of the TCR repertoire")
+ (description
+ "This package provides a model for the clone size distribution of the
+@acronym{TCR, T-cell receptor} repertoire. Further, it permits comparative
+analysis of TCR repertoire libraries based on theoretical model fits.")
+ (license license:artistic2.0)))
+
;; This is a CRAN package, but it depends on a Bioconductor package:
;; r-aroma-light, r-dnacopy..
(define-public r-pscbs
--
2.41.0
Mădălin Ionel Patrașcu wrote 1 years ago
[PATCH 5/5] gnu: Add r-screpertoire.
(address . 66921@debbugs.gnu.org)
d9923f797e2b8e0a387633afdab92f319c39ba2b.1699029004.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-screpertoire): New variable.

Change-Id: Iaa876f787d5e39ca2888bf2082da3d7839224e15
---
gnu/packages/bioconductor.scm | 43 +++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b683868df5..8306b703de 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -10014,6 +10014,49 @@ (define-public r-scmap
different experiment.")
(license license:gpl3)))
+(define-public r-screpertoire
+ (package
+ (name "r-screpertoire")
+ (version "1.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "scRepertoire" version))
+ (sha256
+ (base32 "1wgs8dv5zl82iciy86w5ws1gq8v2piklcifbw7gmbw60kijyr2l1"))))
+ (properties `((upstream-name . "scRepertoire")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-doparallel
+ r-dplyr
+ r-ggalluvial
+ r-ggplot2
+ r-ggraph
+ r-igraph
+ r-plyr
+ r-powertcr
+ r-reshape2
+ r-rlang
+ r-seuratobject
+ r-singlecellexperiment
+ r-stringdist
+ r-stringr
+ r-summarizedexperiment
+ r-tidygraph
+ r-vegan))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/scRepertoire")
+ (synopsis "Toolkit for single-cell immune receptor profiling")
+ (description
+ "The scRepertoire package was built to process data derived from the 10x
+Genomics Chromium Immune Profiling for both @acronym{TCR, T-cell receptor} and
+@acronym{Ig, immunoglobulin} enrichment workflows and subsequently interacts with
+the popular Seurat and SingleCellExperiment R packages. It also allows for
+general analysis of single-cell clonotype information without the use of
+expression information. The package functions as a wrapper for Startrac and
+powerTCR R packages.")
+ (license license:gpl2)))
+
(define-public r-scry
(package
(name "r-scry")
--
2.41.0
Mădălin Ionel Patrașcu wrote 1 years ago
[PATCH 3/5] gnu: Add r-evmix.
(address . 66921@debbugs.gnu.org)
1decef87f8fc7d344825970f0b5f51ad0e820d71.1699029004.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-evmix): New variable.

Change-Id: I93152dee218e9cef85dd66e17231f1728f0ffb52
---
gnu/packages/cran.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d7334963ec..bc3158eea6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7134,6 +7134,35 @@ (define-public r-evd
threshold models.")
(license license:gpl3)))
+(define-public r-evmix
+ (package
+ (name "r-evmix")
+ (version "2.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "evmix" version))
+ (sha256
+ (base32 "02rabc9snci00s1x7h0svfr66lmw1wjcdg0149wc52mnccsdaivf"))))
+ (properties `((upstream-name . "evmix")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-gsl
+ r-mass
+ r-sparsem))
+ (home-page "http://www.math.canterbury.ac.nz/~c.scarrott/evmix.shtml")
+ (synopsis
+ "Extreme value threshold estimation and uncertainty quantification")
+ (description
+ "This package provides the usual distribution functions, maximum likelihood
+inference and model diagnostics for univariate stationary extreme value mixture
+models. Also, there are provided kernel density estimation including various
+boundary corrected kernel density estimation methods and a wide choice of kernels,
+with cross-validation likelihood based bandwidth estimator. Reasonable
+consistency with the base functions in the evd package is provided, so that users
+can safely interchange most code.")
+ (license license:gpl3)))
+
(define-public r-excelr
(package
(name "r-excelr")
--
2.41.0
Ricardo Wurmus wrote 1 years ago
Re: [bug#66921] [PATCH 1/5] gnu: Add r-evd.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 66921-done@debbugs.gnu.org)
877cmxrws8.fsf@elephly.net
Thanks for the patches. I’ve applied the series.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66921@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66921
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help