gnu: Add r-ewastools and r-mblm.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 1 years ago
(address . guix-patches@gnu.org)
a22bac1b-8401-4302-b377-0efccff47e77@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-ewastools): New variable.

* gnu/packages/cran.scm (r-mblm): New variable.
Mădălin Ionel Patrașcu wrote 1 years ago
[PATCH 2/2] gnu: Add r-ewastools.
(address . 66917@debbugs.gnu.org)
a3df51adf12ddf980958d0b0b2471a86741cc5ab.1699023357.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-ewastools): New variable.

Change-Id: I4117dbee188c7d9547fe63b2b89ec9258bbda60b
---
gnu/packages/bioinformatics.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a47e84bc33..11ca777fa2 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -876,6 +876,38 @@ (define-public r-conqur
simultaneously considered.")
(license license:gpl3))))
+(define-public r-ewastools
+ (let ((commit "f7646cacd73266708479b3fea5d625054d179f95")
+ (revision "1"))
+ (package
+ (name "r-ewastools")
+ (version (git-version "1.7.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hhhh5/ewastools/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0irarlnxfnasa755adxsn67rxsy01zwhjhw18g4cag08cqiyyw41"))))
+ (properties `((upstream-name . "ewastools")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-data-table
+ r-igraph
+ r-illuminaio
+ r-mblm
+ r-quadprog))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/hhhh5/ewastools/")
+ (synopsis
+ "Quality control toolset for the Illumina Infinium DNA methylation")
+ (description
+ "Collection of useful functions for working with DNA methylation
+micro-array data.")
+ (license license:unlicense))))
+
(define-public r-numbat
(let ((commit "4ab7752e7d267a3f443756675728521a9b0a7295")
(revision "1"))
--
2.41.0
Mădălin Ionel Patrașcu wrote 1 years ago
[PATCH 1/2] gnu: Add r-mblm.
(address . 66917@debbugs.gnu.org)
395c833b4e654eb62fb10c892716422b634080e5.1699023357.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-mblm): New variable.

Change-Id: Iddfa9bc03a4e5782623253cb70d1ae888545e2ec
---
gnu/packages/cran.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f2a035555b..ec7200749a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3149,6 +3149,27 @@ (define-public r-matrix-utils
objects.")
(license license:gpl3)))
+(define-public r-mblm
+ (package
+ (name "r-mblm")
+ (version "0.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mblm" version))
+ (sha256
+ (base32 "1fipb3bryaimr30lcxsxrn0ymv24z39swca7s4z7p9xcfg3ban1b"))))
+ (properties `((upstream-name . "mblm")))
+ (build-system r-build-system)
+ (home-page "https://www.r-project.org")
+ (synopsis "Median-based linear models")
+ (description
+ "This package provides linear models based on Theil-Sen single median and
+Siegel repeated medians. They are very robust (29 or 50 percent breakdown point,
+respectively), and if no outliers are present, the estimators are very similar
+to OLS.")
+ (license license:gpl2+)))
+
(define-public r-mboost
(package
(name "r-mboost")

base-commit: a0a377fdd6c873aeb6340afeddcd23b4ead7657d
--
2.41.0
Ricardo Wurmus wrote 1 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 66917-done@debbugs.gnu.org)
87fs1lsduy.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/cran.scm (r-mblm): New variable.

I applied this series with minor changes. Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66917@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66917
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help