[PATCH] gnu: Add r-ggbreak.

  • Done
  • quality assurance status badge
Details
2 participants
  • Afkhami, Navid
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Afkhami, Navid
Severity
normal

Debbugs page

Afkhami, Navid wrote 1 years ago
(address . guix-patches@gnu.org)(name . Afkhami, Navid)(address . Navid.Afkhami@mdc-berlin.de)
cebc3c0b4780bd8f620e863ff0f86b6f2437f003.1699021661.git.Navid.Afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-ggbreak): New variable.

Change-Id: I27d62d0110fb56e77dc8cf82581adb6259317c2d
---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 30f28f6adc..f54ad16e34 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -824,6 +824,26 @@ (define-public r-ggalt
text annotations.")
(license license:agpl3)))
+(define-public r-ggbreak
+ (package
+ (name "r-ggbreak")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggbreak" version))
+ (sha256
+ (base32 "14rx16v66xd0fjlywi89dq9dbw41zn7hpq14wgvf0178cxdp2fw4"))))
+ (properties `((upstream-name . "ggbreak")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-aplot r-ggfun r-ggplot2 r-ggplotify r-rlang))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/YuLab-SMU/ggbreak")
+ (synopsis "Set axis break for 'ggplot2'")
+ (description
+ "An implementation of scale functions for setting axis breaks of a ggplot.")
+ (license license:artistic2.0)))
+
(define-public r-ggdist
(package
(name "r-ggdist")

base-commit: 6ae8fd7aa7a843ea831b24b74c9d3f7ea3ff49a9
prerequisite-patch-id: 73f432e1cad3f22e00482218f8a8c252edf0c5dd
--
2.34.1
Ricardo Wurmus wrote 1 years ago
(address . 66916-done@debbugs.gnu.org)
87v8aisbo8.fsf@elephly.net
Thanks for the patch. I changed the description to use a complete
sentence and pushed it to the “master” branch.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66916@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66916
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help