[PATCH] gnu: Add r-methylaid.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 1 years ago
(address . guix-patches@gnu.org)
f27900741fbff9dfd4d846918b0797e600bc2e9e.1699019477.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-methylaid): New variable.

Change-Id: I7839035e5316bdbe5f1386b7b41ed2fc440fb432
---
gnu/packages/bioconductor.scm | 38 +++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d79236ea26..c60f440f3f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8454,6 +8454,44 @@ (define-public r-metaneighbor
profiles than cells of different types.")
(license license:expat)))
+(define-public r-methylaid
+ (package
+ (name "r-methylaid")
+ (version "1.36.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "MethylAid" version))
+ (sha256
+ (base32 "0mzml9j6f7yycf9747ikkpfvxnwji07h8jhwa9a54ix2d0wyxk3d"))))
+ (properties `((upstream-name . "MethylAid")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biobase
+ r-biocgenerics
+ r-biocparallel
+ r-ggplot2
+ r-gridbase
+ r-hexbin
+ r-matrixstats
+ r-minfi
+ r-rcolorbrewer
+ r-shiny
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://git.bioconductor.org/packages/MethylAid")
+ (synopsis
+ "Quality control of large Illumina DNA Methylation array data sets")
+ (description
+ "This package provides a visual and interactive web application using
+RStudio's shiny package. Bad quality samples are detected using sample-dependent
+and sample-independent controls present on the array and user adjustable
+thresholds. In depth exploration of bad quality samples can be performed using
+several interactive diagnostic plots of the quality control probes present on
+the array. Furthermore, the impact of any batch effect provided by the user can
+be explored.")
+ (license license:gpl2+)))
+
(define-public r-methylkit
(package
(name "r-methylkit")

base-commit: a0a377fdd6c873aeb6340afeddcd23b4ead7657d
--
2.41.0
Ricardo Wurmus wrote 1 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 66915-done@debbugs.gnu.org)
87o7g9sg7m.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/bioconductor.scm (r-methylaid): New variable.

Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66915@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66915
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help