Mădălin Ionel Patrașcu wrote 1 years ago
(address . guix-patches@gnu.org)
* gnu/packages/bioconductor.scm (r-methylaid): New variable.
Change-Id: I7839035e5316bdbe5f1386b7b41ed2fc440fb432
---
gnu/packages/bioconductor.scm | 38 +++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)
Toggle diff (53 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d79236ea26..c60f440f3f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8454,6 +8454,44 @@ (define-public r-metaneighbor
profiles than cells of different types.")
(license license:expat)))
+(define-public r-methylaid
+ (package
+ (name "r-methylaid")
+ (version "1.36.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "MethylAid" version))
+ (sha256
+ (base32 "0mzml9j6f7yycf9747ikkpfvxnwji07h8jhwa9a54ix2d0wyxk3d"))))
+ (properties `((upstream-name . "MethylAid")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biobase
+ r-biocgenerics
+ r-biocparallel
+ r-ggplot2
+ r-gridbase
+ r-hexbin
+ r-matrixstats
+ r-minfi
+ r-rcolorbrewer
+ r-shiny
+ r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://git.bioconductor.org/packages/MethylAid")
+ (synopsis
+ "Quality control of large Illumina DNA Methylation array data sets")
+ (description
+ "This package provides a visual and interactive web application using
+RStudio's shiny package. Bad quality samples are detected using sample-dependent
+and sample-independent controls present on the array and user adjustable
+thresholds. In depth exploration of bad quality samples can be performed using
+several interactive diagnostic plots of the quality control probes present on
+the array. Furthermore, the impact of any batch effect provided by the user can
+be explored.")
+ (license license:gpl2+)))
+
(define-public r-methylkit
(package
(name "r-methylkit")
base-commit: a0a377fdd6c873aeb6340afeddcd23b4ead7657d
--
2.41.0