Add r-bsgenome-hsapiens-ucsc-hg38-masked and r-dnamcrosshyb.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 1 years ago
(address . guix-patches@gnu.org)
c0f88b27-2a37-41a0-acf3-75ab334ff358@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-bsgenome-hsapiens-ucsc-hg38-masked
and r-dnamcrosshyb): New variables.
Mădălin Ionel Patrașcu wrote 1 years ago
[PATCH 2/2] gnu: Add r-dnamcrosshyb.
(address . 66914@debbugs.gnu.org)
045773685530dae0ff4ea375c219efc35f62a23b.1699018860.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-dnamcrosshyb): New variable.

Change-Id: I19e332e6adf0ce9cc721d89bb74a1aa709778873
---
gnu/packages/bioconductor.scm | 45 +++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ac09a079b4..d5d5e9d25d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -12636,6 +12636,51 @@ (define-public r-dnabarcodes
demultiplexed, i.e. assigned to their original reference barcode.")
(license license:gpl2)))
+;; It depends on Bioconductor packages
+(define-public r-dnamcrosshyb
+ ;; There aren't any releases.
+ (let ((commit "fe8acb33667e81f00dcb84e0fa75c87ab2db5d8f")
+ (revision "1"))
+ (package
+ (name "r-dnamcrosshyb")
+ (version (git-version "0.0.0.9000" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pjhop/DNAmCrosshyb")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12j1xsiqpvny5rp23z1az0k4cj5ajbcwkg65z00s16vywi2rx6nb"))))
+ (properties `((upstream-name . "DNAmCrosshyb")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocgenerics
+ r-biocparallel
+ r-biostrings
+ r-bsgenome-hsapiens-ucsc-hg19-masked
+ r-bsgenome-hsapiens-ucsc-hg38-masked
+ r-dplyr
+ r-genomicranges
+ r-ggplot2
+ r-iranges
+ r-magrittr
+ r-minfi
+ r-purrr
+ r-s4vectors
+ r-shiny
+ r-stringi
+ r-stringr
+ r-tibble
+ r-tidyr
+ r-watermelon))
+ (home-page "https://github.com/pjhop/DNAmCrosshyb")
+ (synopsis "DNAmCrosshyb")
+ (description
+ "Helper functions to detect cross-hybridization on Illumina DNAm arrays")
+ (license license:gpl3))))
+
(define-public r-ruvseq
(package
(name "r-ruvseq")
--
2.41.0
Mădălin Ionel Patrașcu wrote 1 years ago
[PATCH 1/2] gnu: Add r-bsgenome-hsapiens-ucsc-hg38-masked.
(address . 66914@debbugs.gnu.org)
fcb3821b9f4004beecb10c285fbfd4dd58d0c1b6.1699018860.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm
(r-bsgenome-hsapiens-ucsc-hg38-masked): New variable.

Change-Id: Ic1b646a3bd3b7262dd82f0972961c2e89628e90b
---
gnu/packages/bioconductor.scm | 36 +++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d79236ea26..ac09a079b4 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -68,6 +68,42 @@ (define-module (gnu packages bioconductor)
;;; Annotations
+(define-public r-bsgenome-hsapiens-ucsc-hg38-masked
+ (package
+ (name "r-bsgenome-hsapiens-ucsc-hg38-masked")
+ (version "1.4.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "BSgenome.Hsapiens.UCSC.hg38.masked" version
+ 'annotation))
+ (sha256
+ (base32 "0j71hdxqvvc0s8mc6jp6zk502mrf095qazj95yzzb4rm6sjvd20m"))))
+ (properties `((upstream-name . "BSgenome.Hsapiens.UCSC.hg38.masked")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bsgenome r-bsgenome-hsapiens-ucsc-hg38
+ r-genomeinfodb))
+ (home-page
+ "https://bioconductor.org/packages/BSgenome.Hsapiens.UCSC.hg38.masked")
+ (synopsis
+ "Full masked genomic sequences for Homo sapiens (UCSC version hg38)")
+ (description
+ "This package provides the complete genome sequences for Homo sapiens as
+provided by UCSC (genome hg38, based on assembly GRCh38.p14 since 2023/01/31).
+The sequences are the same as in BSgenome.Hsapiens.UCSC.hg38, except that each
+of them has the 4 following masks on top:
+
+@enumerate
+@item the mask of assembly gaps (AGAPS mask);
+@item the mask of intra-contig ambiguities (AMB mask);
+@item the mask of repeats from @code{RepeatMasker} (RM mask);
+@item the mask of repeats from Tandem Repeats Finder (TRF mask).
+@end enumerate
+
+Only the AGAPS and AMB masks are \"active\" by default. The sequences are stored
+in @code{MaskedDNAString} objects.")
+ (license license:artistic2.0)))
+
(define-public r-mafh5-gnomad-v3-1-2-grch38
(package
(name "r-mafh5-gnomad-v3-1-2-grch38")

base-commit: a0a377fdd6c873aeb6340afeddcd23b4ead7657d
--
2.41.0
Ricardo Wurmus wrote 1 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 66914-done@debbugs.gnu.org)
87jzqxsfih.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (3 lines)
> * gnu/packages/bioconductor.scm
> (r-bsgenome-hsapiens-ucsc-hg38-masked): New variable.

I applied this series after moving r-dnamcrosshyb to (gnu packages
bioinformatics) because it is neither a CRAN nor Bioconductor package.

Thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66914@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66914
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help