[PATCH] gnu: Add r-miamiplot.

  • Done
  • quality assurance status badge
Details
2 participants
  • Afkhami, Navid
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Afkhami, Navid
Severity
normal

Debbugs page

Afkhami, Navid wrote 1 years ago
(address . guix-patches@gnu.org)(name . Afkhami, Navid)(address . Navid.Afkhami@mdc-berlin.de)
c6504183be8232325fb5af56c99bf34331aead24.1699016729.git.Navid.Afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-miamiplot): New variable.

Change-Id: I41a3a951c6f1835800301e4c168eeeb0dd299f06
---
gnu/packages/bioinformatics.scm | 34 +++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3a4bcd093a..e36593fd8e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10665,6 +10665,40 @@ (define-public r-scde
;; See https://github.com/hms-dbmi/scde/issues/38
(license license:gpl2)))
+(define-public r-miamiplot
+ (let ((commit "beede9c5d6431b4d822aa42e064e01baeb5dd4a0")
+ (revision "1"))
+ (package
+ (name "r-miamiplot")
+ (version (git-version "1.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/juliedwhite/miamiplot")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wxxk1lk9jbf0imf59qp302ffasvs84idinkvzirs3dw9w3589n9"))))
+ (properties `((upstream-name . "miamiplot")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-checkmate
+ r-dplyr
+ r-ggplot2
+ r-ggrepel
+ r-gridextra
+ r-magrittr
+ r-rlang))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/juliedwhite/miamiplot")
+ (synopsis "Create a ggplot2 miami plot")
+ (description
+ "This package generates a Miami plot with centered chromosome labels.
+The output is a ggplot2 object. Users can specify which data they
+want plotted on top vs. bottom , whether to display significance
+line(s), what colors to give chromosomes, and what points to label.")
+ (license license:gpl2))))
+
(define-public r-millefy
(package
(name "r-millefy")

base-commit: 28ebbe2be8829a4767b9789c6353ad5e826d1164
--
2.34.1
Ricardo Wurmus wrote 1 years ago
(address . 66913-done@debbugs.gnu.org)
87zfzvrnh5.fsf@elephly.net
Applied, thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66913@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66913
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help