[PATCH 0/2] *** r-nestedcv and r-matrixtests ***

  • Done
  • quality assurance status badge
Details
2 participants
  • Afkhami, Navid
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Afkhami, Navid
Severity
normal

Debbugs page

Afkhami, Navid wrote 1 years ago
(address . guix-patches@gnu.org)(name . Afkhami, Navid)(address . Navid.Afkhami@mdc-berlin.de)
cover.1698943587.git.Navid.Afkhami@mdc-berlin.de
*** The main package is r-nestedcv and r-matrixtests is the dependency. Thanks ***

Afkhami, Navid (2):
gnu: Add r-nestedcv.
gnu: Add r-matrixtests.

gnu/packages/cran.scm | 58 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 58 insertions(+)


base-commit: f5346094f0365a2c04ca00111ff06e17dac832e2
--
2.41.0
Afkhami, Navid wrote 1 years ago
[PATCH 1/2] gnu: Add r-nestedcv.
(address . 66899@debbugs.gnu.org)(name . Afkhami, Navid)(address . Navid.Afkhami@mdc-berlin.de)
783df83f420d6c5b18fabb338b42f9aa90d90528.1698945230.git.Navid.Afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-nestedcv): New variable.

Change-Id: Id998b4192565c220f8d238963ef61217aed12bd3
---
gnu/packages/cran.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e82b027052..5aff1a2dd5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10007,6 +10007,43 @@ (define-public r-n2r
@acronym{NSW, Navigable Small World} graphs.")
(license license:asl2.0)))
+(define-public r-nestedcv
+ (package
+ (name "r-nestedcv")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "nestedcv" version))
+ (sha256
+ (base32 "0jpg4il1niyizfq8kkk391x7anhp2s38mrfypa86skr08ca46zss"))))
+ (properties `((upstream-name . "nestedcv")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-caret
+ r-data-table
+ r-doparallel
+ r-foreach
+ r-ggplot2
+ r-glmnet
+ r-matrixstats
+ r-matrixtests
+ r-proc
+ r-rfast
+ r-rlang))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/myles-lewis/nestedcv")
+ (synopsis "Nested cross-validation with 'glmnet' and 'caret'")
+ (description
+ "Nested cross-validation applied to the glmnet and caret packages.
+With glmnet this includes cross-validation of elastic net alpha
+parameter. A number of feature selection filter functions
+(t-test, Wilcoxon test, ANOVA, Pearson/Spearman correlation,
+random forest, ReliefF) for feature selection are provided and
+can be embedded within the outer loop of the nested CV. Nested
+CV can be also be performed with the caret package giving access
+to the large number of prediction methods available in caret.")
+ (license license:expat)))
+
(define-public r-network
(package
(name "r-network")

base-commit: f5346094f0365a2c04ca00111ff06e17dac832e2
--
2.34.1
Afkhami, Navid wrote 1 years ago
[PATCH 2/2] gnu: Add r-matrixtests.
(address . 66899@debbugs.gnu.org)(name . Afkhami, Navid)(address . Navid.Afkhami@mdc-berlin.de)
f0d912d69600501fce0c8e4cc2bac323889e39a0.1698945230.git.Navid.Afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-matrixtests): New variable.

Change-Id: I62f7bd760fc8603425906c304ef4293da1c0cf61
---
gnu/packages/cran.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5aff1a2dd5..6ff4c9324a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3125,6 +3125,27 @@ (define-public r-grr
functions are simplified but can be faster or have other advantages.")
(license license:gpl3)))
+(define-public r-matrixtests
+ (package
+ (name "r-matrixtests")
+ (version "0.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "matrixTests" version))
+ (sha256
+ (base32 "0d7i00cxzszfdnjm8q5b72ildic8nig6fbw7rba6acdnllpp7sza"))))
+ (properties `((upstream-name . "matrixTests")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-matrixstats))
+ (home-page "https://github.com/karoliskoncevicius/matrixTests")
+ (synopsis "Statistical hypothesis tests on rows and columns of matrices")
+ (description
+ "This package offers quick statistical hypothesis testing for matrix rows/columns.
+The main goals are speed through vectorization, detailed and user-friendly
+output, and compatibility with tests implemented in R.")
+ (license license:gpl2)))
+
(define-public r-matrix-utils
(package
(name "r-matrix-utils")
--
2.34.1
Ricardo Wurmus wrote 1 years ago
[PATCH 0/2] *** r-nestedcv and r-matrixtests ***
(address . 66899-done@debbugs.gnu.org)
878r7gt5t2.fsf@elephly.net
Thanks for the patches! I applied them with minor changes to the
descriptions.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66899@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66899
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help