[PATCH] gnu: Add rivercarro layout generator for river wayland compositor

  • Open
  • quality assurance status badge
Details
One participant
  • Alec Barreto
Owner
unassigned
Submitted by
Alec Barreto
Severity
normal
A
A
Alec Barreto wrote on 2 Nov 2023 07:15
(address . guix-patches@gnu.org)(name . Alec Barreto)(address . mrh57@posteo.net)
1c2acb3b299bc412dbe2c18f843f6f7be7312064.1698905726.git.mrh57@posteo.net
Change-Id: Id9d1d808fae3ac6e0469cbe294a9a3652ce19101
---
gnu/packages/zig-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index 200b5c9940..540c96860b 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -70,6 +70,31 @@ (define-public river
directly from a tty using KMS/DRM.")
(license license:gpl3)))
+(define-public rivercarro
+ (package
+ (name "rivercarro")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~novakane/rivercarro")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1a852hkakha3f5djnd8jrmkcq0xcdxbcbidr2kkfbqrhni9p33cl"))))
+ (build-system zig-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases (modify-phases %standard-phases (delete 'validate-runpath))))
+ (native-inputs (list pkg-config wayland wayland-protocols))
+ (home-page "https://git.sr.ht/~novakane/rivercarro")
+ (synopsis "A slightly modified version of rivertile layout generator for river")
+ (description
+ "A modified version of rivertile which adds: monocle layout, gaps rather than padding, gap size modification at run time, and smart gaps.")
+ (license license:gpl3)))
+
(define-public tigerbeetle
(package
(name "tigerbeetle")

base-commit: 0647f308b46b7ba7aa136068712f8d82d69d1a35
--
This is my first git email patch, so pardon any mistakes.
Rivercarro is a simple package which adds additional ways to generate layouts for the river wayland compositor.
This version, 0.2.1, is not the newest version, it is about 9 months old. The newest version, 0.3.0, requires zig 0.11 to build, but the newest version of zig packaged for guix is 0.10. I would have updated zig mysmelf first, but the move from zig 0.10 -> 0.11 is rather complicated. It's unlikely anyone will update zig for guix in the near future. I was going to package rivercarro before then at least for myself, so I figured I'd do the checks and submit it.
It builds reproducibly and without error on my machine (x86_64). I also use it daily and have encountered no issues.
A
A
Alec Barreto wrote on 4 Nov 2023 20:48
[PATCH v2] gnu: Add rivercarro layout generator for river wayland compositor
(address . 66894@debbugs.gnu.org)(name . Alec Barreto)(address . mrh57@posteo.net)
f4be75d808371d1bb05b27f9f7bf97cdda83d928.1699127283.git.mrh57@posteo.net
Linting issues should be fixed.

The build is succeeding on x86 but failing on arm.
This seems to be a zig issue which has since been fixed in zig 0.11 - https://github.com/ziglang/zig/issues/16800

However as mentioned guix only has zig 0.10 and probably won't be getting zig 0.11 any time soon.

Change-Id: Id9d1d808fae3ac6e0469cbe294a9a3652ce19101

gnu: fix formatting according to =guix lint=

Change-Id: Id61ff3c16f374e7211df2446ad3c6f09598f8981
---
gnu/packages/zig-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index 200b5c9940..48ccbf32d8 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -70,6 +70,35 @@ (define-public river
directly from a tty using KMS/DRM.")
(license license:gpl3)))
+(define-public rivercarro
+ (package
+ (name "rivercarro")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~novakane/rivercarro")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1a852hkakha3f5djnd8jrmkcq0xcdxbcbidr2kkfbqrhni9p33cl"))))
+ (build-system zig-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ (delete 'validate-runpath))))
+ (native-inputs (list pkg-config wayland wayland-protocols))
+ (home-page "https://git.sr.ht/~novakane/rivercarro")
+ (synopsis
+ "Slightly modified version of rivertile layout generator for river")
+ (description
+ "Modified version of rivertile which adds:
+monocle layout, gaps rather than padding,
+gap size modification at run time, and smart gaps.")
+ (license license:gpl3)))
+
(define-public tigerbeetle
(package
(name "tigerbeetle")

base-commit: e3f318f0489322c4c9b5964f03a8b063a7bfbebd
--
2.41.0
A
A
Alec Barreto wrote on 7 Nov 2023 03:51
[PATCH] gnu: Add rivercarro layout generator for river wayland compositor
(address . 66894@debbugs.gnu.org)
87wmuuqnqz.fsf@posteo.net
Also note that the package has no tests (hence why set to =#f=), and
also that the removal of the =validate-runpath= check comes from river itself (see
the definition of the river package for more info).
A
A
Alec Barreto wrote on 13 Nov 2023 19:46
(address . 66894@debbugs.gnu.org)
87fs19cwzz.fsf@posteo.net
Any thoughts on this?
A
A
Alec Barreto wrote on 22 Feb 03:51 +0100
(address . 66894@debbugs.gnu.org)
87jzmx8b47.fsf@posteo.net
friendly ping
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 66894@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66894
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch