Spencer Skylar Chan wrote 1 years ago
(name . guix-patches)(address . guix-patches@gnu.org)
From 1ea1bc0f2740cb62f230f6a9811f75e83ca35a51 Mon Sep 17 00:00:00 2001
From: Skylar Chan <schan12@umd.edu>
Date: Tue, 31 Oct 2023 20:33:49 -0400
Subject: [PATCH] gnu: lowdown: Update to 1.0.2.
* gnu/packages/markup.scm (lowdown): Update to 1.0.2.
[source]: Use upstream tarball and switch to url-fetch.
Change-Id: I2268c587be2fddb43fdf9ae957b6e5344e5f2984
---
gnu/packages/markup.scm | 59 +++++++++++++++++++----------------------
1 file changed, 27 insertions(+), 32 deletions(-)
Toggle diff (75 lines)
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index ad2d74f742..f432936033 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -125,39 +125,34 @@ (define-public markdown
"See License.text in the distribution."))))
(define-public lowdown
- (let ((commit "1de10c1d71bfb4348ae0beaec8b1547d5e114969")
- (revision "1"))
- (package
- (name "lowdown")
- (version (git-version "0.10.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kristapsdz/lowdown")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1wh07nkiihvp1m79sj4qlnqklnn0rfp3hwls8sqcp0bfd96wpa1h"))))
- (build-system gnu-build-system)
- (arguments
- (list
- #:test-target "regress"
- #:phases
- #~(modify-phases %standard-phases
- (replace 'configure
- (lambda _
- (invoke "./configure"
- (string-append "PREFIX=" #$output)
- (string-append "MANDIR=" #$output "/share/man")))))
- #:make-flags #~(list "CFLAGS=-fPIC")))
- (native-inputs
- (list which))
- (home-page "https://kristaps.bsd.lv/lowdown/")
- (synopsis "Simple Markdown translator")
- (description "Lowdown is a Markdown translator producing HTML5,
+ (package
+ (name "lowdown")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://kristaps.bsd.lv/lowdown/snapshots/lowdown-" version ".tar.gz"))
+ (sha256
+ (base32 "11c4l2z56dvwpyjg97xv39s0127axjr9vs7anzgfrbrrzx0hsnz4"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:test-target "regress"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "./configure"
+ (string-append "PREFIX=" #$output)
+ (string-append "MANDIR=" #$output "/share/man")))))
+ #:make-flags #~(list "CFLAGS=-fPIC")))
+ (native-inputs
+ (list which))
+ (home-page "https://kristaps.bsd.lv/lowdown/")
+ (synopsis "Simple Markdown translator")
+ (description "Lowdown is a Markdown translator producing HTML5,
roff documents in the ms and man formats, LaTeX, gemini, and terminal output.")
- (license license:isc))))
+ (license license:isc)))
(define-public discount
(package
base-commit: a0a377fdd6c873aeb6340afeddcd23b4ead7657d
--
2.39.2