[PATCH] gnu: lowdown: Update to 1.0.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • iyzsong
  • Spencer Skylar Chan
Owner
unassigned
Submitted by
Spencer Skylar Chan
Severity
normal

Debbugs page

Spencer Skylar Chan wrote 1 years ago
(name . guix-patches)(address . guix-patches@gnu.org)
CAOEsZhRKgtT6=vW1kEZzcJkw456ha+cL9Z_As3vCniLUPBEWfA@mail.gmail.com

From 1ea1bc0f2740cb62f230f6a9811f75e83ca35a51 Mon Sep 17 00:00:00 2001
From: Skylar Chan <schan12@umd.edu>
Date: Tue, 31 Oct 2023 20:33:49 -0400
Subject: [PATCH] gnu: lowdown: Update to 1.0.2.

* gnu/packages/markup.scm (lowdown): Update to 1.0.2.
[source]: Use upstream tarball and switch to url-fetch.

Change-Id: I2268c587be2fddb43fdf9ae957b6e5344e5f2984
---
gnu/packages/markup.scm | 59 +++++++++++++++++++----------------------
1 file changed, 27 insertions(+), 32 deletions(-)

Toggle diff (75 lines)
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index ad2d74f742..f432936033 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -125,39 +125,34 @@ (define-public markdown
"See License.text in the distribution."))))
(define-public lowdown
- (let ((commit "1de10c1d71bfb4348ae0beaec8b1547d5e114969")
- (revision "1"))
- (package
- (name "lowdown")
- (version (git-version "0.10.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kristapsdz/lowdown")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1wh07nkiihvp1m79sj4qlnqklnn0rfp3hwls8sqcp0bfd96wpa1h"))))
- (build-system gnu-build-system)
- (arguments
- (list
- #:test-target "regress"
- #:phases
- #~(modify-phases %standard-phases
- (replace 'configure
- (lambda _
- (invoke "./configure"
- (string-append "PREFIX=" #$output)
- (string-append "MANDIR=" #$output "/share/man")))))
- #:make-flags #~(list "CFLAGS=-fPIC")))
- (native-inputs
- (list which))
- (home-page "https://kristaps.bsd.lv/lowdown/")
- (synopsis "Simple Markdown translator")
- (description "Lowdown is a Markdown translator producing HTML5,
+ (package
+ (name "lowdown")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://kristaps.bsd.lv/lowdown/snapshots/lowdown-" version ".tar.gz"))
+ (sha256
+ (base32 "11c4l2z56dvwpyjg97xv39s0127axjr9vs7anzgfrbrrzx0hsnz4"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:test-target "regress"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "./configure"
+ (string-append "PREFIX=" #$output)
+ (string-append "MANDIR=" #$output "/share/man")))))
+ #:make-flags #~(list "CFLAGS=-fPIC")))
+ (native-inputs
+ (list which))
+ (home-page "https://kristaps.bsd.lv/lowdown/")
+ (synopsis "Simple Markdown translator")
+ (description "Lowdown is a Markdown translator producing HTML5,
roff documents in the ms and man formats, LaTeX, gemini, and terminal output.")
- (license license:isc))))
+ (license license:isc)))
(define-public discount
(package

base-commit: a0a377fdd6c873aeb6340afeddcd23b4ead7657d
--
2.39.2
Spencer Skylar Chan wrote 1 years ago
[PATCH v2] gnu: lowdown: Update to 1.0.2.
(address . 66883@debbugs.gnu.org)
CAOEsZhT4+C0YeGU41F7ha+yB137rN34giPvjpwAjCsvB3MGLyA@mail.gmail.com
Fixes broken Nix build.
From 8a8b46b472189c447f4eeda0647d8267754377b8 Mon Sep 17 00:00:00 2001
From: Skylar Chan <schan12@umd.edu>
Date: Tue, 31 Oct 2023 20:33:49 -0400
Subject: [PATCH v2] gnu: lowdown: Update to 1.0.2.

* gnu/packages/markup.scm (lowdown): Update to 1.0.2.
[source]: Use upstream tarball and switch to url-fetch.
[arguments]: Invoke make with explicit install targets.

Change-Id: I2268c587be2fddb43fdf9ae957b6e5344e5f2984
---
gnu/packages/markup.scm | 62 ++++++++++++++++++++---------------------
1 file changed, 30 insertions(+), 32 deletions(-)

Toggle diff (78 lines)
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index ad2d74f742..b3277fb368 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -125,39 +125,37 @@ (define-public markdown
"See License.text in the distribution."))))
(define-public lowdown
- (let ((commit "1de10c1d71bfb4348ae0beaec8b1547d5e114969")
- (revision "1"))
- (package
- (name "lowdown")
- (version (git-version "0.10.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kristapsdz/lowdown")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1wh07nkiihvp1m79sj4qlnqklnn0rfp3hwls8sqcp0bfd96wpa1h"))))
- (build-system gnu-build-system)
- (arguments
- (list
- #:test-target "regress"
- #:phases
- #~(modify-phases %standard-phases
- (replace 'configure
- (lambda _
- (invoke "./configure"
- (string-append "PREFIX=" #$output)
- (string-append "MANDIR=" #$output "/share/man")))))
- #:make-flags #~(list "CFLAGS=-fPIC")))
- (native-inputs
- (list which))
- (home-page "https://kristaps.bsd.lv/lowdown/")
- (synopsis "Simple Markdown translator")
- (description "Lowdown is a Markdown translator producing HTML5,
+ (package
+ (name "lowdown")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://kristaps.bsd.lv/lowdown/snapshots/lowdown-" version ".tar.gz"))
+ (sha256
+ (base32 "11c4l2z56dvwpyjg97xv39s0127axjr9vs7anzgfrbrrzx0hsnz4"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:test-target "regress"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "./configure"
+ (string-append "PREFIX=" #$output)
+ (string-append "MANDIR=" #$output "/share/man"))))
+ (replace 'install
+ (lambda _
+ (invoke "make" "install" "install_libs"))))
+ #:make-flags #~(list "CFLAGS=-fPIC")))
+ (native-inputs
+ (list which))
+ (home-page "https://kristaps.bsd.lv/lowdown/")
+ (synopsis "Simple Markdown translator")
+ (description "Lowdown is a Markdown translator producing HTML5,
roff documents in the ms and man formats, LaTeX, gemini, and terminal output.")
- (license license:isc))))
+ (license license:isc)))
(define-public discount
(package

base-commit: f5346094f0365a2c04ca00111ff06e17dac832e2
--
2.39.2
iyzsong wrote 1 years ago
[PATCH v3] gnu: lowdown: Update to 1.1.0.
(address . 66883@debbugs.gnu.org)
8d74ebf2415c7fc5441f5df3caa6809849e30500.1699662419.git.iyzsong@member.fsf.org
From: Skylar Chan <schan12@umd.edu>

* gnu/packages/markup.scm (lowdown): Update to 1.1.0.
[source]: Use upstream tarball and switch to url-fetch.
[arguments]<phases>: Install with "make install install_libs".

Change-Id: I2268c587be2fddb43fdf9ae957b6e5344e5f2984
Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
---
gnu/packages/markup.scm | 66 ++++++++++++++++++++---------------------
1 file changed, 33 insertions(+), 33 deletions(-)

Toggle diff (82 lines)
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 6ee7bebf57..595b08fa20 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -125,39 +125,39 @@ (define-public markdown
"See License.text in the distribution."))))
(define-public lowdown
- (let ((commit "1de10c1d71bfb4348ae0beaec8b1547d5e114969")
- (revision "1"))
- (package
- (name "lowdown")
- (version (git-version "0.10.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kristapsdz/lowdown")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1wh07nkiihvp1m79sj4qlnqklnn0rfp3hwls8sqcp0bfd96wpa1h"))))
- (build-system gnu-build-system)
- (arguments
- (list
- #:test-target "regress"
- #:phases
- #~(modify-phases %standard-phases
- (replace 'configure
- (lambda _
- (invoke "./configure"
- (string-append "PREFIX=" #$output)
- (string-append "MANDIR=" #$output "/share/man")))))
- #:make-flags #~(list "CFLAGS=-fPIC")))
- (native-inputs
- (list which))
- (home-page "https://kristaps.bsd.lv/lowdown/")
- (synopsis "Simple Markdown translator")
- (description "Lowdown is a Markdown translator producing HTML5,
-roff documents in the ms and man formats, LaTeX, gemini, and terminal output.")
- (license license:isc))))
+ (package
+ (name "lowdown")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://kristaps.bsd.lv/lowdown/snapshots/lowdown-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0y88gffrg1zrin0y53j4gbkmpia0r8p0kyklj501wavkqi83j7pk"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:test-target "regress"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "./configure"
+ (string-append "PREFIX=" #$output)
+ (string-append "MANDIR=" #$output "/share/man"))))
+ (replace 'install
+ (lambda _
+ (invoke "make" "install" "install_libs"))))
+ #:make-flags #~(list "CFLAGS=-fPIC")))
+ (native-inputs
+ (list which))
+ (home-page "https://kristaps.bsd.lv/lowdown/")
+ (synopsis "Simple Markdown translator")
+ (description "Lowdown is a Markdown translator producing HTML5, roff
+documents in the ms and man formats, LaTeX, gemini, and terminal output.")
+ (license license:isc)))
(define-public discount
(package

base-commit: bb3ab24a296ffa5273b2e82a02ed057e90c095f3
prerequisite-patch-id: 43b7202bd62a4488685baa7436d94a6b1aecbb0e
--
2.41.0
宋文武 wrote 1 years ago
Re: [bug#66883] [PATCH v2] gnu: lowdown: Update to 1.0.2.
(name . Spencer Skylar Chan)(address . schan12@umd.edu)(address . 66883-done@debbugs.gnu.org)
87sf5d6s3n.fsf@envs.net
Spencer Skylar Chan <schan12@umd.edu> writes:

Hello, I apply this patch to master with some updates (v3 patch):
- Update to version 1.1.0.
- Put url line under 80 columns.
- Adjust commit message for "install_libs".

Thanks.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66883@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66883
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help