Spencer Skylar Chan wrote 1 years ago
(name . guix-patches)(address . guix-patches@gnu.org)
From 379bd2aed0d94c6598b0a9779a4a8f79bd8af96f Mon Sep 17 00:00:00 2001
From: Skylar Chan <schan12@umd.edu>
Date: Tue, 31 Oct 2023 20:36:27 -0400
Subject: [PATCH] gnu: cmark-gfm: Update to 0.29.0.gfm.13.
* gnu/packages/markup.scm (cmark-gfm): Update to 0.29.0.gfm.13.
[arguments]: Use G-expressions.
Change-Id: Id8f856cfa8020bc8028d9bf3041a7c651b8b0102
---
gnu/packages/markup.scm | 19 +++++++++----------
1 file changed, 9 insertions(+), 10 deletions(-)
Toggle diff (42 lines)
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index ad2d74f742..6ee7bebf57 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -391,7 +391,7 @@ (define-public cmark-gfm
(package
(inherit cmark)
(name "cmark-gfm")
- (version "0.29.0.gfm.2")
+ (version "0.29.0.gfm.13")
(home-page "https://github.com/github/cmark-gfm")
(source (origin
(method git-fetch)
@@ -399,16 +399,15 @@ (define-public cmark-gfm
(file-name (git-file-name name version))
(sha256
(base32
- "0vz6zs3m22k7jzfj4782lahciwfjlbi4m3qz5crsmssip3rwdy7h"))))
+ "1apy9i76rgs0bmgdlpjszv0fpqhlap2s12m68wvnsv8j3fsqc90y"))))
(arguments
- '(#:test-target "test"
- #:phases (modify-phases %standard-phases
- (add-after 'install 'install-config
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; XXX: cmark-gfm-core-extensions.h includes this file.
- (install-file "src/config.h"
- (string-append out "/include"))))))))
+ (list #:test-target "test"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'install-config
+ (lambda _
+ ;; XXX: cmark-gfm-core-extensions.h includes this file.
+ (install-file "src/config.h"
+ (string-append #$output "/include")))))))
(synopsis "GitHub flavored CommonMark")
(description
"This package is a fork of @code{cmark}, with GitHub-specific Markdown
base-commit: a0a377fdd6c873aeb6340afeddcd23b4ead7657d
--
2.39.2