(address . bug-guix@gnu.org)
Sometimes when using %inferior-packages from (guix inferior) I get a
match error like this:
Toggle snippet (19 lines)
Oct 31 16:10:56 my-host script.sh[11211]: ERROR:
Oct 31 16:10:56 my-host script.sh[11211]: 1. &inferior-protocol-error: #<inferior pipe (0 1 1) 7fbd31f24000>
Oct 31 16:10:56 my-host script.sh[11211]: In srfi/srfi-1.scm:
Oct 31 16:10:56 my-host script.sh[11211]: 586:29 19 (map1 (("emacs-ivy-hydra" "0.14.0" 140456890688544) ("emacs-unfill" "0.3" 140456890595920) ("emacs-kbd" "0.0.1-0.a7f4c9b" 140456889541840) (…
Oct 31 16:10:57 my-host script.sh[11211]: o-types" "0.12.1" 140456892858544) ("rust-tap" "1.0.1" 140456869622112) ("rust-is-terminal" "0.4.7" 140457009467744) ("rust-glam" "0.16.0" 14045700937…
Oct 31 16:10:57 my-host script.sh[11211]: ("rust-darling" "0.9.0" 140457190695264) ("rust-memchr" "2.5.0" 140457009579568) ("rust-sha2" "0.9.5" 140456869400752) ("rust-base64" "0.11.0" 1404568…
…
Oct 31 16:11:00 my-host script.sh[11211]: 6) ("rust-rustc-version" "0.1.7" 140457010237216) ("rust-crossterm" "0.25.0" 140456889098016) ("rust-rust-hawktracer" "0.7.0" 140457010188288) ("rust-…
Oct 31 16:11:00 my-host script.sh[11211]: 586:17 2 (map1 (("emacs-org-re-reveal" 140456890183456) ("emacs-eldoc" "1.14.0" 140456889995040) ("emacs-skewer-mode" "1.8.0" 140456889618032) ("emac…
Oct 31 16:11:00 my-host script.sh[11211]: 7009533808) ("rust-pathfinder-geometry" "0.5.1" 140456869437440) ("rust-speedy-derive" "0.8.5" 140456869482672) ("rust-cc" "1.0.79" 140456910742560) (…
Oct 31 16:11:00 my-host script.sh[11211]: ("rust-crossterm" "0.25.0" 140456889098016) ("rust-rust-hawktracer" "0.7.0" 140457010188288) ("rust-normpath" "1.1.1" 140457009715616) ("rust-cast5" "…
Oct 31 16:11:00 my-host script.sh[11211]: In guix/inferior.scm:
Oct 31 16:11:00 my-host script.sh[11211]: 415:9 1 (_ _)
Oct 31 16:11:00 my-host script.sh[11211]: In ice-9/boot-9.scm:
Oct 31 16:11:00 my-host script.sh[11211]: 1685:16 0 (raise-exception _ #:continuable? _)
Oct 31 16:11:00 my-host script.sh[11211]: ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Oct 31 16:11:00 my-host script.sh[11211]: Throw to key `match-error' with args `("match" "no matching pattern" ("emacs-org-re-reveal" 140456890183456))'.
I don’t see how this could possibly happen because the expression to be
evaluated by the inferior only ever returns a list where each item
contains of three elements: name, version, and id.
--
Ricardo