correct hash but empty binaries

  • Open
  • quality assurance status badge
Details
One participant
  • lgcoelho
Owner
unassigned
Submitted by
lgcoelho
Severity
normal
L
L
lgcoelho wrote on 31 Oct 2023 14:14
(address . bug-guix@gnu.org)
525b6a09783860b35898077f7115555c@disroot.org
Some weeks ago, after running `guix pull` and `guix home reconfigure
~/.config/guix/home.scm`, my telegram-desktop stopped working. It showed
no error messages whatsoever, running it just didn't start a process.
Given particular circumstances, I did no further investigation, and did
not write a bug report, only switched the pull commit and reconfigured
my home.

Some days later, I guix pulled and reconfigured my home again, this time
to the latest commit, and telegram-desktop was fixed, but mpv was acting
exactly the same, since I didn't investigate the first time, can't
affirm it's the same problem, but seems plausible.

Relevant information:
```
+radio at buer in ~ > strace mpv --help
execve("/home/radio/.guix-home/profile/bin/mpv", ["mpv", "--help"],
0x7ffd853ab2d8 /* 84 vars */) = -1 ENOEXEC (Exec format error)

strace: exec: Exec format error

+++ exited with 1 +++
```
```
+radio at buer in ~ > file $(which mpv)
/home/radio/.guix-home/profile/bin/mpv: symbolic link to
/gnu/store/fqxxf5kdjf6d67szgh5rz64mzkxwm2yx-mpv-0.36.0/bin/mpv
```
```
+radio at buer in ~ > file
/gnu/store/fqxxf5kdjf6d67szgh5rz64mzkxwm2yx-mpv-0.36.0/bin/mpv
/gnu/store/fqxxf5kdjf6d67szgh5rz64mzkxwm2yx-mpv-0.36.0/bin/mpv: empty
```

```
+radio at buer in ~ > guix describe
Generation 127 Oct 31 2023 08:36:59 (current)
radix 58fe4d3
branch: main
commit: 58fe4d318f44103c30465da0af810b3f00aa0b9d
guix c089537
branch: master
commit: c0895371c5759c7d9edb330774e90f192cc4cf2c
```

A friend on the #guix IRC channel tried to reproduce the error, but got
an working mpv, with the exact same hash.
Attachment: file
L
L
lgcoelho wrote on 31 Oct 2023 23:22
(no subject)
(address . 66849@debbugs.gnu.org)
e5b1c285d4f59a271d2265134933c5a3@disroot.org
Now it seems more plausible that telegram-desktop suffered from the same
problem. I discovered my pavucontrol acting the same way as mpv, and
after some investigation I got that:

```
+radio at buer in ~ > for file in ~/.guix-home/profile/bin/*
file -L $file
end | grep empty
/home/radio/.guix-home/profile/bin/mpv: empty
/home/radio/.guix-home/profile/bin/pamixer: empty
/home/radio/.guix-home/profile/bin/pavucontrol: empty
/home/radio/.guix-home/profile/bin/pinentry: empty
/home/radio/.guix-home/profile/bin/pinentry-gtk-2: empty
/home/radio/.guix-home/profile/bin/redshift: empty
/home/radio/.guix-home/profile/bin/yt-dlp: empty

```

I hope it can be useful to understand what is happening.
Attachment: file
?