[PATCH] build-system: clojure: Use the standard error regarding cross builds.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 1 years ago
(address . guix-patches@gnu.org)
3217ef7510266e353bae0e9f44c7d4a73517c4c9.1698655414.git.mail@cbaines.net
Rather than raising an error in the build system.

* guix/build-system/clojure.scm (lower): Return #f for cross builds, rather
than calling error.

Change-Id: Id97c8f5140f55fe2c52ccb0db36fd993922c6a7e
---
guix/build-system/clojure.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (19 lines)
diff --git a/guix/build-system/clojure.scm b/guix/build-system/clojure.scm
index fb897356bc..037fcaf21d 100644
--- a/guix/build-system/clojure.scm
+++ b/guix/build-system/clojure.scm
@@ -83,8 +83,8 @@ (define* (lower name
#:clojure #:jdk #:zip)))
(if target
- (error "No cross-compilation for clojure-build-system yet: LOWER"
- target) ; FIXME
+ #f ; FIXME: No cross-compilation for
+ ; clojure-build-system yet
(bag (name name)
(system system)
(host-inputs `(,@(if source

base-commit: 642769707c05dc1dd5674d60cd3b55d77b35c9d9
--
2.41.0
Ludovic Courtès wrote 1 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 66832@debbugs.gnu.org)
87il637x3c.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (7 lines)
> Rather than raising an error in the build system.
>
> * guix/build-system/clojure.scm (lower): Return #f for cross builds, rather
> than calling error.
>
> Change-Id: Id97c8f5140f55fe2c52ccb0db36fd993922c6a7e

LGTM!
Christopher Baines wrote 1 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 66832-done@debbugs.gnu.org)
878r6sfojh.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (11 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> Rather than raising an error in the build system.
>>
>> * guix/build-system/clojure.scm (lower): Return #f for cross builds, rather
>> than calling error.
>>
>> Change-Id: Id97c8f5140f55fe2c52ccb0db36fd993922c6a7e
>
> LGTM!

Great, I've pushed this to master as
98ae8076435c74f90ad8ad30557963d2caa273c2.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmVbdwJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XevbA/8DhAI+gZrhpZQ0aMONqxuyfrXZOR3/6SI
PdfzLF8MkgvnKSRocVmvEfb6FdeT9vsNmIlL2gME3VHH4K7sIeafNwaVeU3HvjDr
USf/vWYuOSQjXR1X9+UhLLZ3eINNfq2Fi0TpACDqUGrqb+YWcct3Kr+yGUzrsWqo
hONRgS4zs9NiAYSYUj16yAOwW/Ey35Pjwd4N4DFFFKjNNddV2/GvFjPluDT4AZzv
WqA5Unx8oQgpeQcryV/1dSZDQNcMRftjwvtIZeqX0o/yM457fmeWqMuW1NVkrh+A
rDwCBXbmmJfYtb0Kh63JDemBKL54L0QtBcnj91e1JOcm5C+AwnNek9sbTHYE2ZP1
o5Z8Vr4dbS96a+xJeyxgp8o44ut3fdTIYxfFpwzoD6J3osRUjAMbW8Z6d9DJFJR7
B6TFh9rWvtfm1e1dJ49rkiXFT3Mj/9AUWVxAEdDobv8sd5c3CxsA/KAFaSl9BFzC
Ayg3zJIGzgPNDdRrLL8K4Mukc3vsCC5E9YUegjuO15PRC6JDs72EMn6mUiQ8xPzI
5bR6+HSNd5QaloBJXrg5hVewGCiHdip4AX4hYciiRQp51edT2TjiNuqXFdGHb+tz
k7tgJ+4hDJJLOPTksM/K8YU8oS3ZrFiVDx7s9zREHJ9MJHhlhACutlNDFcoGzM8Z
EVfNaLJHWaA=
=yvj4
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66832@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66832
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help