(address . guix-patches@gnu.org)(name . altadil)(address . altadil@protonmail.com)
* gnu/packages/pantheon.scm (pantheon-stylesheet): New variable.
Change-Id: If4e81ba639d3a1c66a6adf89c7009d5cd30838ea
---
This package is not very useful by itself, but hopefully will be, once
we manage to get more of Pantheon into Guix. :)
guix build --no-grafts --check --rounds=2 was successfully run on a Zen4 CPU,
for the following --system= options:
- x86_64-linux
- i686-linux
- aarch64-linux
- armhf-linux
- riscv64-linux.
gnu/packages/pantheon.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 5b83b96801..55cb65045e 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -132,6 +132,28 @@ (define-public pantheon-calculator
desktop.")
(license license:gpl3)))
+(define-public pantheon-stylesheet
+ (package
+ (name "pantheon-stylesheet")
+ (version "7.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/stylesheet")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0l1xv05zl0jfs9kfv3rnz821a442rpywcvxbcnsm6gp4q0kha7b5"))))
+ (build-system meson-build-system)
+ (native-inputs (list gettext-minimal)) ;for msgfmt
+ (inputs (list sassc))
+ (synopsis "GTK stylesheet for the Pantheon desktop")
+ (description "pantheon-stylesheet is the GTK Stylesheet for the Pantheon
+desktop environment (originally from elementary OS).")
+ (home-page "https://elementary.io/open-source")
+ (license license:gpl3+)))
+
(define-public pantheon-terminal
(package
(name "pantheon-terminal")
base-commit: 1dae56618271e7c8b19155d7984b9386ecb661f6
--
2.41.0