[PATCH] gnu: Add pantheon-stylesheet.

  • Open
  • quality assurance status badge
Details
One participant
  • altadil
Owner
unassigned
Submitted by
altadil
Severity
normal
A
A
altadil wrote on 29 Oct 2023 16:01
(address . guix-patches@gnu.org)(name . altadil)(address . altadil@protonmail.com)
2cd684146f0142ac1b2656cf29bbd0aaecccb176.1698591559.git.altadil@protonmail.com
* gnu/packages/pantheon.scm (pantheon-stylesheet): New variable.

Change-Id: If4e81ba639d3a1c66a6adf89c7009d5cd30838ea
---
This package is not very useful by itself, but hopefully will be, once
we manage to get more of Pantheon into Guix. :)
guix build --no-grafts --check --rounds=2 was successfully run on a Zen4 CPU,
for the following --system= options:
- x86_64-linux
- i686-linux
- aarch64-linux
- armhf-linux
- riscv64-linux.
gnu/packages/pantheon.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 5b83b96801..55cb65045e 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -132,6 +132,28 @@ (define-public pantheon-calculator
desktop.")
(license license:gpl3)))
+(define-public pantheon-stylesheet
+ (package
+ (name "pantheon-stylesheet")
+ (version "7.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/stylesheet")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0l1xv05zl0jfs9kfv3rnz821a442rpywcvxbcnsm6gp4q0kha7b5"))))
+ (build-system meson-build-system)
+ (native-inputs (list gettext-minimal)) ;for msgfmt
+ (inputs (list sassc))
+ (synopsis "GTK stylesheet for the Pantheon desktop")
+ (description "pantheon-stylesheet is the GTK Stylesheet for the Pantheon
+desktop environment (originally from elementary OS).")
+ (home-page "https://elementary.io/open-source")
+ (license license:gpl3+)))
+
(define-public pantheon-terminal
(package
(name "pantheon-terminal")

base-commit: 1dae56618271e7c8b19155d7984b9386ecb661f6
--
2.41.0
A
A
altadil wrote on 30 Oct 2023 16:02
[PATCH v1 1/3] gnu: Add pantheon-stylesheet.
(address . 66821@debbugs.gnu.org)(name . altadil)(address . altadil@protonmail.com)
402242f85368d48118b71be442092f856b1ec71b.1698677739.git.altadil@protonmail.com
* gnu/packages/pantheon.scm (pantheon-stylesheet): New variable.
Change-Id: If4e81ba639d3a1c66a6adf89c7009d5cd30838ea
---
This package is not very useful by itself, but hopefully will be, once
we manage to get more of Pantheon into Guix. :)
guix build --no-grafts --check --rounds=2 was successfully run on a Zen4 CPU,
for the following --system= options:
- x86_64-linux
- i686-linux
- aarch64-linux
- armhf-linux
- riscv64-linux.
gnu/packages/pantheon.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 5b83b96801..55cb65045e 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -132,6 +132,28 @@ (define-public pantheon-calculator
desktop.")
(license license:gpl3)))
+(define-public pantheon-stylesheet
+ (package
+ (name "pantheon-stylesheet")
+ (version "7.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/stylesheet")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0l1xv05zl0jfs9kfv3rnz821a442rpywcvxbcnsm6gp4q0kha7b5"))))
+ (build-system meson-build-system)
+ (native-inputs (list gettext-minimal)) ;for msgfmt
+ (inputs (list sassc))
+ (synopsis "GTK stylesheet for the Pantheon desktop")
+ (description "pantheon-stylesheet is the GTK Stylesheet for the Pantheon
+desktop environment (originally from elementary OS).")
+ (home-page "https://elementary.io/open-source")
+ (license license:gpl3+)))
+
(define-public pantheon-terminal
(package
(name "pantheon-terminal")

base-commit: 26565f1bc8548011bc0e1b821a9a957db1bc2d8f
--
2.41.0
A
A
altadil wrote on 30 Oct 2023 16:02
[PATCH v1 2/3] gnu: Add pantheon-photos
(address . 66821@debbugs.gnu.org)(name . altadil)(address . altadil@protonmail.com)
1037e695d17deb0a6766493dfe1e0697ce1efdc8.1698677739.git.altadil@protonmail.com
* gnu/packages/pantheon.scm (pantheon-photos): New variable.

Change-Id: I08a10db8a03cd6ddde936b892d917e8b7d421124
---
guix build --no-grafts --check --rounds=2 was successfully run on a Zen4 CPU,
for the following --system= options:
- x86_64-linux
- i686-linux
- aarch64-linux.
gnu/packages/pantheon.scm | 59 +++++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)

Toggle diff (87 lines)
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 55cb65045e..3465e5cb37 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -25,14 +25,18 @@ (define-module (gnu packages pantheon)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages package-management)
#:use-module (gnu packages pcre)
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages xml)
#:use-module (gnu packages web)
+ #:use-module (gnu packages webkit)
#:use-module (gnu packages xorg)
#:use-module (gnu packages)
#:use-module (guix build-system meson)
@@ -132,6 +136,61 @@ (define-public pantheon-calculator
desktop.")
(license license:gpl3)))
+(define-public pantheon-photos
+ (package
+ (name "pantheon-photos")
+ (version "2.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/photos")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1aw77sdh2z7fah3vbi68145wc0xqg2afch1kswvgkmij0f0n04jn"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'disable-schema-cache-generation
+ (lambda _
+ (setenv "DESTDIR" "/")))
+ (add-after 'install 'install-symlinks
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out
+ "/bin/io.elementary.photos"))
+ (link (string-append out "/bin/pantheon-photos")))
+ (symlink bin link)))))))
+ (native-inputs (list desktop-file-utils
+ `(,glib "bin") intltool pkg-config vala))
+ (inputs (list geocode-glib-with-libsoup2
+ gexiv2
+ granite-6
+ gstreamer
+ gst-plugins-base
+ gtk+
+ json-glib
+ libexif
+ libgee
+ libgphoto2
+ libgudev
+ libhandy
+ libraw
+ libsoup-minimal-2
+ libwebp
+ rest
+ sqlite
+ webkitgtk-with-libsoup2))
+ (synopsis "Photo viewer and organizer designed for the Pantheon desktop")
+ (description
+ "Photos is an image viewer and organizer. It originally comes
+from elementary OS and is designed for the Pantheon desktop environment (but can
+also be used on others.")
+ (home-page "https://elementary.io/open-source")
+ (license license:lgpl2.1+)))
+
(define-public pantheon-stylesheet
(package
(name "pantheon-stylesheet")
--
2.41.0
A
A
altadil wrote on 30 Oct 2023 16:02
[PATCH v1 3/3] gnu: Add pantheon-iconbrowser.
(address . 66821@debbugs.gnu.org)(name . altadil)(address . altadil@protonmail.com)
9ffa7edf2d26180c158a4d59a8307c1562be0c52.1698677739.git.altadil@protonmail.com
* gnu/packages/pantheon.scm (pantheon-iconbrowser): New variable.

Change-Id: I4c1b0aa8a5593e384214e4b1fbad4fef8eaedf4d
---
guix build --no-grafts --check --rounds=2 was successfully run on a Zen4 CPU,
for the following --system= options:
- x86_64-linux
- i686-linux.
The build is currently failing for aarch64 because of a dependency’s build
failure (gst-plugins-bad).
gnu/packages/pantheon.scm | 40 +++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 3465e5cb37..eb7044c5a9 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -136,6 +136,46 @@ (define-public pantheon-calculator
desktop.")
(license license:gpl3)))
+(define-public pantheon-iconbrowser
+ (package
+ (name "pantheon-iconbrowser")
+ (version "2.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/iconbrowser")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0b1afyizq3c94qkf4cqy5jnb4v3nib5vc88k34r08c604p1z2h8p"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases (modify-phases %standard-phases
+ (add-after 'install 'install-symlinks
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out
+ "/bin/io.elementary.iconbrowser"))
+ (link (string-append out
+ "/bin/pantheon-iconbrowser")))
+ (symlink bin link)))))))
+ (native-inputs (list gettext-minimal ;for msgfmt
+ `(,glib "bin")
+ `(,gtk "bin")
+ pkg-config
+ vala))
+ (inputs (list granite gtk gtksourceview))
+ (synopsis "Browse and search system icons")
+ (description
+ "Icon Browser is an application for browsing system icons by
+category or searching them by name. It displays icons at different sizes, as
+well as code snippets (to use the icons in your own apps). It is designed for
+the Pantheon desktop environment (originally from elementary OS).")
+ (home-page "https://elementary.io/open-source")
+ (license license:gpl3+)))
+
(define-public pantheon-photos
(package
(name "pantheon-photos")
--
2.41.0
A
A
altadil wrote on 9 Jan 14:59 +0100
[PATCH v2 1/3] gnu: Add pantheon-stylesheet.
(address . 66821@debbugs.gnu.org)(name . altadil)(address . altadil@protonmail.com)
46fbc22afa0f777079a30f9de6fe987154bea952.1704808651.git.altadil@protonmail.com
* gnu/packages/pantheon.scm (pantheon-stylesheet): New variable.

Change-Id: I5673a540bd44f6ad59b3aa32affbcb4fc0e19035
---
This is a new version of the patch series, to use the newly released
version of pantheon-stylesheet.
guix build --no-grafts --check --rounds=2 was successfully run on a Zen4 CPU,
for the following --system= options:
- x86_64-linux
- i686-linux
- aarch64-linux.
gnu/packages/pantheon.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 5b83b96801..161c49e5aa 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -132,6 +132,28 @@ (define-public pantheon-calculator
desktop.")
(license license:gpl3)))
+(define-public pantheon-stylesheet
+ (package
+ (name "pantheon-stylesheet")
+ (version "7.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/stylesheet")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zl3s3995q5qg8cqqlkf8a1va72ghj15b3z4g7n7xppq046mxfia"))))
+ (build-system meson-build-system)
+ (native-inputs (list gettext-minimal)) ;for msgfmt
+ (inputs (list sassc))
+ (synopsis "GTK stylesheet for the Pantheon desktop")
+ (description "pantheon-stylesheet is the GTK Stylesheet for the Pantheon
+desktop environment (originally from elementary OS).")
+ (home-page "https://elementary.io/open-source")
+ (license license:gpl3+)))
+
(define-public pantheon-terminal
(package
(name "pantheon-terminal")

base-commit: 8920cf302c5a2fd457a2629afe24cf4768f1fed7
--
2.41.0
A
A
altadil wrote on 9 Jan 15:00 +0100
[PATCH v2 2/3] gnu: Add pantheon-photos
(address . 66821@debbugs.gnu.org)(name . altadil)(address . altadil@protonmail.com)
dbe259ceb5ac9b8497bc15d9115cc08858fac504.1704808651.git.altadil@protonmail.com
* gnu/packages/pantheon.scm (pantheon-photos): New variable.

Change-Id: I08a10db8a03cd6ddde936b892d917e8b7d421124
---
gnu/packages/pantheon.scm | 59 +++++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)

Toggle diff (87 lines)
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 161c49e5aa..915bd17296 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -25,14 +25,18 @@ (define-module (gnu packages pantheon)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages package-management)
#:use-module (gnu packages pcre)
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages xml)
#:use-module (gnu packages web)
+ #:use-module (gnu packages webkit)
#:use-module (gnu packages xorg)
#:use-module (gnu packages)
#:use-module (guix build-system meson)
@@ -132,6 +136,61 @@ (define-public pantheon-calculator
desktop.")
(license license:gpl3)))
+(define-public pantheon-photos
+ (package
+ (name "pantheon-photos")
+ (version "2.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/photos")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1aw77sdh2z7fah3vbi68145wc0xqg2afch1kswvgkmij0f0n04jn"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'disable-schema-cache-generation
+ (lambda _
+ (setenv "DESTDIR" "/")))
+ (add-after 'install 'install-symlinks
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out
+ "/bin/io.elementary.photos"))
+ (link (string-append out "/bin/pantheon-photos")))
+ (symlink bin link)))))))
+ (native-inputs (list desktop-file-utils
+ `(,glib "bin") intltool pkg-config vala))
+ (inputs (list geocode-glib-with-libsoup2
+ gexiv2
+ granite-6
+ gstreamer
+ gst-plugins-base
+ gtk+
+ json-glib
+ libexif
+ libgee
+ libgphoto2
+ libgudev
+ libhandy
+ libraw
+ libsoup-minimal-2
+ libwebp
+ rest
+ sqlite
+ webkitgtk-with-libsoup2))
+ (synopsis "Photo viewer and organizer designed for the Pantheon desktop")
+ (description
+ "Photos is an image viewer and organizer. It originally comes
+from elementary OS and is designed for the Pantheon desktop environment (but can
+also be used on others.")
+ (home-page "https://elementary.io/open-source")
+ (license license:lgpl2.1+)))
+
(define-public pantheon-stylesheet
(package
(name "pantheon-stylesheet")
--
2.41.0
A
A
altadil wrote on 9 Jan 15:00 +0100
[PATCH v2 3/3] gnu: Add pantheon-iconbrowser.
(address . 66821@debbugs.gnu.org)(name . altadil)(address . altadil@protonmail.com)
c6b84a6f2f0d88cbfca7c0899b6ce2f2d9bd971a.1704808651.git.altadil@protonmail.com
* gnu/packages/pantheon.scm (pantheon-iconbrowser): New variable.

Change-Id: I4c1b0aa8a5593e384214e4b1fbad4fef8eaedf4d
---
gnu/packages/pantheon.scm | 40 +++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 915bd17296..780c9d9c78 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -136,6 +136,46 @@ (define-public pantheon-calculator
desktop.")
(license license:gpl3)))
+(define-public pantheon-iconbrowser
+ (package
+ (name "pantheon-iconbrowser")
+ (version "2.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/iconbrowser")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0b1afyizq3c94qkf4cqy5jnb4v3nib5vc88k34r08c604p1z2h8p"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases (modify-phases %standard-phases
+ (add-after 'install 'install-symlinks
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out
+ "/bin/io.elementary.iconbrowser"))
+ (link (string-append out
+ "/bin/pantheon-iconbrowser")))
+ (symlink bin link)))))))
+ (native-inputs (list gettext-minimal ;for msgfmt
+ `(,glib "bin")
+ `(,gtk "bin")
+ pkg-config
+ vala))
+ (inputs (list granite gtk gtksourceview))
+ (synopsis "Browse and search system icons")
+ (description
+ "Icon Browser is an application for browsing system icons by
+category or searching them by name. It displays icons at different sizes, as
+well as code snippets (to use the icons in your own apps). It is designed for
+the Pantheon desktop environment (originally from elementary OS).")
+ (home-page "https://elementary.io/open-source")
+ (license license:gpl3+)))
+
(define-public pantheon-photos
(package
(name "pantheon-photos")
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 66821@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66821
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch