[PATCH gnome-team] gnu: at-spi2-core: Update to 2.48.4.

  • Done
  • quality assurance status badge
Details
2 participants
  • Vivien Kraus
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal

Debbugs page

Vivien Kraus wrote 1 years ago
(address . guix-patches@gnu.org)
7249cc2130949445f57d8b9265e0da952d048b6a.1698583747.git.vivien@planete-kraus.eu
* gnu/packages/gtk.scm (at-spi2-core): Update to 2.48.4.

Change-Id: I3fc09c79f1ae5594fe9ad50e7212fbee11ce8a90
---
gnu/packages/gtk.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 21a12689b7..ce7b3919a0 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -792,7 +792,7 @@ (define-public at-spi2-core
(hidden-package
(package
(name "at-spi2-core")
- (version "2.45.90")
+ (version "2.48.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -800,7 +800,7 @@ (define-public at-spi2-core
name "-" version ".tar.xz"))
(sha256
(base32
- "03dba3c6m3sfapkkbbgzvbi1qcmrrlppydxjjs1m8ds9qb9hl1g9"))))
+ "05d5azffbglnvqzwk8ngg61jksm3brrwhmfpymsrccz8j8lv3v19"))))
(build-system meson-build-system)
(arguments
(list

base-commit: 2677bf985c0025d04ffdcff31763978b633dbc58
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team WIP v2] gnu: at-spi2-core: Update to 2.48.4.
(address . 66814@debbugs.gnu.org)
9b1b828225740531672a3ae2cbe0420013dc931f.1698601268.git.liliana.prikler@gmail.com
* gnu/packages/gtk.scm (at-spi2-core): Update to 2.48.4.
(at-spi2-core-with-documentation)[#:phases]: Adjust accordingly.
[native-inputs]: Remove docbook-xml-4.3 and gtk-doc/stable.
Add gi-docgen, python, and python-sphinx.

Change-Id: I3fc09c79f1ae5594fe9ad50e7212fbee11ce8a90
Co-authored-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
---
Hi Vivien,

your patch sadly caused the documentation build to fail. Below is a
revised version that builds, albeit without tests. The original package
is sadly written in a way that doesn't allow to easily disable tests,
but more importantly, the tests actually fail with the documentation
enabled. We should investigate as to why that happens.

Cheers

gnu/packages/gtk.scm | 28 +++++++++-------------------
1 file changed, 9 insertions(+), 19 deletions(-)

Toggle diff (89 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 21a12689b7..c0435304b4 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -106,6 +106,7 @@ (define-module (gnu packages gtk)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages guile)
#:use-module (gnu packages guile-xyz)
@@ -792,7 +793,7 @@ (define-public at-spi2-core
(hidden-package
(package
(name "at-spi2-core")
- (version "2.45.90")
+ (version "2.48.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -800,7 +801,7 @@ (define-public at-spi2-core
name "-" version ".tar.xz"))
(sha256
(base32
- "03dba3c6m3sfapkkbbgzvbi1qcmrrlppydxjjs1m8ds9qb9hl1g9"))))
+ "05d5azffbglnvqzwk8ngg61jksm3brrwhmfpymsrccz8j8lv3v19"))))
(build-system meson-build-system)
(arguments
(list
@@ -864,28 +865,17 @@ (define-public at-spi2-core-with-documentation
#$flags))
((#:phases phases)
#~(modify-phases #$phases
+ (delete 'check) ; XXX: dbus-daemon terminated by signal 11
(add-after 'unpack 'set-documentation-path
(lambda _
;; Ensure that the cross-references point to the "doc" output.
- (substitute* "doc/libatspi/meson.build"
- (("docpath =.*")
- (string-append "docpath = '" #$output:doc
- "/share/gtk-doc/html'\n")))))
- (add-before 'install 'prepare-doc-directory
- (lambda _
- (mkdir-p (string-append #$output:doc "/share"))))
- #$@(if (%current-target-system)
- #~()
- #~((add-after 'install 'move-documentation
- (lambda _
- (copy-recursively
- (string-append #$output "/share/gtk-doc")
- (string-append #$output:doc "/share/gtk-doc"))
- (delete-file-recursively
- (string-append #$output "/share/gtk-doc"))))))))))
+ (substitute* "doc/meson.build"
+ (("docs_dir =.*")
+ (string-append "docs_dir = '" #$output:doc
+ "/share/doc'\n")))))))))
(native-inputs
(modify-inputs (package-native-inputs at-spi2-core)
- (append docbook-xml-4.3 gtk-doc/stable)))
+ (append gi-docgen python python-sphinx)))
(properties (alist-delete 'hidden?
(package-properties at-spi2-core)))))

base-commit: 2677bf985c0025d04ffdcff31763978b633dbc58
prerequisite-patch-id: 3931d81d2155eb6c9bc99ea2d6d31a88377eda1c
prerequisite-patch-id: 226444cea9d3b0974377ad049735cd82b44be03a
prerequisite-patch-id: 1a7bf978a65eaae43a37fb40be6b4882652afb60
prerequisite-patch-id: efd150ce5309a68704db0bf22f477e93f231c0a9
prerequisite-patch-id: 3e54a72abd9d3b8ba43db1579ba3d03ad9f09235
prerequisite-patch-id: b37777e77370089c61c3e0cf1e77726fda827839
prerequisite-patch-id: 6d3d08c2f7a78de0a37aa439eee13eb4b8617e64
prerequisite-patch-id: d9f3cae36515204c9ed3b95108e510c0f65191b5
prerequisite-patch-id: 3bc4d0d28f6888944494494aeeac006b9b6c4069
prerequisite-patch-id: 0c122ec94fb2c0f9a2b416880f95e38a86119ce3
prerequisite-patch-id: 5648fb1ad60f3b49ed5e7942942b6780eb088c15
prerequisite-patch-id: 1cb3f92d09106b3f6136a18103a32e1801eeba41
prerequisite-patch-id: e69edd73b93d50e3c4ce78ac07af21b8743df518
prerequisite-patch-id: 83c27d6e791400fbf76220dc02a883d798ab72b0
prerequisite-patch-id: b2c8766578b5aeb5d9b1ba1722db93e8040e6a7a
prerequisite-patch-id: d88a09d78da3fff7de925022f57b037dbdb7b114
prerequisite-patch-id: 5f72a047ed04a1a063b08904e6523212ce639bf2
prerequisite-patch-id: a6bbbc23395653f93da46ceebc2b065599978218
prerequisite-patch-id: ca443a72e9397405d895f633da92b048369ed8d2
prerequisite-patch-id: c779825b86ad4f937269a8995a1fcb162b7643b3
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v3] gnu: at-spi2-core: Update to 2.48.4.
(address . liliana.prikler@gmail.com)
e2ac89a72f135611849f47f10f904d0777e66e1b.1698750173.git.vivien@planete-kraus.eu
* gnu/packages/gtk.scm (at-spi2-core): Update to 2.48.4.
(at-spi2-core-with-documentation)[#:phases]: Adjust accordingly.
[native-inputs]: Remove docbook-xml-4.3 and gtk-doc/stable.
Add gi-docgen, python, and python-sphinx.

Change-Id: I3fc09c79f1ae5594fe9ad50e7212fbee11ce8a90
Co-authored-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
---

Thank you! The build was fine for x86_64, but it did fail on i686 with the
described segfault of dbus-run-session. Using the other patch series to
update (gnu packages glib), #66689, I could get dbus-run-session to print a
warning about more entries than 128 to listen to for changes before crashing,
which led me to the linked issue. It does not mean the issue we experience
here is related: maybe there is a problem when listening for changes on more
than 128 directories, and maybe there is another problem when actually reading
them.

In any case, it is worth remembering that when such a crash occurs in
dbus-run-session, it may be because there are too many entries in
XDG_DATA_DIRS. Now I’ll see if that fixes #66823 (it has about a hundred of
XDG_DATA_DIRS, but less than 128).

The solution is not very satisfying. Maybe we could create a directory-union
of all the XDG_DATA_DIRS? I don’t know how to do that in the check phase of a
build.

At least it should now work.

Best regards,

Vivien

gnu/packages/gtk.scm | 43 +++++++++++++++++++------------------------
1 file changed, 19 insertions(+), 24 deletions(-)

Toggle diff (95 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 21a12689b7..08fed555c9 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -106,6 +106,7 @@ (define-module (gnu packages gtk)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages guile)
#:use-module (gnu packages guile-xyz)
@@ -792,7 +793,7 @@ (define-public at-spi2-core
(hidden-package
(package
(name "at-spi2-core")
- (version "2.45.90")
+ (version "2.48.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -800,7 +801,7 @@ (define-public at-spi2-core
name "-" version ".tar.xz"))
(sha256
(base32
- "03dba3c6m3sfapkkbbgzvbi1qcmrrlppydxjjs1m8ds9qb9hl1g9"))))
+ "05d5azffbglnvqzwk8ngg61jksm3brrwhmfpymsrccz8j8lv3v19"))))
(build-system meson-build-system)
(arguments
(list
@@ -816,10 +817,15 @@ (define-public at-spi2-core
(lambda _
;; xfconfd requires a writable HOME
(setenv "HOME" (getenv "TMPDIR"))
- ;; Run test-suite under a dbus session.
- (setenv "XDG_DATA_DIRS" ;for finding org.xfce.Xfconf.service
- (string-append #$output "/share:"
- (getenv "XDG_DATA_DIRS")))
+ ;; dbus-run-session may crash if XDG_DATA_DIRS has too
+ ;; many entries, maybe related to
+ ;; https://gitlab.freedesktop.org/dbus/dbus/-/issues/481.
+ (setenv "XDG_DATA_DIRS"
+ (string-append
+ #$output "/share:"
+ #$(this-package-native-input
+ "gsettings-desktop-schemas")
+ "/share"))
;; Don't fail on missing '/etc/machine-id'.
(setenv "DBUS_FATAL_WARNINGS" "0")
(with-directory-excursion (string-append "../at-spi2-core-"
@@ -837,7 +843,8 @@ (define-public at-spi2-core
;; atspi-2.pc refers to all these.
(list dbus glib libx11 libxi libxtst))
(native-inputs
- (list gettext-minimal
+ (list findutils
+ gettext-minimal
`(,glib "bin")
gobject-introspection
gsettings-desktop-schemas
@@ -867,25 +874,13 @@ (define-public at-spi2-core-with-documentation
(add-after 'unpack 'set-documentation-path
(lambda _
;; Ensure that the cross-references point to the "doc" output.
- (substitute* "doc/libatspi/meson.build"
- (("docpath =.*")
- (string-append "docpath = '" #$output:doc
- "/share/gtk-doc/html'\n")))))
- (add-before 'install 'prepare-doc-directory
- (lambda _
- (mkdir-p (string-append #$output:doc "/share"))))
- #$@(if (%current-target-system)
- #~()
- #~((add-after 'install 'move-documentation
- (lambda _
- (copy-recursively
- (string-append #$output "/share/gtk-doc")
- (string-append #$output:doc "/share/gtk-doc"))
- (delete-file-recursively
- (string-append #$output "/share/gtk-doc"))))))))))
+ (substitute* "doc/meson.build"
+ (("docs_dir =.*")
+ (string-append "docs_dir = '" #$output:doc
+ "/share/doc'\n")))))))))
(native-inputs
(modify-inputs (package-native-inputs at-spi2-core)
- (append docbook-xml-4.3 gtk-doc/stable)))
+ (append gi-docgen python python-sphinx)))
(properties (alist-delete 'hidden?
(package-properties at-spi2-core)))))

base-commit: 2677bf985c0025d04ffdcff31763978b633dbc58
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v4 3/3] gnu: orca: Update to 44.2.
(address . liliana.prikler@gmail.com)
3f094dc1f7b8b95713920517fb07e8eac7aaa908.1699992503.git.vivien@planete-kraus.eu
* gnu/packages/gnome.scm (orca): Update to 44.2.
[#:phase 'qualify-programs]: Also expand pgrep.
[inputs]: Add procps. Rename at-spi2-atk to at-spi2-core.

Change-Id: I05fdab970909edda44ca9957d2ad721f62e6bfec
---
gnu/packages/gnome.scm | 21 +++++++++++++++------
1 file changed, 15 insertions(+), 6 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2958da2cd9..bfc16159c0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11089,7 +11089,7 @@ (define-public python-pyatspi
(define-public orca
(package
(name "orca")
- (version "42.3")
+ (version "44.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -11098,17 +11098,25 @@ (define-public orca
name "-" version ".tar.xz"))
(sha256
(base32
- "097pyav3z5ssic8vwd7v1s7vynpycdpyfr324rr6c7mfzq5vmp7s"))))
+ "11jn925ga970y74did96ms78pc3lshkd9rd8v82i6zdzigxa7yvd"))))
(build-system glib-or-gtk-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'qualify-xkbcomp
+ (add-before 'configure 'qualify-programs
(lambda* (#:key inputs #:allow-other-keys)
(let ((xkbcomp (string-append
- (assoc-ref inputs "xkbcomp") "/bin/xkbcomp")))
+ (assoc-ref inputs "xkbcomp") "/bin/xkbcomp"))
+ (pgrep (string-append
+ (assoc-ref inputs "procps") "/bin/pgrep")))
(substitute* "src/orca/orca.py"
- (("'xkbcomp'") (format #f "'~a'" xkbcomp))))))
+ (("'xkbcomp'") (format #f "'~a'" xkbcomp)))
+ (substitute* "src/orca/debug.py"
+ (("'pgrep %s'")
+ (format #f "'~a %s'" pgrep)))
+ (substitute* "src/orca/orca_bin.py.in"
+ (("'pgrep -u %s -x orca'")
+ (format #f "'~a -u %s -x orca'" pgrep))))))
(add-after 'install 'wrap-orca
(lambda* (#:key outputs #:allow-other-keys)
(wrap-program (search-input-file outputs "bin/orca")
@@ -11124,13 +11132,14 @@ (define-public orca
pkg-config
libxml2))
(inputs
- (list at-spi2-atk
+ (list at-spi2-core
bash-minimal
gsettings-desktop-schemas
gstreamer
gst-plugins-base
gst-plugins-good
gtk+
+ procps ; for pgrep
python
python-pygobject
python-pyatspi
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v4 0/3] Update at-spi2-core and orca
(address . liliana.prikler@gmail.com)
cover.1699992503.git.vivien@planete-kraus.eu
Dear guix,

Orca fails to start both on master and gnome-team. With at-spi2-core and orca
updated, libical fails to build, but we can update it too on the way.

What do you think?

Best regards,

Vivien

Vivien Kraus (3):
gnu: at-spi2-core: Update to 2.48.4.
gnu: libical: Update to 3.0.17.
gnu: orca: Update to 44.2.

gnu/packages/calendar.scm | 4 ++--
gnu/packages/gnome.scm | 21 +++++++++++++------
gnu/packages/gtk.scm | 43 +++++++++++++++++----------------------
3 files changed, 36 insertions(+), 32 deletions(-)


base-commit: 72e886328c14c832b2ed71c400069b63852ee18d
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v4 1/3] gnu: at-spi2-core: Update to 2.48.4.
(address . liliana.prikler@gmail.com)
6286d591a8eb892aa5cd63732fe060b68371f04e.1699992503.git.vivien@planete-kraus.eu
* gnu/packages/gtk.scm (at-spi2-core): Update to 2.48.4.
(at-spi2-core-with-documentation)[#:phases]: Adjust accordingly.
[native-inputs]: Remove docbook-xml-4.3 and gtk-doc/stable.
Add gi-docgen, python, and python-sphinx.

Change-Id: I3fc09c79f1ae5594fe9ad50e7212fbee11ce8a90
Co-authored-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
---
gnu/packages/gtk.scm | 43 +++++++++++++++++++------------------------
1 file changed, 19 insertions(+), 24 deletions(-)

Toggle diff (93 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 21a12689b7..08fed555c9 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -106,6 +106,7 @@ (define-module (gnu packages gtk)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages guile)
#:use-module (gnu packages guile-xyz)
@@ -792,7 +793,7 @@ (define-public at-spi2-core
(hidden-package
(package
(name "at-spi2-core")
- (version "2.45.90")
+ (version "2.48.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -800,7 +801,7 @@ (define-public at-spi2-core
name "-" version ".tar.xz"))
(sha256
(base32
- "03dba3c6m3sfapkkbbgzvbi1qcmrrlppydxjjs1m8ds9qb9hl1g9"))))
+ "05d5azffbglnvqzwk8ngg61jksm3brrwhmfpymsrccz8j8lv3v19"))))
(build-system meson-build-system)
(arguments
(list
@@ -816,10 +817,15 @@ (define-public at-spi2-core
(lambda _
;; xfconfd requires a writable HOME
(setenv "HOME" (getenv "TMPDIR"))
- ;; Run test-suite under a dbus session.
- (setenv "XDG_DATA_DIRS" ;for finding org.xfce.Xfconf.service
- (string-append #$output "/share:"
- (getenv "XDG_DATA_DIRS")))
+ ;; dbus-run-session may crash if XDG_DATA_DIRS has too
+ ;; many entries, maybe related to
+ ;; https://gitlab.freedesktop.org/dbus/dbus/-/issues/481.
+ (setenv "XDG_DATA_DIRS"
+ (string-append
+ #$output "/share:"
+ #$(this-package-native-input
+ "gsettings-desktop-schemas")
+ "/share"))
;; Don't fail on missing '/etc/machine-id'.
(setenv "DBUS_FATAL_WARNINGS" "0")
(with-directory-excursion (string-append "../at-spi2-core-"
@@ -837,7 +843,8 @@ (define-public at-spi2-core
;; atspi-2.pc refers to all these.
(list dbus glib libx11 libxi libxtst))
(native-inputs
- (list gettext-minimal
+ (list findutils
+ gettext-minimal
`(,glib "bin")
gobject-introspection
gsettings-desktop-schemas
@@ -867,25 +874,13 @@ (define-public at-spi2-core-with-documentation
(add-after 'unpack 'set-documentation-path
(lambda _
;; Ensure that the cross-references point to the "doc" output.
- (substitute* "doc/libatspi/meson.build"
- (("docpath =.*")
- (string-append "docpath = '" #$output:doc
- "/share/gtk-doc/html'\n")))))
- (add-before 'install 'prepare-doc-directory
- (lambda _
- (mkdir-p (string-append #$output:doc "/share"))))
- #$@(if (%current-target-system)
- #~()
- #~((add-after 'install 'move-documentation
- (lambda _
- (copy-recursively
- (string-append #$output "/share/gtk-doc")
- (string-append #$output:doc "/share/gtk-doc"))
- (delete-file-recursively
- (string-append #$output "/share/gtk-doc"))))))))))
+ (substitute* "doc/meson.build"
+ (("docs_dir =.*")
+ (string-append "docs_dir = '" #$output:doc
+ "/share/doc'\n")))))))))
(native-inputs
(modify-inputs (package-native-inputs at-spi2-core)
- (append docbook-xml-4.3 gtk-doc/stable)))
+ (append gi-docgen python python-sphinx)))
(properties (alist-delete 'hidden?
(package-properties at-spi2-core)))))
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v4 2/3] gnu: libical: Update to 3.0.17.
(address . liliana.prikler@gmail.com)
077b89a8c8983d93bfbf81a4c9319b2a19653ec6.1699992503.git.vivien@planete-kraus.eu
* gnu/packages/calendar.scm (libical): Update to 3.0.17.

Change-Id: Ifa230c4e514d7bc4ea01907928678e8bfb490783
---
gnu/packages/calendar.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 991995daf7..9586e463c2 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -123,7 +123,7 @@ (define-public date
(define-public libical
(package
(name "libical")
- (version "3.0.16")
+ (version "3.0.17")
(source (origin
(method url-fetch)
(uri (string-append
@@ -131,7 +131,7 @@ (define-public libical
version "/libical-" version ".tar.gz"))
(sha256
(base32
- "0cqc1wpalxmxjx8dmcaga9w8kd5l7944hqmidz43hifaf7fhaixl"))))
+ "06vqbxg4f3i03087grjncfy9pbvmlhg4v1ajhwr400l7nrnrmnmw"))))
(build-system cmake-build-system)
(arguments
(list
--
2.41.0
Liliana Marie Prikler wrote 1 years ago
Re: [PATCH gnome-team v4 3/3] gnu: orca: Update to 44.2.
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)
6c63be1ec639a407731fb14c929720afb2bcd799.camel@gmail.com
Am Dienstag, dem 14.11.2023 um 17:08 +0100 schrieb Vivien Kraus:
Toggle quote (3 lines)
> * gnu/packages/gnome.scm (orca): Update to 44.2.
> [#:phase 'qualify-programs]: Also expand pgrep.
> [inputs]: Add procps. Rename at-spi2-atk to at-spi2-core.
Rename to → Replace with?


Cheers
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v5 1/3] gnu: at-spi2-core: Update to 2.48.4.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
6286d591a8eb892aa5cd63732fe060b68371f04e.1700116480.git.vivien@planete-kraus.eu
* gnu/packages/gtk.scm (at-spi2-core): Update to 2.48.4.
(at-spi2-core-with-documentation)[#:phases]: Adjust accordingly.
[native-inputs]: Remove docbook-xml-4.3 and gtk-doc/stable.
Add gi-docgen, python, and python-sphinx.

Change-Id: I3fc09c79f1ae5594fe9ad50e7212fbee11ce8a90
Co-authored-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
---
gnu/packages/gtk.scm | 43 +++++++++++++++++++------------------------
1 file changed, 19 insertions(+), 24 deletions(-)

Toggle diff (95 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 21a12689b7..08fed555c9 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -106,6 +106,7 @@ (define-module (gnu packages gtk)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages sphinx)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages guile)
#:use-module (gnu packages guile-xyz)
@@ -792,7 +793,7 @@ (define-public at-spi2-core
(hidden-package
(package
(name "at-spi2-core")
- (version "2.45.90")
+ (version "2.48.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -800,7 +801,7 @@ (define-public at-spi2-core
name "-" version ".tar.xz"))
(sha256
(base32
- "03dba3c6m3sfapkkbbgzvbi1qcmrrlppydxjjs1m8ds9qb9hl1g9"))))
+ "05d5azffbglnvqzwk8ngg61jksm3brrwhmfpymsrccz8j8lv3v19"))))
(build-system meson-build-system)
(arguments
(list
@@ -816,10 +817,15 @@ (define-public at-spi2-core
(lambda _
;; xfconfd requires a writable HOME
(setenv "HOME" (getenv "TMPDIR"))
- ;; Run test-suite under a dbus session.
- (setenv "XDG_DATA_DIRS" ;for finding org.xfce.Xfconf.service
- (string-append #$output "/share:"
- (getenv "XDG_DATA_DIRS")))
+ ;; dbus-run-session may crash if XDG_DATA_DIRS has too
+ ;; many entries, maybe related to
+ ;; https://gitlab.freedesktop.org/dbus/dbus/-/issues/481.
+ (setenv "XDG_DATA_DIRS"
+ (string-append
+ #$output "/share:"
+ #$(this-package-native-input
+ "gsettings-desktop-schemas")
+ "/share"))
;; Don't fail on missing '/etc/machine-id'.
(setenv "DBUS_FATAL_WARNINGS" "0")
(with-directory-excursion (string-append "../at-spi2-core-"
@@ -837,7 +843,8 @@ (define-public at-spi2-core
;; atspi-2.pc refers to all these.
(list dbus glib libx11 libxi libxtst))
(native-inputs
- (list gettext-minimal
+ (list findutils
+ gettext-minimal
`(,glib "bin")
gobject-introspection
gsettings-desktop-schemas
@@ -867,25 +874,13 @@ (define-public at-spi2-core-with-documentation
(add-after 'unpack 'set-documentation-path
(lambda _
;; Ensure that the cross-references point to the "doc" output.
- (substitute* "doc/libatspi/meson.build"
- (("docpath =.*")
- (string-append "docpath = '" #$output:doc
- "/share/gtk-doc/html'\n")))))
- (add-before 'install 'prepare-doc-directory
- (lambda _
- (mkdir-p (string-append #$output:doc "/share"))))
- #$@(if (%current-target-system)
- #~()
- #~((add-after 'install 'move-documentation
- (lambda _
- (copy-recursively
- (string-append #$output "/share/gtk-doc")
- (string-append #$output:doc "/share/gtk-doc"))
- (delete-file-recursively
- (string-append #$output "/share/gtk-doc"))))))))))
+ (substitute* "doc/meson.build"
+ (("docs_dir =.*")
+ (string-append "docs_dir = '" #$output:doc
+ "/share/doc'\n")))))))))
(native-inputs
(modify-inputs (package-native-inputs at-spi2-core)
- (append docbook-xml-4.3 gtk-doc/stable)))
+ (append gi-docgen python python-sphinx)))
(properties (alist-delete 'hidden?
(package-properties at-spi2-core)))))

base-commit: 72e886328c14c832b2ed71c400069b63852ee18d
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v5 2/3] gnu: libical: Update to 3.0.17.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
077b89a8c8983d93bfbf81a4c9319b2a19653ec6.1700116481.git.vivien@planete-kraus.eu
* gnu/packages/calendar.scm (libical): Update to 3.0.17.

Change-Id: Ifa230c4e514d7bc4ea01907928678e8bfb490783
---
gnu/packages/calendar.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 991995daf7..9586e463c2 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -123,7 +123,7 @@ (define-public date
(define-public libical
(package
(name "libical")
- (version "3.0.16")
+ (version "3.0.17")
(source (origin
(method url-fetch)
(uri (string-append
@@ -131,7 +131,7 @@ (define-public libical
version "/libical-" version ".tar.gz"))
(sha256
(base32
- "0cqc1wpalxmxjx8dmcaga9w8kd5l7944hqmidz43hifaf7fhaixl"))))
+ "06vqbxg4f3i03087grjncfy9pbvmlhg4v1ajhwr400l7nrnrmnmw"))))
(build-system cmake-build-system)
(arguments
(list
--
2.41.0
Vivien Kraus wrote 1 years ago
[PATCH gnome-team v5 3/3] gnu: orca: Update to 44.2.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
80f3e38d7ff1c028044dbdf510318bd245fcae59.1700116481.git.vivien@planete-kraus.eu
* gnu/packages/gnome.scm (orca): Update to 44.2.
[#:phases]<qualify-programs>: Also expand pgrep.
[inputs]: Add procps. Replace at-spi2-atk with at-spi2-core.

Change-Id: I05fdab970909edda44ca9957d2ad721f62e6bfec
---
gnu/packages/gnome.scm | 21 +++++++++++++++------
1 file changed, 15 insertions(+), 6 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2958da2cd9..bfc16159c0 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11089,7 +11089,7 @@ (define-public python-pyatspi
(define-public orca
(package
(name "orca")
- (version "42.3")
+ (version "44.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -11098,17 +11098,25 @@ (define-public orca
name "-" version ".tar.xz"))
(sha256
(base32
- "097pyav3z5ssic8vwd7v1s7vynpycdpyfr324rr6c7mfzq5vmp7s"))))
+ "11jn925ga970y74did96ms78pc3lshkd9rd8v82i6zdzigxa7yvd"))))
(build-system glib-or-gtk-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'qualify-xkbcomp
+ (add-before 'configure 'qualify-programs
(lambda* (#:key inputs #:allow-other-keys)
(let ((xkbcomp (string-append
- (assoc-ref inputs "xkbcomp") "/bin/xkbcomp")))
+ (assoc-ref inputs "xkbcomp") "/bin/xkbcomp"))
+ (pgrep (string-append
+ (assoc-ref inputs "procps") "/bin/pgrep")))
(substitute* "src/orca/orca.py"
- (("'xkbcomp'") (format #f "'~a'" xkbcomp))))))
+ (("'xkbcomp'") (format #f "'~a'" xkbcomp)))
+ (substitute* "src/orca/debug.py"
+ (("'pgrep %s'")
+ (format #f "'~a %s'" pgrep)))
+ (substitute* "src/orca/orca_bin.py.in"
+ (("'pgrep -u %s -x orca'")
+ (format #f "'~a -u %s -x orca'" pgrep))))))
(add-after 'install 'wrap-orca
(lambda* (#:key outputs #:allow-other-keys)
(wrap-program (search-input-file outputs "bin/orca")
@@ -11124,13 +11132,14 @@ (define-public orca
pkg-config
libxml2))
(inputs
- (list at-spi2-atk
+ (list at-spi2-core
bash-minimal
gsettings-desktop-schemas
gstreamer
gst-plugins-base
gst-plugins-good
gtk+
+ procps ; for pgrep
python
python-pygobject
python-pyatspi
--
2.41.0
Liliana Marie Prikler wrote 1 years ago
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)
40bb35a72a60daa2cc411cdfe91ee30b748df5f3.camel@gmail.com
Am Dienstag, dem 14.11.2023 um 17:08 +0100 schrieb Vivien Kraus:
Toggle quote (3 lines)
> * gnu/packages/gnome.scm (orca): Update to 44.2.
> [#:phases]<qualify-programs>: Also expand pgrep.
> [inputs]: Add procps. Replace at-spi2-atk with at-spi2-core.
Pushed. Next time, use two spaces please, I forgot to fix that ^^"
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66814@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66814
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help