[PATCH 0/2] Update python-black to 23.1.0

  • Open
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal
N
N
Nicolas Graves wrote on 28 Oct 2023 11:45
(address . guix-patches@gnu.org)(address . ngraves@ngraves.fr)
20231028094534.26587-1-ngraves@ngraves.fr
This patch series updates python-black to 23.1.0.

Nicolas Graves (2):
gnu: python-packaging: Update to 22.0.
gnu: python-black: Update to 23.1.0.

gnu/packages/python-xyz.scm | 65 +++++++++++++++----------------------
1 file changed, 27 insertions(+), 38 deletions(-)

--
2.41.0
L
L
Ludovic Courtès wrote on 4 Dec 2023 21:56
(name . Nicolas Graves)(address . ngraves@ngraves.fr)(address . 66788@debbugs.gnu.org)
87fs0hn0tx.fsf@gnu.org
Hi,

Nicolas Graves <ngraves@ngraves.fr> skribis:

Toggle quote (6 lines)
> This patch series updates python-black to 23.1.0.
>
> Nicolas Graves (2):
> gnu: python-packaging: Update to 22.0.
> gnu: python-black: Update to 23.1.0.

Looks like you forgot to send the actual patches, no?

Ludo’.
N
N
Nicolas Graves wrote on 4 Feb 13:54 +0100
[PATCH 1/2] gnu: python-black: Update to 23.1.0.
(address . 66788@debbugs.gnu.org)
20240204125440.3508-1-ngraves@ngraves.fr
* gnu/packages/python-xyz.scm (python-black): Update to 23.1.0.
---
gnu/packages/python-xyz.scm | 36 +++++++++++++++++-------------------
1 file changed, 17 insertions(+), 19 deletions(-)

Toggle diff (67 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c68b17b0ab..5ffea67fc9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7496,43 +7496,41 @@ (define-public python-language-server
(define-public python-black
(package
(name "python-black")
- (version "22.3.0")
+ (version "23.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "black" version))
(sha256
- (base32
- "0yfahlqc7dsdp1js0cbv706apldnfnlbal9b53cww8n0hs40n0im"))))
- (build-system python-build-system)
+ (base32 "1b4jjv3fw2wgssnw2v1x0w09s7rz9sj5g4i1lwmmlgwhm2z9ggdh"))))
+ (build-system pyproject-build-system)
+ ;; These tests fail because Guix replaces the file shebangs.
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'patch-source-shebangs 'use-absolute-file-names
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- (let* ((inpts (or native-inputs inputs))
- (python3 (search-input-file inpts "/bin/python3")))
- (substitute* (find-files "tests" "\\.py$")
- (("#!/usr/bin/env python3(\\.[0-9]+)?" _ minor-version)
- (string-append "#!" python3 (if (string? minor-version)
- minor-version
- "")))))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests? (invoke "pytest" "-vv")))))))
+ '(#:test-flags `("-k" ,(string-append
+ "not test_infer_target_version "
+ "and not test_simple_format[fmtonoff] "
+ "and not test_simple_format[function] "
+ "and not test_simple_format[string_prefixes] "
+ "and not test_python_39[python39]"))))
(propagated-inputs
(list python-click
python-attrs
python-appdirs
python-pathspec
python-mypy-extensions
+ python-packaging
python-platformdirs
python-regex
python-tomli
python-typed-ast
python-typing-extensions))
(native-inputs
- (list python-pytest python-pytest-aiohttp python-setuptools-scm))
+ (list python-hatchling
+ python-hatch-vcs
+ python-hatch-fancy-pypi-readme
+ python-pytest
+ python-pytest-aiohttp
+ python-setuptools-scm))
(home-page "https://github.com/psf/black")
(synopsis "The uncompromising code formatter")
(description "Black is the uncompromising Python code formatter.")
--
2.41.0
N
N
Nicolas Graves wrote on 4 Feb 13:54 +0100
[PATCH 2/2] gnu: python-packaging: Update to 22.0.
(address . 66788@debbugs.gnu.org)
20240204125440.3508-2-ngraves@ngraves.fr
* gnu/packages/python-xyz.scm (python-packaging): Update to 22.0.
---
gnu/packages/python-xyz.scm | 29 ++++++++++-------------------
1 file changed, 10 insertions(+), 19 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5ffea67fc9..b1d2923595 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23500,25 +23500,16 @@ (define-public python-gtts
(define-public python-packaging
(package/inherit python-packaging-bootstrap
(name "python-packaging")
- (arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (if tests?
- (invoke "pytest" "-vv")
- (format #t "test suite not run~%")))))))
- (native-inputs (list python-pretend python-pytest))
- (propagated-inputs (list python-pyparsing python-six))
- (home-page "https://github.com/pypa/packaging")
- (synopsis "Core utilities for Python packages")
- (description "Packaging is a Python module for dealing with Python packages.
- It offers an interface for working with package versions, names, and dependency
- information.")
- ;; From 'LICENSE': This software is made available under the terms of
- ;; *either* of the licenses found in LICENSE.APACHE or LICENSE.BSD.
- ;; Contributions to this software is made under the terms of *both* these
- ;; licenses.
- (license (list license:asl2.0 license:bsd-2))))
+ (version "22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "packaging" version))
+ (sha256
+ (base32 "1lygw8fw9qj8md86g0ckzp16y1qlhw60zq0pjy7pn0acplhfr611"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pretend python-pytest python-flit-core))
+ (propagated-inputs (list python-pyparsing python-six))))
(define-public python-relatorio
(package
--
2.41.0
N
N
Nicolas Graves wrote on 4 Feb 13:55 +0100
Re: [bug#66788] [PATCH 0/2] Update python-black to 23.1.0
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 66788@debbugs.gnu.org)
877cjk1j9f.fsf@ngraves.fr
On 2023-12-04 21:56, Ludovic Courtès wrote:

Toggle quote (12 lines)
> Hi,
>
> Nicolas Graves <ngraves@ngraves.fr> skribis:
>
>> This patch series updates python-black to 23.1.0.
>>
>> Nicolas Graves (2):
>> gnu: python-packaging: Update to 22.0.
>> gnu: python-black: Update to 23.1.0.
>
> Looks like you forgot to send the actual patches, no?

Indeed, I've sent them now, sorry.
Toggle quote (6 lines)
>
> Ludo’.
>
>
>

--
Best regards,
Nicolas Graves
?