[PATCH 0/3] fix and update ansible to 8.5.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Jack Hill
  • Christopher Baines
Owner
unassigned
Submitted by
Jack Hill
Severity
normal

Debbugs page

Jack Hill wrote 1 years ago
(address . guix-patches@gnu.org)
28cf2040-3e78-dc66-7a6e-1d8742ea16dc@jackhill.us
Hi Guix,

These patches update ansible-core and ansible to their latest releases.
Currently ansible-core doesn't build, so that is also fixed.

In ansible-core I've enabled some tests that were marked as failing
before, but now pass. Also, if I just run ansible-test without specifying
which copy to run, the one on PATH didn't work, and printed messages like

"""
Configured locale: en_US.UTF-8
FATAL: The current working directory must be within the source tree being tested.

Testing an Ansible collection: {...}/ansible_collections/{namespace}/{collection}/
Example #1: community.general -> ~/code/ansible_collections/community/general/
Example #2: ansible.util -> ~/.ansible/collections/ansible_collections/ansible/util/

Current working directory: /tmp/guix-build-ansible-core-2.15.5.drv-0/ansible-core-2.15.5/
No "ansible_collections" parent directory was found.
Cannot test "/tmp/guix-build-ansible-core-2.15.5.drv-0/ansible-core-2.15.5" with ansible-test from "/gnu/store/56zvvfavw59v57wi0c3lvwp27fjswa8l-ansible-core-2.15.5/lib/python3.10/site-packages/ansible_test".

Did you intend to run "/tmp/guix-build-ansible-core-2.15.5.drv-0/ansible-core-2.15.5/bin/ansible-test" instead?
"""

So far, so good, but I'm not sure if this is yet ready to merge. Other
than running `ansible --version` I haven't had a chance to test it. I'd
like to use it to create a back, but with `guix pack -RR ansible-core
ansible glibc-locales bash` running `ansible --version` on a CentOS 7 system
prints:

"""
ERROR: Ansible could not initialize the preferred locale: unsupported locale setting
"""

Also, it seems like the really useful commands are provided by
ansible-core and not ansible, so I'm not sure if the former should be
propagated in the latter? Maybe there is some other packaging bug?

Nevertheless, I think these changes are definitely an improvement over
what we have now, so I wanted to share them to get feedback and maybe find
a collaborator.

Jack Hill (3):
gnu: ansible-core: Update to 2.15.5 and fix tests.
gnu: Remove python-resolvelib@0.5.
gnu: ansible: Update to 8.5.0.

gnu/packages/admin.scm | 20 ++++++--------------
gnu/packages/python-xyz.scm | 16 ----------------
2 files changed, 6 insertions(+), 30 deletions(-)


base-commit: cbd20d627497053871db863970c07d93c7081786
--
2.41.0
Jack Hill wrote 1 years ago
[PATCH 2/3] gnu: Remove python-resolvelib@0.5.
(address . 66766@debbugs.gnu.org)
891190a29f1297eae66e426f95288eb25a4e2f19.1698345519.git.jackhill@jackhill.us
* gnu/packages/python-xyz.scm (python-resolvelib-0.5): Delete
variable. This was only used by ansible-core which can now use the
newer version.

Change-Id: Ic40e21561807ed5faae466e13193892e4f9aa6ae
---
gnu/packages/python-xyz.scm | 16 ----------------
1 file changed, 16 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 65c23cb318..300a7b2713 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13745,22 +13745,6 @@ (define-public python-resolvelib
includes dependency resolution logic.")
(license license:isc)))
-;;; This older version is required by ansible-core.
-(define-public python-resolvelib-0.5
- (package/inherit python-resolvelib
- (name "python-resolvelib")
- (version "0.5.4")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/sarugaku/resolvelib")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0697y330sqhiclk25v151qxg7aixzpj434lbg5qib0qlna5zg9la"))))))
-
(define-public python-commonmark
(package
(name "python-commonmark")
--
2.41.0
Jack Hill wrote 1 years ago
[PATCH 3/3] gnu: ansible: Update to 8.5.0.
(address . 66766@debbugs.gnu.org)
33864ade0c3dbe79f330e5f02e67aba7cabb1120.1698345519.git.jackhill@jackhill.us
* gnu/packages/admin.scm (ansible): Update to 8.5.0.

Change-Id: I38ac84a0945f3ba10e13246cf8ae95c3795b52b3
---
gnu/packages/admin.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c1327d54a5..5e0e0d9b52 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2973,13 +2973,13 @@ (define-public ansible-core
(define-public ansible
(package
(name "ansible")
- (version "7.4.0")
+ (version "8.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ansible" version))
(sha256
- (base32 "142barhwz0wx5kn74xi0bfl21iwq2yq3jp14kxajsg9nggndcr09"))))
+ (base32 "0bazj5h12wraf30bb2schzwk553y20n9vh45km4b5kgmvadm0z1j"))))
(build-system python-build-system)
(propagated-inputs (list ansible-core))
;; The Ansible collections are found by ansible-core via the Python search
--
2.41.0
Jack Hill wrote 1 years ago
[PATCH 1/3] gnu: ansible-core: Update to 2.15.5 and fix tests.
(address . 66766@debbugs.gnu.org)
ec9dd0e48f56d70575b511dc43d25040dab3e978.1698345519.git.jackhill@jackhill.us
* gnu/packages/admin.scm (ansible-core): Update to 2.15.5.
[#:phases]<check>: Enable tests that now pass and choose
the right ansible-test to invoke.
[propagated-inputs]: replace python-resolvelib-0.5 with python-resolvelib.

Change-Id: Ibda3222a16fefb1484affdb62e38a3a07ce61986
---
gnu/packages/admin.scm | 16 ++++------------
1 file changed, 4 insertions(+), 12 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 8f72b0eeae..c1327d54a5 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2835,13 +2835,13 @@ (define-public fdupes
(define-public ansible-core
(package
(name "ansible-core")
- (version "2.14.4")
+ (version "2.15.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ansible-core" version))
(sha256
- (base32 "057g87smxcn6zc558xk4zr6ga4q8clmkyxghn5gx60a94sy61clh"))))
+ (base32 "00hnwjk4dxgxbz4xlza2wqx20yks5xr7074hzlzsyja3ip5kkicc"))))
(build-system python-build-system)
(arguments
`(#:modules ((guix build python-build-system)
@@ -2911,14 +2911,6 @@ (define-public ansible-core
(when tests?
;; Otherwise Ansible fails to create its config directory.
(setenv "HOME" "/tmp")
- ;; This test module messes up with sys.path and causes many
- ;; test failures.
- (delete-file "test/units/_vendor/test_vendor.py")
- ;; The test fails when run in the container, for reasons
- ;; unknown.
- (delete-file "test/units/utils/test_display.py")
- ;; This test fail for reasons unknown.
- (delete-file "test/units/cli/test_adhoc.py")
;; These tests fail in the container; it appears that the
;; mocking of the absolute file names such as /usr/bin/svcs do
;; not work as intended there.
@@ -2933,7 +2925,7 @@ (define-public ansible-core
;; does some extra environment setup. Taken from
;; https://raw.githubusercontent.com/ansible/ansible/\
;; devel/test/utils/shippable/shippable.sh.
- (invoke "ansible-test" "units" "-v"
+ (invoke "./bin/ansible-test" "units" "-v"
"--num-workers" (number->string
(parallel-job-count)))))))))
(native-inputs
@@ -2954,7 +2946,7 @@ (define-public ansible-core
python-jinja2
python-pyyaml
python-packaging ;for version number parsing
- python-resolvelib-0.5))
+ python-resolvelib))
(home-page "https://www.ansible.com/")
(synopsis "Radically simple IT automation")
(description "Ansible aims to be a radically simple IT automation system.

base-commit: cbd20d627497053871db863970c07d93c7081786
--
2.41.0
Jack Hill wrote 1 years ago
[PATCH v2 2/3] gnu: Remove python-resolvelib@0.5.
(address . 66766@debbugs.gnu.org)
b6f7f6fc7d001fccbbd358d2bcd9f41a70fef010.1698354353.git.jackhill@jackhill.us
* gnu/packages/python-xyz.scm (python-resolvelib-0.5): Delete
variable. This was only used by ansible-core which can now use the
newer version.

Change-Id: Ic40e21561807ed5faae466e13193892e4f9aa6ae
---
gnu/packages/python-xyz.scm | 16 ----------------
1 file changed, 16 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6b991c448b..96ccf38c54 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13763,22 +13763,6 @@ (define-public python-resolvelib
includes dependency resolution logic.")
(license license:isc)))
-;;; This older version is required by ansible-core.
-(define-public python-resolvelib-0.5
- (package/inherit python-resolvelib
- (name "python-resolvelib")
- (version "0.5.4")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/sarugaku/resolvelib")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0697y330sqhiclk25v151qxg7aixzpj434lbg5qib0qlna5zg9la"))))))
-
(define-public python-commonmark
(package
(name "python-commonmark")
--
2.41.0
Jack Hill wrote 1 years ago
[PATCH v2 3/3] gnu: ansible: Update to 8.5.0.
(address . 66766@debbugs.gnu.org)
7531acb3653cabe1eec758b3c9102fde53131fc1.1698354353.git.jackhill@jackhill.us
* gnu/packages/admin.scm (ansible): Update to 8.5.0.

Change-Id: I38ac84a0945f3ba10e13246cf8ae95c3795b52b3
---
gnu/packages/admin.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9e28d2e8c0..afbcf7fda6 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2973,13 +2973,13 @@ (define-public ansible-core
(define-public ansible
(package
(name "ansible")
- (version "7.4.0")
+ (version "8.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ansible" version))
(sha256
- (base32 "142barhwz0wx5kn74xi0bfl21iwq2yq3jp14kxajsg9nggndcr09"))))
+ (base32 "0bazj5h12wraf30bb2schzwk553y20n9vh45km4b5kgmvadm0z1j"))))
(build-system python-build-system)
(propagated-inputs (list ansible-core))
;; The Ansible collections are found by ansible-core via the Python search
--
2.41.0
Jack Hill wrote 1 years ago
[PATCH v2 1/3] gnu: ansible-core: Update to 2.15.5 and fix tests.
(address . 66766@debbugs.gnu.org)
08dc3889305b13fa8cee6244474ed6a105dc30fb.1698354353.git.jackhill@jackhill.us
* gnu/packages/admin.scm (ansible-core): Update to 2.15.5.
[#:phases]<check>: Enable tests that now pass and choose
the right ansible-test to invoke.
[propagated-inputs]: replace python-resolvelib-0.5 with python-resolvelib.

Change-Id: Ibda3222a16fefb1484affdb62e38a3a07ce61986
---
gnu/packages/admin.scm | 16 ++++------------
1 file changed, 4 insertions(+), 12 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 67d836112d..9e28d2e8c0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2835,13 +2835,13 @@ (define-public fdupes
(define-public ansible-core
(package
(name "ansible-core")
- (version "2.14.4")
+ (version "2.15.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ansible-core" version))
(sha256
- (base32 "057g87smxcn6zc558xk4zr6ga4q8clmkyxghn5gx60a94sy61clh"))))
+ (base32 "00hnwjk4dxgxbz4xlza2wqx20yks5xr7074hzlzsyja3ip5kkicc"))))
(build-system python-build-system)
(arguments
`(#:modules ((guix build python-build-system)
@@ -2911,14 +2911,6 @@ (define-public ansible-core
(when tests?
;; Otherwise Ansible fails to create its config directory.
(setenv "HOME" "/tmp")
- ;; This test module messes up with sys.path and causes many
- ;; test failures.
- (delete-file "test/units/_vendor/test_vendor.py")
- ;; The test fails when run in the container, for reasons
- ;; unknown.
- (delete-file "test/units/utils/test_display.py")
- ;; This test fail for reasons unknown.
- (delete-file "test/units/cli/test_adhoc.py")
;; These tests fail in the container; it appears that the
;; mocking of the absolute file names such as /usr/bin/svcs do
;; not work as intended there.
@@ -2933,7 +2925,7 @@ (define-public ansible-core
;; does some extra environment setup. Taken from
;; https://raw.githubusercontent.com/ansible/ansible/\
;; devel/test/utils/shippable/shippable.sh.
- (invoke "ansible-test" "units" "-v"
+ (invoke "./bin/ansible-test" "units" "-v"
"--num-workers" (number->string
(parallel-job-count)))))))))
(native-inputs
@@ -2954,7 +2946,7 @@ (define-public ansible-core
python-jinja2
python-pyyaml
python-packaging ;for version number parsing
- python-resolvelib-0.5))
+ python-resolvelib))
(home-page "https://www.ansible.com/")
(synopsis "Radically simple IT automation")
(description "Ansible aims to be a radically simple IT automation system.

base-commit: a69dec71493c1ecf06071d3304038f3648de69c4
--
2.41.0
Jack Hill wrote 1 years ago
[PATCH v3 1/3] gnu: ansible-core: Update to 2.15.5 and fix tests.
(address . 66766@debbugs.gnu.org)
08dc3889305b13fa8cee6244474ed6a105dc30fb.1698414364.git.jackhill@jackhill.us
* gnu/packages/admin.scm (ansible-core): Update to 2.15.5.
[#:phases]<check>: Enable tests that now pass and choose
the right ansible-test to invoke.
[propagated-inputs]: replace python-resolvelib-0.5 with python-resolvelib.

Change-Id: Ibda3222a16fefb1484affdb62e38a3a07ce61986
---
gnu/packages/admin.scm | 16 ++++------------
1 file changed, 4 insertions(+), 12 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 67d836112d..9e28d2e8c0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2835,13 +2835,13 @@ (define-public fdupes
(define-public ansible-core
(package
(name "ansible-core")
- (version "2.14.4")
+ (version "2.15.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ansible-core" version))
(sha256
- (base32 "057g87smxcn6zc558xk4zr6ga4q8clmkyxghn5gx60a94sy61clh"))))
+ (base32 "00hnwjk4dxgxbz4xlza2wqx20yks5xr7074hzlzsyja3ip5kkicc"))))
(build-system python-build-system)
(arguments
`(#:modules ((guix build python-build-system)
@@ -2911,14 +2911,6 @@ (define-public ansible-core
(when tests?
;; Otherwise Ansible fails to create its config directory.
(setenv "HOME" "/tmp")
- ;; This test module messes up with sys.path and causes many
- ;; test failures.
- (delete-file "test/units/_vendor/test_vendor.py")
- ;; The test fails when run in the container, for reasons
- ;; unknown.
- (delete-file "test/units/utils/test_display.py")
- ;; This test fail for reasons unknown.
- (delete-file "test/units/cli/test_adhoc.py")
;; These tests fail in the container; it appears that the
;; mocking of the absolute file names such as /usr/bin/svcs do
;; not work as intended there.
@@ -2933,7 +2925,7 @@ (define-public ansible-core
;; does some extra environment setup. Taken from
;; https://raw.githubusercontent.com/ansible/ansible/\
;; devel/test/utils/shippable/shippable.sh.
- (invoke "ansible-test" "units" "-v"
+ (invoke "./bin/ansible-test" "units" "-v"
"--num-workers" (number->string
(parallel-job-count)))))))))
(native-inputs
@@ -2954,7 +2946,7 @@ (define-public ansible-core
python-jinja2
python-pyyaml
python-packaging ;for version number parsing
- python-resolvelib-0.5))
+ python-resolvelib))
(home-page "https://www.ansible.com/")
(synopsis "Radically simple IT automation")
(description "Ansible aims to be a radically simple IT automation system.

base-commit: a69dec71493c1ecf06071d3304038f3648de69c4
--
2.41.0
Jack Hill wrote 1 years ago
[PATCH v3 3/3] gnu: ansible: Update to 8.5.0.
(address . 66766@debbugs.gnu.org)
7531acb3653cabe1eec758b3c9102fde53131fc1.1698414364.git.jackhill@jackhill.us
* gnu/packages/admin.scm (ansible): Update to 8.5.0.

Change-Id: I38ac84a0945f3ba10e13246cf8ae95c3795b52b3
---
gnu/packages/admin.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9e28d2e8c0..afbcf7fda6 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2973,13 +2973,13 @@ (define-public ansible-core
(define-public ansible
(package
(name "ansible")
- (version "7.4.0")
+ (version "8.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "ansible" version))
(sha256
- (base32 "142barhwz0wx5kn74xi0bfl21iwq2yq3jp14kxajsg9nggndcr09"))))
+ (base32 "0bazj5h12wraf30bb2schzwk553y20n9vh45km4b5kgmvadm0z1j"))))
(build-system python-build-system)
(propagated-inputs (list ansible-core))
;; The Ansible collections are found by ansible-core via the Python search
--
2.41.0
Jack Hill wrote 1 years ago
[PATCH v3 2/3] gnu: Remove python-resolvelib@0.5.
(address . 66766@debbugs.gnu.org)
b6f7f6fc7d001fccbbd358d2bcd9f41a70fef010.1698414364.git.jackhill@jackhill.us
* gnu/packages/python-xyz.scm (python-resolvelib-0.5): Delete
variable. This was only used by ansible-core which can now use the
newer version.

Change-Id: Ic40e21561807ed5faae466e13193892e4f9aa6ae
---
gnu/packages/python-xyz.scm | 16 ----------------
1 file changed, 16 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6b991c448b..96ccf38c54 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13763,22 +13763,6 @@ (define-public python-resolvelib
includes dependency resolution logic.")
(license license:isc)))
-;;; This older version is required by ansible-core.
-(define-public python-resolvelib-0.5
- (package/inherit python-resolvelib
- (name "python-resolvelib")
- (version "0.5.4")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/sarugaku/resolvelib")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0697y330sqhiclk25v151qxg7aixzpj434lbg5qib0qlna5zg9la"))))))
-
(define-public python-commonmark
(package
(name "python-commonmark")
--
2.41.0
Christopher Baines wrote 1 years ago
Re: [bug#66766] [PATCH v3 3/3] gnu: ansible: Update to 8.5.0.
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 66766-done@debbugs.gnu.org)
87a5s0xs2m.fsf@cbaines.net
Jack Hill <jackhill@jackhill.us> writes:

Toggle quote (7 lines)
> * gnu/packages/admin.scm (ansible): Update to 8.5.0.
>
> Change-Id: I38ac84a0945f3ba10e13246cf8ae95c3795b52b3
> ---
> gnu/packages/admin.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)

This patch, and the preceding ones look good to me. I've pushed them to
master as 85451b38dd175f8bd4bcb42336c895bdc9373d28.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmU/lKFfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xdo8A//Xo//jOVb6Cfut5LbqgD+D/wH3kyQF5B8
SFtmzxd5HpKR1oijpS4S+9R1rUqeAUw8wBhzg58AbDTGpy2KqsaCKkvaNdh1yDY1
yfVMoSnWNc072btRIIkH8oRgiFf571ECBSoC/l4f9lf2syUPmMbjq/rOqaqaUjnY
8PomKKjGMC+49XI1CLlX7iXMgxjSuop+tuGlo9jspgzHbVi2lrwiTblsR65pCS6g
GUphSTUQugb2ASA8+T6E6fua9ygnjBjPlrEPHW8LOXV6Vtzqx7XQ9bH4vDt37B90
99Ly3OxjT5286ko5am/yXDvP7X6xACXUJohZmi28/xQFAe2OA838K69QEcgHeDUL
7HVHT+UkbWbiR4tLDCigRV0j233sL2aa2lj8bO/XOnfNJMa9jd1IduT5UbAMBKxS
YNeBUNHuxj9QwDB9VRfooBdtMQoGfJdWh6XVbru0wiIXx/FoU8hmQTUtcvA+wRZT
jlSoARLkmj56PBwDioGC6rLYUdopKVeSNkmG1eBA9jVlHOULMIiPfv0EGVf0XeO+
14rfR47GGwBoPp8frckfllTdWSNNKAvHRSqFu8vMG0urluAACPRyb/o5/wyc3Vfy
13Cma7o/QONwv1eXVZ7nYws6pcL9hXLSTmtiWu5qCOqyppo9Ww2t5PEumhDdiLHg
U+/IdbV+WN4=
=l6oT
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66766@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66766
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help