grep 3.8 now needs pcre2 as input, not pcre

  • Done
  • quality assurance status badge
Details
2 participants
  • Matt Beshara
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Matt Beshara
Severity
normal
M
M
Matt Beshara wrote on 26 Oct 2023 00:21
(address . bug-guix@gnu.org)
87zg06496e.fsf@mfa.pw
Hi Guix people,
I have been working on creating a package definition for
pulseaudio-equalizer¹ and when built with the current definition
of the grep package, it prints this error message when running:

grep: Perl matching not supported in a --disable-perl-regexp build
grep: write error: Broken pipe

Searching for that error message, I came across this:

So it seems that, for version 3.8, the pcre input package for grep
should be changed to pcre2. I have made this change in a new
definition which inherits grep and told my pulseaudio-equalizer
package to use that as a propagated input, and that causes the
error to go away. For the sake of completeness, here’s the
definition I used:

(define grep-fixed
(package
(inherit grep)
(inputs (list pcre2))))

Best wishes,
Matt

M
M
Maxim Cournoyer wrote on 22 Jan 05:34 +0100
(name . Matt Beshara)(address . m@mfa.pw)(address . 66753-done@debbugs.gnu.org)
87fryq56ll.fsf@gmail.com
Hi,

Matt Beshara <m@mfa.pw> writes:

Toggle quote (26 lines)
> Hi Guix people,
> I have been working on creating a package definition for
> pulseaudio-equalizer¹ and when built with the current definition of
> the grep package, it prints this error message when running:
>
> grep: Perl matching not supported in a --disable-perl-regexp build
> grep: write error: Broken pipe
>
> Searching for that error message, I came across this:
> https://trac.macports.org/ticket/65800
>
> So it seems that, for version 3.8, the pcre input package for grep
> should be changed to pcre2. I have made this change in a new
> definition which inherits grep and told my pulseaudio-equalizer
> package to use that as a propagated input, and that causes the error
> to go away. For the sake of completeness, here’s the definition I
> used:
>
> (define grep-fixed
> (package
> (inherit grep)
> (inputs (list pcre2))))
>
> Best wishes,
> Matt

This appears to have been fixed independently by spacecadet in commit
5b0cea02358044f0cc695bacc3f44db1e220239b ("gnu: grep: Fix PCRE matches
(grep -P).").

Closing!

--
Thanks,
Maxim
Closed
?