Tomas Volf wrote 1 years ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . wolf@wolfsden.cz)
* gnu/packages/rust-apps.scm (rust-cbindgen-0.26): New variable.
(rust-cbindgen-0.24): Inherit from rust-cbindgen-0.26.
Change-Id: Id17f8e251ceecc8ae0708dcfc19acfc5c56b824f
---
The formating of the arguments and the native-inputs is a bit different than
before, but this is what guix style did produce.
gnu/packages/rust-apps.scm | 58 ++++++++++++++++++++++----------------
1 file changed, 34 insertions(+), 24 deletions(-)
Toggle diff (78 lines)
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 4a4247751b..a06447143a 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1370,35 +1370,45 @@ (define-public rust-cbindgen
"This package provides a tool for generating C/C++ bindings to Rust code.")
(license license:mpl2.0)))
-(define-public rust-cbindgen-0.24
+(define-public rust-cbindgen-0.26
(package
(inherit rust-cbindgen)
(name "rust-cbindgen")
+ (version "0.26.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cbindgen" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0jdbxmn5h5nlr4bifx85gny309djv5djs9q78fa1d7sj0wdw2sys"))))
+ (arguments
+ `(#:cargo-inputs (("rust-clap" ,rust-clap-3)
+ ("rust-heck" ,rust-heck-0.4)
+ ("rust-indexmap" ,rust-indexmap-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-syn" ,rust-syn-1)
+ ("rust-tempfile" ,rust-tempfile-3)
+ ("rust-toml" ,rust-toml-0.5))
+ #:cargo-development-inputs (("rust-serial-test" ,rust-serial-test-0.5))))
+ (native-inputs (list python-cython))))
+
+(define-public rust-cbindgen-0.24
+ (package
+ (inherit rust-cbindgen-0.26)
+ (name "rust-cbindgen")
(version "0.24.3")
(source (origin
- (method url-fetch)
- (uri (crate-uri "cbindgen" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1yqxqsz2d0cppd8zwihk2139g5gy38wqgl9snj6rnk8gyvnqsdd6"))))
- (arguments
- `(#:cargo-inputs
- (("rust-clap" ,rust-clap-3)
- ("rust-heck" ,rust-heck-0.4)
- ("rust-indexmap" ,rust-indexmap-1)
- ("rust-log" ,rust-log-0.4)
- ("rust-proc-macro2" ,rust-proc-macro2-1)
- ("rust-quote" ,rust-quote-1)
- ("rust-serde" ,rust-serde-1)
- ("rust-serde-json" ,rust-serde-json-1)
- ("rust-syn" ,rust-syn-1)
- ("rust-tempfile" ,rust-tempfile-3)
- ("rust-toml" ,rust-toml-0.5))
- #:cargo-development-inputs
- (("rust-serial-test" ,rust-serial-test-0.5))))
- (native-inputs
- (list python-cython))))
+ (method url-fetch)
+ (uri (crate-uri "cbindgen" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1yqxqsz2d0cppd8zwihk2139g5gy38wqgl9snj6rnk8gyvnqsdd6"))))))
(define-public rust-cbindgen-0.23
(package
base-commit: bd34d5818842871e83aac12305263a821220d124
--
2.41.0