[PATCH] gnu: Add rust-cbindgen-0.26.

  • Done
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • John Kehayias
  • Tomas Volf
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal

Debbugs page

Tomas Volf wrote 1 years ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . wolf@wolfsden.cz)
3123036ee09665554505c0be483af632c1afc52c.1698158872.git.wolf@wolfsden.cz
* gnu/packages/rust-apps.scm (rust-cbindgen-0.26): New variable.
(rust-cbindgen-0.24): Inherit from rust-cbindgen-0.26.

Change-Id: Id17f8e251ceecc8ae0708dcfc19acfc5c56b824f
---
The formating of the arguments and the native-inputs is a bit different than
before, but this is what guix style did produce.

gnu/packages/rust-apps.scm | 58 ++++++++++++++++++++++----------------
1 file changed, 34 insertions(+), 24 deletions(-)

Toggle diff (78 lines)
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 4a4247751b..a06447143a 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -1370,35 +1370,45 @@ (define-public rust-cbindgen
"This package provides a tool for generating C/C++ bindings to Rust code.")
(license license:mpl2.0)))
-(define-public rust-cbindgen-0.24
+(define-public rust-cbindgen-0.26
(package
(inherit rust-cbindgen)
(name "rust-cbindgen")
+ (version "0.26.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cbindgen" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0jdbxmn5h5nlr4bifx85gny309djv5djs9q78fa1d7sj0wdw2sys"))))
+ (arguments
+ `(#:cargo-inputs (("rust-clap" ,rust-clap-3)
+ ("rust-heck" ,rust-heck-0.4)
+ ("rust-indexmap" ,rust-indexmap-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-syn" ,rust-syn-1)
+ ("rust-tempfile" ,rust-tempfile-3)
+ ("rust-toml" ,rust-toml-0.5))
+ #:cargo-development-inputs (("rust-serial-test" ,rust-serial-test-0.5))))
+ (native-inputs (list python-cython))))
+
+(define-public rust-cbindgen-0.24
+ (package
+ (inherit rust-cbindgen-0.26)
+ (name "rust-cbindgen")
(version "0.24.3")
(source (origin
- (method url-fetch)
- (uri (crate-uri "cbindgen" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1yqxqsz2d0cppd8zwihk2139g5gy38wqgl9snj6rnk8gyvnqsdd6"))))
- (arguments
- `(#:cargo-inputs
- (("rust-clap" ,rust-clap-3)
- ("rust-heck" ,rust-heck-0.4)
- ("rust-indexmap" ,rust-indexmap-1)
- ("rust-log" ,rust-log-0.4)
- ("rust-proc-macro2" ,rust-proc-macro2-1)
- ("rust-quote" ,rust-quote-1)
- ("rust-serde" ,rust-serde-1)
- ("rust-serde-json" ,rust-serde-json-1)
- ("rust-syn" ,rust-syn-1)
- ("rust-tempfile" ,rust-tempfile-3)
- ("rust-toml" ,rust-toml-0.5))
- #:cargo-development-inputs
- (("rust-serial-test" ,rust-serial-test-0.5))))
- (native-inputs
- (list python-cython))))
+ (method url-fetch)
+ (uri (crate-uri "cbindgen" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1yqxqsz2d0cppd8zwihk2139g5gy38wqgl9snj6rnk8gyvnqsdd6"))))))
(define-public rust-cbindgen-0.23
(package

base-commit: bd34d5818842871e83aac12305263a821220d124
--
2.41.0
John Kehayias wrote 1 years ago
(name . Tomas Volf)(address . wolf@wolfsden.cz)
87msw51h2u.fsf@protonmail.com
Hi Tomas,

On Tue, Oct 24, 2023 at 04:47 PM, Tomas Volf wrote:

Toggle quote (9 lines)
> * gnu/packages/rust-apps.scm (rust-cbindgen-0.26): New variable.
> (rust-cbindgen-0.24): Inherit from rust-cbindgen-0.26.
>
> Change-Id: Id17f8e251ceecc8ae0708dcfc19acfc5c56b824f
> ---
> The formating of the arguments and the native-inputs is a bit different than
> before, but this is what guix style did produce.
>

I think I've seen both ways; this is fine to me.

Toggle quote (80 lines)
> gnu/packages/rust-apps.scm | 58 ++++++++++++++++++++++----------------
> 1 file changed, 34 insertions(+), 24 deletions(-)
>
> diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
> index 4a4247751b..a06447143a 100644
> --- a/gnu/packages/rust-apps.scm
> +++ b/gnu/packages/rust-apps.scm
> @@ -1370,35 +1370,45 @@ (define-public rust-cbindgen
> "This package provides a tool for generating C/C++ bindings to Rust code.")
> (license license:mpl2.0)))
>
> -(define-public rust-cbindgen-0.24
> +(define-public rust-cbindgen-0.26
> (package
> (inherit rust-cbindgen)
> (name "rust-cbindgen")
> + (version "0.26.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (crate-uri "cbindgen" version))
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32 "0jdbxmn5h5nlr4bifx85gny309djv5djs9q78fa1d7sj0wdw2sys"))))
> + (arguments
> + `(#:cargo-inputs (("rust-clap" ,rust-clap-3)
> + ("rust-heck" ,rust-heck-0.4)
> + ("rust-indexmap" ,rust-indexmap-1)
> + ("rust-log" ,rust-log-0.4)
> + ("rust-proc-macro2" ,rust-proc-macro2-1)
> + ("rust-quote" ,rust-quote-1)
> + ("rust-serde" ,rust-serde-1)
> + ("rust-serde-json" ,rust-serde-json-1)
> + ("rust-syn" ,rust-syn-1)
> + ("rust-tempfile" ,rust-tempfile-3)
> + ("rust-toml" ,rust-toml-0.5))
> + #:cargo-development-inputs (("rust-serial-test" ,rust-serial-test-0.5))))
> + (native-inputs (list python-cython))))
> +
> +(define-public rust-cbindgen-0.24
> + (package
> + (inherit rust-cbindgen-0.26)
> + (name "rust-cbindgen")
> (version "0.24.3")
> (source (origin
> - (method url-fetch)
> - (uri (crate-uri "cbindgen" version))
> - (file-name (string-append name "-" version ".tar.gz"))
> - (sha256
> - (base32
> - "1yqxqsz2d0cppd8zwihk2139g5gy38wqgl9snj6rnk8gyvnqsdd6"))))
> - (arguments
> - `(#:cargo-inputs
> - (("rust-clap" ,rust-clap-3)
> - ("rust-heck" ,rust-heck-0.4)
> - ("rust-indexmap" ,rust-indexmap-1)
> - ("rust-log" ,rust-log-0.4)
> - ("rust-proc-macro2" ,rust-proc-macro2-1)
> - ("rust-quote" ,rust-quote-1)
> - ("rust-serde" ,rust-serde-1)
> - ("rust-serde-json" ,rust-serde-json-1)
> - ("rust-syn" ,rust-syn-1)
> - ("rust-tempfile" ,rust-tempfile-3)
> - ("rust-toml" ,rust-toml-0.5))
> - #:cargo-development-inputs
> - (("rust-serial-test" ,rust-serial-test-0.5))))
> - (native-inputs
> - (list python-cython))))
> + (method url-fetch)
> + (uri (crate-uri "cbindgen" version))
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "1yqxqsz2d0cppd8zwihk2139g5gy38wqgl9snj6rnk8gyvnqsdd6"))))))
>
> (define-public rust-cbindgen-0.23
> (package
>
> base-commit: bd34d5818842871e83aac12305263a821220d124

Thanks, applied as a69dec71493c1ecf06071d3304038f3648de69c4 after
discussing with Efraim on #guix (there's 19003bf84aff99e6aa2eef60559d14772ea2aab2
on rust-team but I opted for this one since it was all the same to
Efraim).

John
Closed
Efraim Flashner wrote 1 years ago
(name . Tomas Volf)(address . wolf@wolfsden.cz)(address . 66729-done@debbugs.gnu.org)
ZUdu9PcxLXnm3ZSe@3900XT
Looks like this patch was applied. Closing!

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmVHbvQACgkQQarn3Mo9
g1Hc8A//QqpgHaZgztAIz2Tvt7VLbvZoCaynwtXEWt54gAOCmKVeP+htEMif+Yuw
bXKiBFSVQwpk4y2Eq3omOnFVJTW5SXN6ejt6ht5FxxkBmBBkqRdECs4JM9AfQOxf
OcAUfkQzxYwE7ivE+5aROX2b8nZCmLqQRD3pH31giKWhApNo2C3h2nVu8A7uf7HV
bvnrCI1MmqsQeKQYNgpUyAct3SacPnDtmYHPx6KGXFNccessu2gx81nDJ+BcqdmR
DPIgH1MZPyRbmdzLi3fVG4b7CJRkZAxKAgVEsW3g1Y1rpdj/2V76mTt0BfxH1yDW
M3hTKE+QrJxUkY8+a6OfoiSBiSNS68cJ7Sq/ng2PmlSmeSHCkaqoYk4aaNvtQ9Kr
Y5hlgNU7egG0r8GdvDvyRfS5upLMXgS5II2onpVdfu2viqyA7VTtjnTh/p62x3w3
aF1M+CAz8xe3nPTH7PRHcw1ACpTeOhScm/i8em4z11pUAGl2hHIhSDzZWcGd4Jq6
S4ty1YgTFZRM6GSz/IAvBQ5pg9nhG95nFnvP8926xJH6ofp1S2gGDTJuf31bT5rJ
XgBY/U6XQSjrzvOIMJDtzEPDpZ5P+QF8xy/nkPAubgdbWTqxiPeLSI9CvyPg9TM+
eZJFiIwrnZkLADRTQQsO7r3cm1aOgxuV8Vj5gDM+wvioCBmMp7M=
=CHHA
-----END PGP SIGNATURE-----


Closed
Tomas Volf wrote 1 years ago
control message for bug #66729
(address . control@debbugs.gnu.org)
3ec79caf327c70c471c0b0dc8943609e@wolfsden.cz
unarchive 66729
quit
Tomas Volf wrote 1 years ago
(address . control@debbugs.gnu.org)
878r3kz8e6.fsf@wolfsden.cz
submitter 66729 !
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66729@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66729
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help