[PATCH] gnu: Add python-numpy-illustrated.

  • Done
  • quality assurance status badge
Details
One participant
  • Andreas Enge
Owner
unassigned
Submitted by
Andreas Enge
Severity
normal

Debbugs page

Andreas Enge wrote 1 years ago
(address . guix-patches@gnu.org)(name . Andreas Enge)(address . andreas.enge@inria.fr)
05b01891e3840a0cce19704f6a5bed47dd980630.1698083429.git.andreas.enge@inria.fr
* gnu/packages/python-xyz.scm (python-numpy-illustrated): New variable.

Change-Id: If4546822f2c36966698fb59499f5a20001a0a0e1
---
gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 65c23cb318..dd2d49f919 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7401,6 +7401,26 @@ (define-public python-numpy-documentation
(description "This package provides the complete NumPy documentation in
the Texinfo, HTML, and PDF formats.")))
+(define-public python-numpy-illustrated
+ (package
+ (name "python-numpy-illustrated")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "numpy-illustrated" version))
+ (sha256
+ (base32 "0s7ki6lm9xwd4pj7rx6al230wbywqk11wjvgdk44lbdq2fz7kfxd"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-numpy))
+ (home-page "https://github.com/axil/numpy-illustrated")
+ (synopsis "Helper functions from the NumPy Illustrated guide")
+ (description
+ "This package provides helper functions for the
+@url{https://betterprogramming.pub/numpy-illustrated-the-visual-guide-to-numpy-3b1d4976de1d?sk=57b908a77aa44075a49293fa1631dd9b,
+NumPy Illustrated} programming guide.")
+ (license license:expat)))
+
(define-public python-munch
(package
(name "python-munch")

base-commit: b6619c5db410fb01e552c6168bd6bc7f41c6c993
--
2.41.0
Andreas Enge wrote 1 years ago
Closing for now
(address . 66707-done@debbugs.gnu.org)
ZTa0TE-Ti4nEohm0@jurong
This is supposed to be the outcome of a tutorial on Guix packaging
I plan to give next month, and which I am testing. So please just
disregard it for now, I will file it again live.

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66707@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66707
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help