Andreas Enge wrote 1 years ago
(address . guix-patches@gnu.org)(name . Andreas Enge)(address . andreas.enge@inria.fr)
* gnu/packages/python-xyz.scm (python-numpy-illustrated): New variable.
Change-Id: If4546822f2c36966698fb59499f5a20001a0a0e1
---
gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 65c23cb318..dd2d49f919 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7401,6 +7401,26 @@ (define-public python-numpy-documentation
(description "This package provides the complete NumPy documentation in
the Texinfo, HTML, and PDF formats.")))
+(define-public python-numpy-illustrated
+ (package
+ (name "python-numpy-illustrated")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "numpy-illustrated" version))
+ (sha256
+ (base32 "0s7ki6lm9xwd4pj7rx6al230wbywqk11wjvgdk44lbdq2fz7kfxd"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-numpy))
+ (home-page "https://github.com/axil/numpy-illustrated")
+ (synopsis "Helper functions from the NumPy Illustrated guide")
+ (description
+ "This package provides helper functions for the
+@url{https://betterprogramming.pub/numpy-illustrated-the-visual-guide-to-numpy-3b1d4976de1d?sk=57b908a77aa44075a49293fa1631dd9b,
+NumPy Illustrated} programming guide.")
+ (license license:expat)))
+
(define-public python-munch
(package
(name "python-munch")
base-commit: b6619c5db410fb01e552c6168bd6bc7f41c6c993
--
2.41.0