(address . bug-guix@gnu.org)
The recently-committed GnuTLS 3.8.1 fails to (cross-)build for GNU/Hurd:
Toggle snippet (48 lines)
CC common.lo
CC key_encode.lo
CC key_decode.lo
CC time.lo
In file included from ./../system.h:47,
from ./../gnutls_int.h:85,
from common.c:24:
./../pathbuf.h:28:25: error: 'PATH_MAX' undeclared here (not in a function)
28 | #define GNUTLS_PATH_MAX PATH_MAX
| ^~~~~~~~
./../pathbuf.h:31:19: note: in expansion of macro 'GNUTLS_PATH_MAX'
31 | char base[GNUTLS_PATH_MAX + 1];
| ^~~~~~~~~~~~~~~
In file included from ./../system.h:47,
from ./../gnutls_int.h:85,
from time.c:24:
./../pathbuf.h:28:25: error: 'PATH_MAX' undeclared here (not in a function)
28 | #define GNUTLS_PATH_MAX PATH_MAX
| ^~~~~~~~
./../pathbuf.h:31:19: note: in expansion of macro 'GNUTLS_PATH_MAX'
31 | char base[GNUTLS_PATH_MAX + 1];
| ^~~~~~~~~~~~~~~
In file included from ./../system.h:47,
from ./../gnutls_int.h:85,
from key_decode.c:24:
./../pathbuf.h:28:25: error: 'PATH_MAX' undeclared here (not in a function)
28 | #define GNUTLS_PATH_MAX PATH_MAX
| ^~~~~~~~
./../pathbuf.h:31:19: note: in expansion of macro 'GNUTLS_PATH_MAX'
31 | char base[GNUTLS_PATH_MAX + 1];
| ^~~~~~~~~~~~~~~
In file included from ./../system.h:47,
from ./../gnutls_int.h:85,
from key_encode.c:24:
./../pathbuf.h:28:25: error: 'PATH_MAX' undeclared here (not in a function)
28 | #define GNUTLS_PATH_MAX PATH_MAX
| ^~~~~~~~
./../pathbuf.h:31:19: note: in expansion of macro 'GNUTLS_PATH_MAX'
31 | char base[GNUTLS_PATH_MAX + 1];
| ^~~~~~~~~~~~~~~
make[5]: *** [Makefile:2330: time.lo] Error 1
make[5]: *** Waiting for unfinished jobs....
make[5]: *** [Makefile:2330: common.lo] Error 1
make[5]: *** [Makefile:2330: key_decode.lo] Error 1
make[5]: *** [Makefile:2330: key_encode.lo] Error 1
make[5]: Leaving directory '/tmp/guix-build-gnutls-3.8.1.drv-0/gnutls-3.8.1/lib/x509'
This is because ‘PATH_MAX’ is undefined on GNU/Hurd.
Ludo’.