* gnu/packages/glib.scm (appstream-glib): Update to 0.8.2.
[native-inputs]: Update style.
[propagated-inputs]: Same.
[inputs]: Replace libsoup with curl. Update style.
[arguments]: Update style.
[description]: Fix lint issue.
Change-Id: Icea8c8330351127d0cc85e74716ebd3c3c4a88fa
---
gnu/packages/glib.scm | 70 +++++++++++++++++++++++--------------------
1 file changed, 37 insertions(+), 33 deletions(-)
Toggle diff (104 lines)
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index af3f15b0ea..81a7785160 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -45,6 +45,7 @@ (define-module (gnu packages glib)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages cpp)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages elf)
@@ -1293,7 +1294,7 @@ (define-public sdbus-c++
(define-public appstream-glib
(package
(name "appstream-glib")
- (version "0.7.18")
+ (version "0.8.2")
(source (origin
(method url-fetch)
(uri (string-append "https://people.freedesktop.org/~hughsient/"
@@ -1301,45 +1302,48 @@ (define-public appstream-glib
"appstream-glib-" version ".tar.xz"))
(sha256
(base32
- "00j0kkgf224nzmrha72g8pd72mymhph7vaisj35i4ffy7cpd47na"))))
+ "15lbrmyx94cf6p6svq02yiskh31xidq092c711pqs16mml06a9bi"))))
(build-system meson-build-system)
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("gsettings" ,gsettings-desktop-schemas) ; for ‘org.gnome.system.proxy’
- ("glib:bin" ,glib "bin") ; for glib-compile-resources
- ("pkg-config" ,pkg-config)))
+ (list gettext-minimal
+ `(,glib "bin") ;for glib-compile-resources
+ gsettings-desktop-schemas ;for ‘org.gnome.system.proxy’
+ pkg-config))
(propagated-inputs
- `(("gcab" ,gcab) ; for .pc file
- ("gdk-pixbuf" ,gdk-pixbuf) ; for .pc file
- ("libuuid" ,util-linux "lib"))) ; for .pc file
+ (list gcab ;for .pc file
+ gdk-pixbuf ;same
+ `(,util-linux "lib"))) ;libuuid, for .pc file
(inputs
- `(("glib" ,glib)
- ("gperf" ,gperf)
- ("gtk+" ,gtk+)
- ("json-glib" ,json-glib)
- ("libarchive" ,libarchive)
- ("libsoup" ,libsoup-minimal-2)))
+ (list curl
+ gperf
+ gtk+
+ json-glib
+ libarchive
+ glib))
(arguments
- `(#:configure-flags
- (list "-Ddep11=false"
- "-Dintrospection=false" ; avoid g-ir-scanner dependency
- "-Drpm=false"
- "-Dstemmer=false")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-tests
- (lambda _
- (substitute* "libappstream-glib/as-self-test.c"
- (("g_test_add_func.*as_test_store_local_appdata_func);") ""))
- #t))
- (add-before 'check 'set-home
- (lambda _
- ;; Some tests want write access there.
- (setenv "HOME" "/tmp"))))))
+ (list
+ #:configure-flags
+ #~(list "-Ddep11=false"
+ "-Dintrospection=false" ; avoid g-ir-scanner dependency
+ "-Drpm=false"
+ "-Dstemmer=false")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ (substitute* "libappstream-glib/as-self-test.c"
+ (("g_test_add_func.*as_test_store_local_appdata_func);") ""))
+ #t))
+ (add-before 'check 'set-home
+ (lambda _
+ ;; Some tests want write access there.
+ (setenv "HOME" "/tmp"))))))
(home-page "https://github.com/hughsie/appstream-glib")
(synopsis "Library for reading and writing AppStream metadata")
- (description "This library provides objects and helper methods to help
-reading and writing @uref{https://www.freedesktop.org/wiki/Distributions/AppStream,AppStream}
+ (description
+ "This library provides objects and helper methods to help
+reading and writing
+@uref{https://www.freedesktop.org/wiki/Distributions/AppStream,AppStream}
metadata.")
(license license:lgpl2.1+)))
--
2.41.0