References to ungrafted glibc retained

  • Done
  • quality assurance status badge
Details
One participant
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
important

Debbugs page

Ludovic Courtès wrote 1 years ago
(address . bug-guix@gnu.org)
87bkcss7iw.fsf@inria.fr
As discussed while reviewing the now-applied glibc replacement at
https://issues.guix.gnu.org/66348, I stumbled upon a case where a
package still refers to a ungrafted glibc in addition to the grafted
one:

Toggle snippet (19 lines)
$ guix gc -R $(guix build libreoffice) | grep glibc-2.35
/gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35
$ guix build -e '(@@ (gnu packages commencement) glibc-final)'
/gnu/store/gd0x2az3a0sgj5aa9fbv201g7wwfj5m7-glibc-2.35-debug
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35
/gnu/store/i2g0is6wjq3ccs6m1l6w9mhf44k4042h-glibc-2.35-static
$ guix build -e '(@@ (gnu packages commencement) glibc-final)' --no-grafts
/gnu/store/0lzva77yj6hddmhasia65krknyi8kxsg-glibc-2.35-debug
/gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35
/gnu/store/l0yryi5jsa1grnvw01c9nkz9c81cv224-glibc-2.35-static
$ guix describe
Generation 277 Oct 16 2023 23:15:43 (current)
guix b437896
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: b437896e87a51cc610388d4c462893652dd773e6

The path to the ungrafted libc goes like this:

Toggle snippet (7 lines)
$ guix graph --path -t references $(guix build libreoffice) /gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35
/gnu/store/n8y9jk8wnvxxg54g19ds0jf5agiv5vs2-libreoffice-7.5.4.2
/gnu/store/y392yldk4pbk4z5q587bz5n61hzbcf4g-mariadb-10.10.2-dev
/gnu/store/cilkyfnc5fxmpviyypci3d2881ik3nih-mariadb-10.10.2-lib
/gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35

Similar problem with GIMP:

Toggle snippet (11 lines)
$ guix gc -R $(guix build gimp) | grep glibc-2.35
/gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35
$ guix graph --path -t references $(guix build gimp |grep -v doc) /gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35
/gnu/store/fw40cg57p0ycggrf8qvhl116257c5vv7-gimp-2.10.32
/gnu/store/mhfdl59lwhv4nh5kd4pnrh8jjls6976w-exiv2-0.27.5
/gnu/store/47xjz7g247yrnfxbkpr0hi81cqkrlvdn-gcc-11.3.0
/gnu/store/930nwsiysdvy2x5zv1sf6v7ym75z8ayk-gcc-11.3.0-lib
/gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35

Ludo’.
Ludovic Courtès wrote 1 years ago
control message for bug #66662
(address . control@debbugs.gnu.org)
87a5scs780.fsf@gnu.org
severity 66662 important
quit
Ludovic Courtès wrote 1 years ago
(address . control@debbugs.gnu.org)
878r7ws77v.fsf@gnu.org
tags 66662 + security
quit
Ludovic Courtès wrote 1 years ago
Re: bug#66662: References to ungrafted glibc retained
(address . 66662-done@debbugs.gnu.org)
87bkcjab51.fsf@gnu.org
Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (32 lines)
> As discussed while reviewing the now-applied glibc replacement at
> <https://issues.guix.gnu.org/66348>, I stumbled upon a case where a
> package still refers to a ungrafted glibc in addition to the grafted
> one:
>
> $ guix gc -R $(guix build libreoffice) | grep glibc-2.35
> /gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35
> /gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35
> $ guix build -e '(@@ (gnu packages commencement) glibc-final)'
> /gnu/store/gd0x2az3a0sgj5aa9fbv201g7wwfj5m7-glibc-2.35-debug
> /gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35
> /gnu/store/i2g0is6wjq3ccs6m1l6w9mhf44k4042h-glibc-2.35-static
> $ guix build -e '(@@ (gnu packages commencement) glibc-final)' --no-grafts
> /gnu/store/0lzva77yj6hddmhasia65krknyi8kxsg-glibc-2.35-debug
> /gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35
> /gnu/store/l0yryi5jsa1grnvw01c9nkz9c81cv224-glibc-2.35-static
> $ guix describe
> Generation 277 Oct 16 2023 23:15:43 (current)
> guix b437896
> repository URL: https://git.savannah.gnu.org/git/guix.git
> branch: master
> commit: b437896e87a51cc610388d4c462893652dd773e6
>
>
> The path to the ungrafted libc goes like this:
>
> $ guix graph --path -t references $(guix build libreoffice) /gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35
> /gnu/store/n8y9jk8wnvxxg54g19ds0jf5agiv5vs2-libreoffice-7.5.4.2
> /gnu/store/y392yldk4pbk4z5q587bz5n61hzbcf4g-mariadb-10.10.2-dev
> /gnu/store/cilkyfnc5fxmpviyypci3d2881ik3nih-mariadb-10.10.2-lib
> /gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35

Fixed in 67effc1560fc175dfbcb58ef5b965b08b3942d6c, which actually
removes a few lines of code in grafts.scm.

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66662@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66662
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help