[PATCH] gnu: Add moonfish.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ricardo Wurmus
  • zamfofex
Owner
unassigned
Submitted by
zamfofex
Severity
normal
Z
Z
zamfofex wrote on 20 Oct 2023 20:40
(address . guix-patches@gnu.org)(name . zamfofex)(address . zamfofex@twdb.moe)
7e8a3994730ad4b020d1f45ae65fac4ff3504b66.1697827234.git.zamfofex@twdb.moe
* gnu/packages/games.scm (moonfish): New variable.
---
gnu/packages/games.scm | 50 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (69 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4d5b85248a..cd48130f08 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10409,6 +10409,56 @@ (define-public stockfish
(home-page "https://stockfishchess.org/")
(license license:gpl3+))))
+(define-public moonfish
+ (let ((commit "69674e88a5393217a724b9390ff3c843bd0fc768")
+ (revision "1"))
+ (package
+ (name "moonfish")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~zamfofex/moonfish")
+ (commit commit)))
+ (sha256
+ (base32
+ "10hfdjr6qi6ladmgq9h69v3zkarld9kjaav7q3y8w5fakljypjjb"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (inputs (list bearssl cjson))
+ (outputs '("out" "tools"))
+ (arguments
+ `(#:make-flags '(,(string-append "CC="
+ (cc-for-target)))
+ #:tests? #f ;no check target
+ #:phases (modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (replace 'install
+ ;; no 'install' target
+ (lambda _
+ (let* ((out (assoc-ref %outputs "out"))
+ (tools (assoc-ref %outputs "tools"))
+ (out-bin (string-append out "/bin"))
+ (tools-bin (string-append tools "/bin"))
+ (tool (string-append tools-bin "/moonfish-")))
+ (mkdir-p out-bin)
+ (mkdir-p tools-bin)
+ (copy-file "moonfish"
+ (string-append out-bin "/moonfish"))
+ (copy-file "play"
+ (string-append tool "play"))
+ (copy-file "lichess"
+ (string-append tool "lichess"))
+ (copy-file "analyse"
+ (string-append tool "analyse"))))))))
+ (home-page "https://git.sr.ht/~zamfofex/moonfish")
+ (synopsis "Simple chess engine written in C")
+ (description
+ "moonfish is a toy UCI chess engine made for fun. It is inspired by
+sunfish, but is written in C rather than Python. It also has TUI tools for
+using any UCI engine and also to connect UCI engines to Lichess.")
+ (license license:agpl3+))))
+
(define-public barrage
(package
(name "barrage")

base-commit: daeeaa221605726d8853b00261619ba039bd6db7
prerequisite-patch-id: fa910eaade316c0f90b10713e330b4a5094cf327
prerequisite-patch-id: 5c50cfc478757944497783ccb53f0bbdaaacedfc
prerequisite-patch-id: 1f0d9d1c7ae75a37170f7a6e3e4e6c3432c49981
prerequisite-patch-id: 17e3c302bf595929a92e1a4ef3be2af6686af253
--
2.41.0
Z
Z
zamfofex wrote on 21 Oct 2023 03:17
[PATCH v2] gnu: Add moonfish.
(address . 66654@debbugs.gnu.org)(name . zamfofex)(address . zamfofex@twdb.moe)
9dfee67d9a604025ab595767a71c3fd080d0eff3.1697851048.git.zamfofex@twdb.moe
* gnu/packages/games.scm (moonfish): New variable.
---
gnu/packages/games.scm | 50 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4d5b85248a..97515abc10 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10409,6 +10409,56 @@ (define-public stockfish
(home-page "https://stockfishchess.org/")
(license license:gpl3+))))
+(define-public moonfish
+ (let ((commit "4f8829009e8c26e6a878261e0bc4c7e7617ef6b6")
+ (revision "1"))
+ (package
+ (name "moonfish")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~zamfofex/moonfish")
+ (commit commit)))
+ (sha256
+ (base32
+ "1ksg42x9cyn3pbfryy9raqb355k47cqcisascpy157c3cgdr2z60"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (inputs (list bearssl cjson))
+ (outputs '("out" "tools"))
+ (arguments
+ `(#:make-flags '(,(string-append "CC="
+ (cc-for-target)))
+ #:tests? #f ;no check target
+ #:phases (modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (replace 'install
+ ;; no 'install' target
+ (lambda _
+ (let* ((out (assoc-ref %outputs "out"))
+ (tools (assoc-ref %outputs "tools"))
+ (out-bin (string-append out "/bin"))
+ (tools-bin (string-append tools "/bin"))
+ (tool (string-append tools-bin "/moonfish-")))
+ (mkdir-p out-bin)
+ (mkdir-p tools-bin)
+ (copy-file "moonfish"
+ (string-append out-bin "/moonfish"))
+ (copy-file "play"
+ (string-append tool "play"))
+ (copy-file "lichess"
+ (string-append tool "lichess"))
+ (copy-file "analyse"
+ (string-append tool "analyse"))))))))
+ (home-page "https://git.sr.ht/~zamfofex/moonfish")
+ (synopsis "Simple chess engine written in C")
+ (description
+ "moonfish is a toy UCI chess engine made for fun. It is inspired by
+sunfish, but is written in C rather than Python. It also has TUI tools for
+using any UCI engine and also to connect UCI engines to Lichess.")
+ (license license:agpl3+))))
+
(define-public barrage
(package
(name "barrage")

base-commit: 17954419aa25bf947f3351d82a11dc2f5472acaa
--
2.41.0
R
R
Ricardo Wurmus wrote on 27 Oct 2023 13:52
[PATCH] gnu: Add moonfish.
(address . 66654-done@debbugs.gnu.org)
878r7oi8o2.fsf@elephly.net
Thanks for your patience and the patch!

I’ve changed the arguments to use G-expressions and pushed the package
with commit c11b9133d29a815d947b556551563c8dc4a68a35.

--
Ricardo
Closed
?