(address . bug-guix@gnu.org)
`guix locate guild' fails with attempt to write a readonly sqlite3 database
mwette@bluefin$ strace -o logx guix locate guild
guix locate: indexing files from /gnu/store...
guix locate: traversing local profile manifests...
Backtrace:
13 (primitive-load "/home/mwette/.config/guix/current/bin/…")
In guix/ui.scm:
2323:7 12 (run-guix . _)
2286:10 11 (run-guix-command _ . _)
In ice-9/boot-9.scm:
1752:10 10 (with-exception-handler _ _ #:unwind? _ # _)
In guix/scripts/locate.scm:
621:8 9 (_)
123:8 8 (call-with-database _ _)
In guix/progress.scm:
71:36 7 (call-with-progress-reporter _ _)
In srfi/srfi-1.scm:
634:9 6 (for-each #<procedure 7f179a23ca00 at guix/scripts/loc…> …)
In guix/scripts/locate.scm:
442:2 5 (_ _)
286:2 4 (insert-files #<<sqlite-db> pointer: #<pointer 0x1f98f…> …)
In srfi/srfi-1.scm:
634:9 3 (for-each #<procedure 7f179abb3000 at guix/scripts/loc…> …)
In sqlite3.scm:
637:15 2 (sqlite-fold #<procedure 7f179a23c5a0 at ice-9/boot-9.…> …)
166:2 1 (_ _)
In ice-9/boot-9.scm:
1685:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Throw to key `sqlite-error' with args `(#f 8 "attempt to write a
readonly database")'.
indexing 1,654 packages
mwette@bluefin$