(address . guix-patches@gnu.org)
Hi
I needed to tweak something in Sway and could not find its xml wayland
protocol files. It was hidden in the package source. Exposed them to the
build.
Toggle diff (21 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8576d0297d..45ef9cb073 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1648,7 +1648,15 @@ (define-public wlroots
(substitute* "backend/drm/meson.build"
(("/usr/share/hwdata/pnp.ids")
(string-append (assoc-ref (or native-inputs inputs) "hwdata")
- "/share/hwdata/pnp.ids"))))))))
+ "/share/hwdata/pnp.ids")))))
+ (add-after 'install 'copy-protocols
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (mkdir-p "protocols")
+ (copy-recursively
+ "protocol" ;; why singular?!
+ (string-append (assoc-ref outputs "out")
+ "/protocols"))
+ #t)))))
(propagated-inputs
(list ;; As required by wlroots.pc.
eudev