(@ (gnu packages wm) wlroots): expose "protocol" dir

  • Open
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Grigory Shepelev
Owner
unassigned
Submitted by
Grigory Shepelev
Severity
normal
G
G
Grigory Shepelev wrote on 18 Oct 2023 07:01
(address . guix-patches@gnu.org)
CAGJuR-4LvL-Hpb7OuHZWuiLEOjEOptkEAty2XUoMjrTYWqJdjw@mail.gmail.com
Hi

I needed to tweak something in Sway and could not find its xml wayland
protocol files. It was hidden in the package source. Exposed them to the
build.
Attachment: file
Toggle diff (21 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8576d0297d..45ef9cb073 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1648,7 +1648,15 @@ (define-public wlroots
(substitute* "backend/drm/meson.build"
(("/usr/share/hwdata/pnp.ids")
(string-append (assoc-ref (or native-inputs inputs) "hwdata")
- "/share/hwdata/pnp.ids"))))))))
+ "/share/hwdata/pnp.ids")))))
+ (add-after 'install 'copy-protocols
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (mkdir-p "protocols")
+ (copy-recursively
+ "protocol" ;; why singular?!
+ (string-append (assoc-ref outputs "out")
+ "/protocols"))
+ #t)))))
(propagated-inputs
(list ;; As required by wlroots.pc.
eudev
G
G
Grigory Shepelev wrote on 18 Oct 2023 08:24
Re: bug#66601: Acknowledgement ((@ (gnu packages wm) wlroots): expose "protocol" dir)
(address . 66601@debbugs.gnu.org)
CAGJuR-5+rxLBqnd=jG1jYmGdmWGtsKZ_J-3CGawuFpR8oi-sLA@mail.gmail.com
Sorry, it has to be "add-before 'configure"

??, 18 ???. 2023??. ? 08:02, GNU bug Tracking System <help-debbugs@gnu.org>:

Toggle quote (22 lines)
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
> guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 66601@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 66601: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=66601
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
>
Attachment: file
L
L
Ludovic Courtès wrote on 22 Nov 2023 15:43
Re: bug#66601: (@ (gnu packages wm) wlroots): expose "protocol" dir
(name . Grigory Shepelev)(address . shegeley@gmail.com)(address . 66601@debbugs.gnu.org)
87jzq9lugk.fsf@gnu.org
Hi Grigory,

Grigory Shepelev <shegeley@gmail.com> skribis:

Toggle quote (21 lines)
> I needed to tweak something in Sway and could not find its xml wayland
> protocol files. It was hidden in the package source. Exposed them to the
> build.
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 8576d0297d..45ef9cb073 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -1648,7 +1648,15 @@ (define-public wlroots
> (substitute* "backend/drm/meson.build"
> (("/usr/share/hwdata/pnp.ids")
> (string-append (assoc-ref (or native-inputs inputs) "hwdata")
> - "/share/hwdata/pnp.ids"))))))))
> + "/share/hwdata/pnp.ids")))))
> + (add-after 'install 'copy-protocols
> + (lambda* (#:key inputs outputs #:allow-other-keys)
> + (mkdir-p "protocols")
> + (copy-recursively
> + "protocol" ;; why singular?!
> + (string-append (assoc-ref outputs "out")
> + "/protocols"))

/protocol(s) is a non-standard directory (should it be
/share/sway/protocols?).

Also, it seems to me that this kind of change belongs upstream. Could
you check why it’s not there and/or how other distros deal with it?

Thanks,
Ludo’.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 66601@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66601
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch