[PATCH 0/3] Refactor GNU poke definition.

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Ludovic Courtès
  • Bruno Victal
Owner
unassigned
Submitted by
Bruno Victal
Severity
normal
B
B
Bruno Victal wrote on 15 Oct 2023 19:44
(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
cover.1697391346.git.mirai@makinata.eu
Notable changes:
* Removed obsolete comments and inputs from poke.
* Subsumed emacs-poke into poke.
NOTE: The emacs-poke naming is confusing as there exists a ELPA poke package
which is an emacs interface for GNU poke. The modes provided by our emacs-poke
package are seldomly used and emacs/poke people are mostly looking for
emacs-poke-mode which is being added with #66561 [1] so to prevent intolerable
confusion in the future emacs-poke has been pre-emptively removed to make way
for the ELPA poke.


Bruno Victal (3):
gnu: poke: Revise package definition.
gnu: poke: Install emacs modes.
gnu: Remove emacs-poke.

gnu/packages/engineering.scm | 39 +++++++++++-------------------------
1 file changed, 12 insertions(+), 27 deletions(-)


base-commit: a0d2ecde943bd1854ddbb7c0cad35a1fc64dc5ab
--
2.41.0
B
B
Bruno Victal wrote on 15 Oct 2023 19:47
[PATCH 2/3] gnu: poke: Install emacs modes.
(address . 66566@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
4d53f537e30cc18a084e24b3fabec4e15bbb4288.1697391346.git.mirai@makinata.eu
* gnu/packages/engineering.scm (poke)[arguments]<#:configure-flags>: Correctly
set lispdir for emacs.
---
gnu/packages/engineering.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 46937384e4..112417b30e 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3253,10 +3253,16 @@ (define-public poke
(inputs (list libgc readline libtextstyle))
(arguments
(list
+ #:imported-modules `((guix build emacs-build-system)
+ (guix build emacs-utils)
+ ,@%gnu-build-system-modules)
+ #:modules '((guix build gnu-build-system)
+ ((guix build emacs-build-system) #:prefix emacs:)
+ (guix build utils))
#:configure-flags
#~(list "--disable-static"
- ;; The emacs files are provided in emacs-poke.
- "--with-lispdir=/tmp/share/emacs")))
+ (string-append "--with-lispdir="
+ (emacs:elpa-directory #$output)))))
(home-page "https://www.gnu.org/software/poke/#documentation")
(synopsis "Editing of arbitrary binary data")
(description "GNU poke is an interactive, extensible editor for binary data.
--
2.41.0
B
B
Bruno Victal wrote on 15 Oct 2023 19:47
[PATCH 3/3] gnu: Remove emacs-poke.
(address . 66566@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
8f333d4832350044e64b9107af6fa28c4468ec69.1697391346.git.mirai@makinata.eu
This naming conflicts with the ELPA 'poke' package, a emacs interface to
GNU poke.

* gnu/packages/engineering.scm (emacs-poke): Remove variable.
---
gnu/packages/engineering.scm | 18 ------------------
1 file changed, 18 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 112417b30e..a00c098f90 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3271,24 +3271,6 @@ (define-public poke
data structures and to operate on them.")
(license license:gpl3+)))
-(define-public emacs-poke
- (package
- (inherit poke)
- (name "emacs-poke")
- (build-system emacs-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'expand-load-path 'change-working-directory
- (lambda _ (chdir "etc"))))))
- (inputs '())
- (native-inputs '())
- (synopsis "GNU Poke major modes for Emacs")
- (description
- "This package provides two Emacs major modes for working with GNU Poke:
-@code{Poke Ras mode} and @code{Poke Map mode}.")))
-
(define-public pcb2gcode
(package
(name "pcb2gcode")
--
2.41.0
B
B
Bruno Victal wrote on 15 Oct 2023 19:47
[PATCH 1/3] gnu: poke: Revise package definition.
(address . 66566@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
7e36201bf26dc13369aeac84d533ebfa15726040.1697391346.git.mirai@makinata.eu
Rewrite package using G-Expressions. Remove obsolete comments, options and
unused dependencies [1].

[1]: GNU poke commit: c17b0fb7d9d0b97398c664c882d6ef1e732bc66a

* gnu/packages/engineering.scm (poke)[inputs]: Remove json-c.
[arguments]: Use G-Expression. Remove obsolete comments and configure-flags.
---
gnu/packages/engineering.scm | 15 ++++++---------
1 file changed, 6 insertions(+), 9 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index c9aec482da..46937384e4 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3248,18 +3248,15 @@ (define-public poke
(delete-file "libpoke/pvm-vm1.c")
(delete-file "libpoke/pvm-vm2.c")))))
(build-system gnu-build-system)
- ;; The GUI, which we elide, requires tcl and tk.
(native-inputs (list bison dejagnu flex libtool pkg-config))
;; FIXME: Enable NBD support by adding `libnbd' (currently unpackaged).
- (inputs (list json-c libgc readline libtextstyle))
+ (inputs (list libgc readline libtextstyle))
(arguments
- ;; To build the GUI, add the `--enable-gui' configure flag.
- ;; To enable the "hyperlink server", add the `--enable-hserver' flag.
- `(#:configure-flags
- '("--enable-mi"
- "--disable-static"
- ;; The emacs files are provided in emacs-poke.
- "--with-lispdir=/tmp/share/emacs")))
+ (list
+ #:configure-flags
+ #~(list "--disable-static"
+ ;; The emacs files are provided in emacs-poke.
+ "--with-lispdir=/tmp/share/emacs")))
(home-page "https://www.gnu.org/software/poke/#documentation")
(synopsis "Editing of arbitrary binary data")
(description "GNU poke is an interactive, extensible editor for binary data.
--
2.41.0
E
E
Efraim Flashner wrote on 16 Oct 2023 11:23
Re: [bug#66566] [PATCH 3/3] gnu: Remove emacs-poke.
(name . Bruno Victal)(address . mirai@makinata.eu)(address . 66566@debbugs.gnu.org)
ZS0BF3HRve1fYpJq@3900XT
Does it make more sense to either replace this package with the ELPA
poke package, or to deprecate this package and have it point back at
poke?

On Sun, Oct 15, 2023 at 06:47:08PM +0100, Bruno Victal wrote:
Toggle quote (44 lines)
> This naming conflicts with the ELPA 'poke' package, a emacs interface to
> GNU poke.
>
> * gnu/packages/engineering.scm (emacs-poke): Remove variable.
> ---
> gnu/packages/engineering.scm | 18 ------------------
> 1 file changed, 18 deletions(-)
>
> diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
> index 112417b30e..a00c098f90 100644
> --- a/gnu/packages/engineering.scm
> +++ b/gnu/packages/engineering.scm
> @@ -3271,24 +3271,6 @@ (define-public poke
> data structures and to operate on them.")
> (license license:gpl3+)))
>
> -(define-public emacs-poke
> - (package
> - (inherit poke)
> - (name "emacs-poke")
> - (build-system emacs-build-system)
> - (arguments
> - (list
> - #:phases
> - #~(modify-phases %standard-phases
> - (add-before 'expand-load-path 'change-working-directory
> - (lambda _ (chdir "etc"))))))
> - (inputs '())
> - (native-inputs '())
> - (synopsis "GNU Poke major modes for Emacs")
> - (description
> - "This package provides two Emacs major modes for working with GNU Poke:
> -@code{Poke Ras mode} and @code{Poke Map mode}.")))
> -
> (define-public pcb2gcode
> (package
> (name "pcb2gcode")
> --
> 2.41.0
>
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmUtARcACgkQQarn3Mo9
g1FLrBAAqpKJZTtCgetDj22Bm/cuMtMXp9c6/58d6QsHFxSfW6eAB6uX0iFmH282
ZoZXd9q4py6T/Oy1gvOSHI320jL0SX3yw+TpKECuZ7G4nybymevtVLp++ErLKuY/
abzIoSp2ExsomFzXfZ9MsyDyJHPlga8mWT6M9fgNYfenjdNsywWfs5fhgGHQYk4N
UQb7AmlRhyCFbSh5KMsO037GDwUJIl472gxcDA4pHZrmpCAWoEabt8wWB4HKaU5S
T7UPdyaFyfDn6i2gWVwFEDSMBCvZaflvFZuJB9Lase8KHLdfKHJAfdMbLI1Ea9vo
QEXTJjiZ5CdOOO65wtrIjJv+nSR1W6B3YH9ANyb/+imKJLz+E8mQoh/lsZuPB0h4
+9MnkjuzEmS1CcA9anyQdP421dsWkGccqv8aD97NuG2e79NdZNyauUdJ78IphCEM
Zwn6/i3jgaNnxrxfaIsK+iCNMdICqBDyeQt1+1CCJXfsqQwKREOVNKk/NqE7RLGT
kSVZG7HFrMWzI+8ieSznaEqja9gLyNL5NG62XPra8kGnHekHFHfY/elTDYCdVsp8
eV5CyTb+b2RHiIgb2h6W9LUPZ5SvURMfovfYnNpqnk66JUfYFKjh6m/QEyEC4yq2
mZpkZd3BFhRWeFQ/K6oNWrHOyaY8KQc4lFRQkS+nIGPZX5vpWYE=
=bYh0
-----END PGP SIGNATURE-----


B
B
Bruno Victal wrote on 16 Oct 2023 16:57
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 66566@debbugs.gnu.org)
5f75ba1f-ccdc-4d10-b522-f2cc0f9313a7@makinata.eu
Hi Efraim,

On 2023-10-16 10:23, Efraim Flashner wrote:
Toggle quote (4 lines)
> Does it make more sense to either replace this package with the ELPA
> poke package, or to deprecate this package and have it point back at
> poke?

I'd say it makes sense to replace it with the ELPA one to avoid confusion,
though I didn't do so here since I'm not planning on using it (yet) and
thus can't vouch whether it works or not.

--
Furthermore, I consider that nonfree software must be eradicated.

Cheers,
Bruno.
L
L
Ludovic Courtès wrote on 21 Oct 2023 00:20
(name . Bruno Victal)(address . mirai@makinata.eu)
87y1fxrl52.fsf@gnu.org
Hi!

Bruno Victal <mirai@makinata.eu> skribis:

Toggle quote (9 lines)
> On 2023-10-16 10:23, Efraim Flashner wrote:
>> Does it make more sense to either replace this package with the ELPA
>> poke package, or to deprecate this package and have it point back at
>> poke?
>
> I'd say it makes sense to replace it with the ELPA one to avoid confusion,
> though I didn't do so here since I'm not planning on using it (yet) and
> thus can't vouch whether it works or not.

But since ‘poke’ now provides the Emacs mode, should we:

(define-public emacs-poke
(deprecated-package "emacs-poke" poke))

for now?

(I can do it on your behalf, let me know.)

Ludo’.
B
B
Bruno Victal wrote on 21 Oct 2023 10:58
(name . Ludovic Courtès)(address . ludo@gnu.org)
a5762bb4-8412-486e-8a3a-494fac2ea4f0@makinata.eu
Hi Ludo’,

On 2023-10-20 23:20, Ludovic Courtès wrote:
Toggle quote (9 lines)
> But since ‘poke’ now provides the Emacs mode, should we:
>
> (define-public emacs-poke
> (deprecated-package "emacs-poke" poke))
>
> for now?
>
> (I can do it on your behalf, let me know.)

Go ahead! I think there's no harm in doing this but do leave a comment
above it indicating that the package can be substituted anytime in the
future with the ELPA 'poke'.

--
Furthermore, I consider that nonfree software must be eradicated.

Cheers,
Bruno.
L
L
Ludovic Courtès wrote on 21 Oct 2023 16:08
(name . Bruno Victal)(address . mirai@makinata.eu)
87y1fwqd99.fsf@gnu.org
Hi Bruno,

Bruno Victal <mirai@makinata.eu> skribis:

Toggle quote (14 lines)
> On 2023-10-20 23:20, Ludovic Courtès wrote:
>> But since ‘poke’ now provides the Emacs mode, should we:
>>
>> (define-public emacs-poke
>> (deprecated-package "emacs-poke" poke))
>>
>> for now?
>>
>> (I can do it on your behalf, let me know.)
>
> Go ahead! I think there's no harm in doing this but do leave a comment
> above it indicating that the package can be substituted anytime in the
> future with the ELPA 'poke'.

Done, thanks!

Ludo’.
Closed
?