[PATCH] gnu: Add rust-bzip2-rs

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Stefan
  • Steve George
Owner
unassigned
Submitted by
Stefan
Severity
normal
S
S
Stefan wrote on 15 Oct 2023 18:06
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
39753ebe-d35d-005e-670a-d38a40dfb5b7@vodafonemail.de
* gnu/packages/crates-io.scm (rust-bzip2-rs-0.1): New variable.
* gnu/packages/crates-io.scm (rust-bytesize-1): Moved to group bzip2 related
packages.
---
gnu/packages/crates-io.scm | 80 +++++++++++++++++++++++++++-----------
1 file changed, 57 insertions(+), 23 deletions(-)

Toggle diff (116 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 80fb92ec82..0271dba14a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2022 Paul Alesius <paul@unnservice.com>
;;; Copyright © 2023 Arnav Andrew Jose <arnav.jose@gmail.com>
+;;; Copyright © 2023 Stefan <stefan-guix@vodafonemail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9932,6 +9933,29 @@ (define-public rust-bytestring-0.1
"This package provides a UTF-8 encoded string with Bytes as a storage.")
(license (list license:expat license:asl2.0))))
+(define-public rust-bytesize-1
+ (package
+ (name "rust-bytesize")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "bytesize" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0w7wmmbcirxp5isza0i1lxq5d7r7f0z1pxbxl5f6s1n5m8vfqn3c"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-serde" ,rust-serde-1))))
+ (home-page "https://github.com/hyunsik/bytesize/")
+ (synopsis "Human-readable byte count representation library for Rust")
+ (description "ByteSize is an utility for human-readable byte count
+representation, with support for both SI and binary units.")
+ (license license:asl2.0)))
+
(define-public rust-bzip2-0.4
(package
(name "rust-bzip2")
@@ -9965,29 +9989,6 @@ (define-public rust-bzip2-0.4
exposed as Reader/Writer streams.")
(license (list license:expat license:asl2.0))))
-(define-public rust-bytesize-1
- (package
- (name "rust-bytesize")
- (version "1.1.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "bytesize" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0w7wmmbcirxp5isza0i1lxq5d7r7f0z1pxbxl5f6s1n5m8vfqn3c"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-serde" ,rust-serde-1))))
- (home-page "https://github.com/hyunsik/bytesize/")
- (synopsis "Human-readable byte count representation library for Rust")
- (description "ByteSize is an utility for human-readable byte count
-representation, with support for both SI and binary units.")
- (license license:asl2.0)))
-
(define-public rust-bzip2-0.3
(package
(inherit rust-bzip2-0.4)
@@ -10015,6 +10016,39 @@ (define-public rust-bzip2-0.3
("rust-rand" ,rust-rand-0.3)
("rust-tokio-core" ,rust-tokio-core-0.1))))))
+(define-public rust-bzip2-rs-0.1
+ (package
+ (name "rust-bzip2-rs")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "bzip2-rs" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0dgp83kixqrqj6q6574qr5zsfpbsiiwhqs3krhvsn4f8wkkmksxy"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "Cargo.toml"
+ (("nightly = .*") ""))))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-crc32fast" ,rust-crc32fast-1)
+ ("rust-tinyvec" ,rust-tinyvec-1)
+ ("rust-rayon-core" ,rust-rayon-core-1))
+ #:cargo-development-inputs
+ (("rust-bzip2" ,rust-bzip2-0.4)
+ ("rust-criterion" ,rust-criterion-0.3)
+ ("rust-pretty_assertions" ,rust-pretty-assertions-0.6))))
+ (home-page "https://github.com/paolobarbolini/bzip2-rs")
+ (synopsis "Pure Rust bzip2 decompressor")
+ (description "Pure Rust 100% safe bzip2 decompressor.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-bzip2-sys-0.1
(package
(name "rust-bzip2-sys")

base-commit: a0d2ecde943bd1854ddbb7c0cad35a1fc64dc5ab
--
2.41.0
S
S
Steve George wrote on 9 Nov 2023 12:35
[PATCH v2 1/1] gnu: Add rust-bzip2-rs
(address . 66563@debbugs.gnu.org)
6ceef07f30a11398e8d3efe6bbe801b9c2da6d18.1699529383.git.steve@futurile.net
From: Stefan <stefan-guix@vodafonemail.de>

* gnu/packages/crates-io.scm (rust-bzip2-rs-0.1): New variable.
* gnu/packages/crates-io.scm (rust-bytesize-1): Moved bzip2 alphabetically.

Change-Id: I41a7e5a00cb2feec6dcda0360044fb5a91b9e1fe
---
gnu/packages/crates-io.scm | 84 ++++++++++++++++++++++++++------------
1 file changed, 59 insertions(+), 25 deletions(-)

Toggle diff (118 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b15c1e5d9ab..606ed5aa297 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
;;; Copyright © 2023 Steve George <steve@futurile.net>
+;;; Copyright © 2023 Stefan <stefan-guix@vodafonemail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10748,6 +10749,31 @@ (define-public rust-bytes-0.3
#:cargo-development-inputs
(("rust-rand" ,rust-rand-0.3))))))
+(define-public rust-bytesize-1
+ (package
+ (name "rust-bytesize")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "bytesize" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1k3aak70iwz4s2gsjbxf0ws4xnixqbdz6p2ha96s06748fpniqx3"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-serde" ,rust-serde-1))
+ #:cargo-development-inputs
+ (("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-toml" ,rust-toml-0.7))))
+ (home-page "https://github.com/hyunsik/bytesize/")
+ (synopsis "Human-readable byte count representation library for Rust")
+ (description "ByteSize is an utility for human-readable byte count
+representation, with support for both SI and binary units.")
+ (license license:asl2.0)))
+
(define-public rust-bytestring-0.1
(package
(name "rust-bytestring")
@@ -10805,31 +10831,6 @@ (define-public rust-bzip2-0.4
exposed as Reader/Writer streams.")
(license (list license:expat license:asl2.0))))
-(define-public rust-bytesize-1
- (package
- (name "rust-bytesize")
- (version "1.3.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "bytesize" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1k3aak70iwz4s2gsjbxf0ws4xnixqbdz6p2ha96s06748fpniqx3"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-serde" ,rust-serde-1))
- #:cargo-development-inputs
- (("rust-serde" ,rust-serde-1)
- ("rust-serde-json" ,rust-serde-json-1)
- ("rust-toml" ,rust-toml-0.7))))
- (home-page "https://github.com/hyunsik/bytesize/")
- (synopsis "Human-readable byte count representation library for Rust")
- (description "ByteSize is an utility for human-readable byte count
-representation, with support for both SI and binary units.")
- (license license:asl2.0)))
-
(define-public rust-bzip2-0.3
(package
(inherit rust-bzip2-0.4)
@@ -10857,6 +10858,39 @@ (define-public rust-bzip2-0.3
("rust-rand" ,rust-rand-0.3)
("rust-tokio-core" ,rust-tokio-core-0.1))))))
+(define-public rust-bzip2-rs-0.1
+ (package
+ (name "rust-bzip2-rs")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "bzip2-rs" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0dgp83kixqrqj6q6574qr5zsfpbsiiwhqs3krhvsn4f8wkkmksxy"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "Cargo.toml"
+ (("nightly = .*") ""))))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-crc32fast" ,rust-crc32fast-1)
+ ("rust-tinyvec" ,rust-tinyvec-1)
+ ("rust-rayon-core" ,rust-rayon-core-1))
+ #:cargo-development-inputs
+ (("rust-bzip2" ,rust-bzip2-0.4)
+ ("rust-criterion" ,rust-criterion-0.3)
+ ("rust-pretty_assertions" ,rust-pretty-assertions-0.6))))
+ (home-page "https://github.com/paolobarbolini/bzip2-rs")
+ (synopsis "Pure Rust bzip2 decompressor")
+ (description "Pure Rust 100% safe bzip2 decompressor.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-bzip2-sys-0.1
(package
(name "rust-bzip2-sys")
--
2.41.0
S
S
Steve George wrote on 9 Nov 2023 12:35
[PATCH v2 0/1] Add rust-bzip2-rs
(address . 66563@debbugs.gnu.org)
cover.1699529382.git.steve@futurile.net
Moved onto the Rust branch and tested it builds.

Stefan (1):
gnu: Add rust-bzip2-rs

gnu/packages/crates-io.scm | 84 ++++++++++++++++++++++++++------------
1 file changed, 59 insertions(+), 25 deletions(-)


base-commit: bbec79fd55ba8efe4cb015bd07e4f40fb7d252d1
--
2.41.0
E
E
Efraim Flashner wrote on 4 Dec 2023 10:54
Re: [bug#66563] [PATCH v2 1/1] gnu: Add rust-bzip2-rs
(name . Steve George)(address . steve@futurile.net)
ZW2hvnANAyENVPwI@3900XT
Sorry, I ended up packaging this one myself while looking at a different
patch set.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmVtob0ACgkQQarn3Mo9
g1FaQA//TyTK4UGc6Nd6ZxUthiBow2+69Ma7rtk6/CatLMtDfw7Vo72ddaJzEmHL
s+H6D1bElQeAFeX2/pdf2DkgwEnpDZ6XoXftm4rIsJFIgT4UewN4roTpwHMqA+yI
SsBH/W7JaHj0NCBrS9FArVAzwsl2Z2IRihwg0w/GJ2Qe1dBIXEVQ7ZCiIgSSqTrk
aAuCULg92o2wlR6m98feK94ChwzTV9uVRXfVGhLRtJPG3kQhC8thzhvJa+ST03SI
YqKAEhjZDtZb2zOkZ9TtELKl/kf+J2teM+DSJuGPKMqX/XN3KWEI6BfXOhfKedW8
m2FE6zOGVqlYga+HqxmKaqujmPmm1OGrrSOlrONC+gqNUPRdg5GUvXAEUaJa0ugv
H2MqOwws7CAKAHv6geCGnueZzR+z2UVCQHglMrSevYQyPWFtZo0e28fKuEHp62Ee
N4GpaaNkSot7nVX3jkPJZ/7SFA13uSTuvv7a+VhwJ96byFFfr7WD8U923ZcAFOUI
+NtduedIrowlptEffKqEm18a1tSdubXZXWYRcNRBDudeFUpR8HVj/AFHKeTaso9A
bR3ftNVaWrwhuRnUaVoQ0cM+AxigSj9p/NDZJ2/igSmuxmF1sjG05mzq0fVE4Ona
FMK7Cmw8n7zvMido3OpcCe2yqovRO6GCQwMlM5kA5mij+v5XMMQ=
=12DP
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66563@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66563
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch