[DOCUMENTATION] doc: Expand origin-Reference section

  • Done
  • quality assurance status badge
Details
2 participants
  • Christina O'Donnell
  • Ludovic Courtès
Owner
unassigned
Submitted by
Christina O'Donnell
Severity
normal

Debbugs page

Christina O'Donnell wrote 1 years ago
(address . guix-patches@gnu.org)(name . Christina O'Donnell)(address . cdo@mutix.org)
bc59aa9e4a3dd34f9ae786076a8b42f14c8fb0dc.1697288401.git.cdo@mutix.org
* doc/guix.texi (origin Reference): Add references for hg-reference,
svn-reference, bzr-fetch, and bzr-reference.
---
doc/guix.texi | 74 ++++++++++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 73 insertions(+), 1 deletion(-)

Toggle diff (91 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 083504dcb8..531039ad33 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -8530,9 +8530,81 @@ origin Reference
Return a fixed-output derivation that fetches @var{ref}, a
@code{<hg-reference>} object. The output is expected to have recursive
hash @var{hash} of type @var{hash-algo} (a symbol). Use @var{name} as
-the file name, or a generic name if @code{#false}.
+the file name, or a generic name if @code{#f}.
+@end deffn
+
+@deftp {Data Type} hg-reference
+This data type represents a Mercurial reference for @code{hg-fetch} to
+retrieve.
+
+@table @asis
+@item @code{url}
+The URL of the Mercurial repository to clone.
+
+@item @code{revision}
+This string denotes revision to fetch specified as a number.
+@end table
+@end deftp
+
+For Subversion repositories, the module @code{(guix svn-download)}
+defines the @code{svn-fetch} origin method and @code{svn-reference} data
+type for support of the Subversion version control system.
+
+@deffn {Procedure} svn-fetch ref hash-algo hash [name]
+Return a fixed-output derivation that fetches @var{ref}, a
+@code{<svn-reference>} object. The output is expected to have recursive
+hash @var{hash} of type @var{hash-algo} (a symbol). Use @var{name} as
+the file name, or a generic name if @code{#f}.
+@end deffn
+
+@deftp {Data Type} svn-reference
+This data type represents a Subversion reference for @code{svn-fetch} to
+retrieve.
+
+@table @asis
+@item @code{url}
+The URL of the Subversion repository to clone.
+
+@item @code{revision}
+This string denotes revision to fetch specified as a number.
+
+@item @code{recursive?} (default: @code{#f})
+This Boolean indicates whether to recursively fetch Subversion
+sub-modules.
+
+@item @code{user-name} (default: @code{#f})
+The name of an account that has read-access to the repository, if the
+repository isn't public.
+
+@item @code{password} (default: @code{#f})
+Password to access the Subversion repository, if required.
+@end table
+@end deftp
+
+For Bazaar repositories, the module @code{(guix bzr-download)}
+defines the @code{bzr-fetch} origin method and @code{bzr-reference} data
+type for support of the Bazaar version control system.
+
+@deffn {Procedure} bzr-fetch ref hash-algo hash [name]
+Return a fixed-output derivation that fetches @var{ref}, a
+@code{<bzr-reference>} object. The output is expected to have recursive
+hash @var{hash} of type @var{hash-algo} (a symbol). Use @var{name} as
+the file name, or a generic name if @code{#f}.
@end deffn
+@deftp {Data Type} bzr-reference
+This data type represents a Bazaar reference for @code{bzr-fetch} to
+retrieve.
+
+@table @asis
+@item @code{url}
+The URL of the Bazaar repository to clone.
+
+@item @code{revision}
+This string denotes revision to fetch specified as a number.
+@end table
+@end deftp
+
@node Defining Package Variants
@section Defining Package Variants

base-commit: 8e8d20b6b35d3ab529f9045cc8a779cdcec9c471
--
2.41.0
Christina O'Donnell wrote 1 years ago
(address . 66540@debbugs.gnu.org)(address . janneke@gnu.org)
0d9ee251-1a10-a3fb-ce15-3beb6c7d1399@mutix.org
Attachment: file
Ludovic Courtès wrote 1 years ago
(name . Christina O'Donnell)(address . cdo@mutix.org)(address . 66540-done@debbugs.gnu.org)
87pm1b4ow8.fsf@gnu.org
Hi Christina,

Christina O'Donnell <cdo@mutix.org> skribis:

Toggle quote (3 lines)
> * doc/guix.texi (origin Reference): Add references for hg-reference,
> svn-reference, bzr-fetch, and bzr-reference.

This looks great to me.

For ‘svn-reference’, I had to check the code: when ‘recursive?’ is
false, “--ignore-externals” is passed to ‘svn’. I have a vague
recollection of “externals” being akin to submodules in Git. Anyway, I
modified the patch as shown below.

Applied now, thank you!

Ludo’.
Toggle diff (13 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 24ee1dc702..91408b8e62 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -8573,7 +8573,7 @@ origin Reference
@item @code{recursive?} (default: @code{#f})
This Boolean indicates whether to recursively fetch Subversion
-sub-modules.
+``externals''.
@item @code{user-name} (default: @code{#f})
The name of an account that has read-access to the repository, if the
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66540@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66540
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help