[PATCH core-updates 0/3] Custom output labels for copy-build-system.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Ludovic Courtès
  • Bruno Victal
Owner
unassigned
Submitted by
Bruno Victal
Severity
normal
B
B
Bruno Victal wrote on 12 Oct 2023 17:27
(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
cover.1697124046.git.mirai@makinata.eu
This patch-series implements a `#:output' parameter for the rules within
a install-plan used by the copy-build-system which can be used to
selectively install some files into different outputs.

For demonstration purposes the docbook-dsssl package was refactored to
make use of this new feature, with a bonus patch that fixes an
inconsistency in the same package that was caught while testing.


Bruno Victal (3):
build: copy-build-system: Allow specifying different output labels.
gnu: docbook-dsssl: Refactor install-plan.
gnu: docbook-dsssl: Fix script installation path.

doc/guix.texi | 6 ++++++
gnu/packages/docbook.scm | 31 ++++++++++++++-----------------
guix/build/copy-build-system.scm | 18 +++++++++++++-----
3 files changed, 33 insertions(+), 22 deletions(-)


base-commit: 651265562bf6fea52c49596f9fb8ec380e5f0022
--
2.41.0
B
B
Bruno Victal wrote on 12 Oct 2023 17:30
[PATCH core-updates 3/3] gnu: docbook-dsssl: Fix script installation path.
(address . 66500@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
ba1b0da09da18a704b527c6211ce6d7637fc4538.1697124046.git.mirai@makinata.eu
* gnu/packages/docbook.scm (docbook-dsssl)[source]: Fix script permission.
[arguments]<#:install-plan>: Install script and manpage correctly.
[inputs]: Add perl.
---
gnu/packages/docbook.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 07cb06059a..9445c86157 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -516,6 +516,7 @@ (define-public docbook-dsssl
"1g72y2yyc2k89kzs0lvrb9n7hjayw1hdskfpplpz97pf1c99wcig"))
(snippet
#~(begin
+ (chmod "bin/collateindex.pl" #o755)
;; Remove empty directories.
(rmdir "doc")
(rmdir "docsrc")))))
@@ -524,10 +525,12 @@ (define-public docbook-dsssl
(arguments
(list
#:install-plan
- #~`(("./" "sgml/dtd/docbook/")
+ #~`(("./" "sgml/dtd/docbook/" #:exclude ("bin"))
+ ("bin/collateindex.pl" "bin/")
+ ("bin/collateindex.pl.1" "share/man/man1/")
(#$(this-package-input "docbook-dsssl-doc") "./" #:output "doc"))))
(inputs
- (list docbook-dsssl-doc))
+ (list perl docbook-dsssl-doc))
(home-page "https://docbook.org/")
(synopsis "DSSSL style sheets for DocBook")
(description "This package provides DSSSL style sheets for DocBook.")
--
2.41.0
B
B
Bruno Victal wrote on 12 Oct 2023 17:30
[PATCH core-updates 1/3] build: copy-build-system: Allow specifying different output labels.
(address . 66500@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
b486734d4ac6f5247d216da3444d91acb7e2ebd1.1697124046.git.mirai@makinata.eu
* guix/build/copy-build-system.scm: Introduce '#:output' parameter to specify
which output label to use for a given rule.
* doc/guix.texi (Build Systems): Document it.
---
doc/guix.texi | 6 ++++++
guix/build/copy-build-system.scm | 18 +++++++++++++-----
2 files changed, 19 insertions(+), 5 deletions(-)

Toggle diff (84 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 4afe1af6c0..8e627912a0 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -9460,6 +9460,9 @@ Build Systems
If both inclusions and exclusions are specified, the exclusions are done
on top of the inclusions.
@end itemize
+@item When a package has multiple outputs the @code{#:output} argument
+can be used to specify which output label the files should be installed
+to.
@end itemize
In all cases, the paths relative to @var{source} are preserved within
@var{target}.
@@ -9476,6 +9479,9 @@ Build Systems
@file{share/my-app/sub/file}.
@item @code{("foo/sub" "share/my-app" #:include ("file"))}: Install @file{foo/sub/file} to
@file{share/my-app/file}.
+@item @code{("foo/doc" "share/my-app/doc" #:output "doc")}: Install
+@file{"foo/doc"} to @file{"share/my-app/doc"} for output labelled
+@code{"doc"}.
@end itemize
@end defvar
diff --git a/guix/build/copy-build-system.scm b/guix/build/copy-build-system.scm
index fb2d1db056..152cf88224 100644
--- a/guix/build/copy-build-system.scm
+++ b/guix/build/copy-build-system.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,9 +41,9 @@ (define* (install #:key install-plan outputs #:allow-other-keys)
An install plan is a list of plans in the form:
- (SOURCE TARGET [FILTERS])
+ (SOURCE TARGET [FILTERS] [#:output OUTPUT])
-In the above, FILTERS are optional.
+In the above, FILTERS and OUTPUT are optional.
- When SOURCE matches a file or directory without trailing slash, install it to
TARGET.
@@ -63,6 +64,9 @@ (define* (install #:key install-plan outputs #:allow-other-keys)
If both `#:include*` and `#:exclude*` are specified, the exclusion is done
on the inclusion list.
+- When a package has multiple outputs the `#:output` argument can be used
+to specify which output label the files should be installed to.
+
Examples:
- `(\"foo/bar\" \"share/my-app/\")`: Install bar to \"share/my-app/bar\".
@@ -72,7 +76,9 @@ (define* (install #:key install-plan outputs #:allow-other-keys)
- `(\"foo/\" \"share/my-app\" #:include (\"sub/file\"))`: Install only \"foo/sub/file\" to
\"share/my-app/sub/file\".
- `(\"foo/sub\" \"share/my-app\" #:include (\"file\"))`: Install \"foo/sub/file\" to
-\"share/my-app/file\"."
+\"share/my-app/file\".
+- `(\"foo/doc\" \"share/my-app/doc\" #:output \"doc\")`: Install \"foo/doc\" to
+\"share/my-app/doc\" for output labelled \"doc\"."
(define (install-simple source target)
"Install SOURCE to TARGET.
TARGET must point to a store location.
@@ -133,8 +139,10 @@ (define* (install #:key install-plan outputs #:allow-other-keys)
(string-append target "/")))
file-list))))
- (define* (install source target #:key include exclude include-regexp exclude-regexp)
- (let ((final-target (string-append (assoc-ref outputs "out") "/" target))
+ (define* (install source target
+ #:key include exclude include-regexp exclude-regexp
+ (output "out"))
+ (let ((final-target (string-append (assoc-ref outputs output) "/" target))
(filters? (or include exclude include-regexp exclude-regexp)))
(when (and (not (file-is-directory? source))
filters?)
--
2.41.0
B
B
Bruno Victal wrote on 12 Oct 2023 17:30
[PATCH core-updates 2/3] gnu: docbook-dsssl: Refactor install-plan.
(address . 66500@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
c699471a8b9d9597dc3dbdbd668710c812d2b22e.1697124046.git.mirai@makinata.eu
Replace custom phase with copy-build-system newly added #:output parameter.
Additionally remove extra slashes from license URIs and obsolete inputs.

* gnu/packages/docbook.scm (docbook-dsssl)[source]: Remove empty directories
from source using a snippet.
[arguments]<#:phases>: Relocate 'install-doc logic into …
<#:install-plan>: … here. Remove obsolete exclusion rules.
[native-inputs]: Remove bzip2 and tar since these are already available by
default.
[license]: Remove extraneous slash.
(docbook-dsssl-doc)[license]: Remove extraneous slash.
---
gnu/packages/docbook.scm | 26 ++++++++++----------------
1 file changed, 10 insertions(+), 16 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index f7dff53808..07cb06059a 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -513,31 +513,25 @@ (define-public docbook-dsssl
name "-" version ".tar.bz2"))
(sha256
(base32
- "1g72y2yyc2k89kzs0lvrb9n7hjayw1hdskfpplpz97pf1c99wcig"))))
+ "1g72y2yyc2k89kzs0lvrb9n7hjayw1hdskfpplpz97pf1c99wcig"))
+ (snippet
+ #~(begin
+ ;; Remove empty directories.
+ (rmdir "doc")
+ (rmdir "docsrc")))))
(build-system copy-build-system)
(outputs '("out" "doc"))
(arguments
(list
#:install-plan
- #~`(("./" "sgml/dtd/docbook/"
- #:exclude ("doc" "docsrc")))
- #:phases
- #~(modify-phases %standard-phases
- ;; The doc output contains 1.4 MiB of HTML documentation.
- (add-after 'install 'install-doc
- (lambda* (#:key inputs #:allow-other-keys)
- (mkdir-p (string-append #$output:doc "/share/doc"))
- (symlink (assoc-ref inputs "docbook-dsssl-doc")
- (format #f "~a/share/doc/~a-~a"
- #$output:doc #$name #$version)))))))
+ #~`(("./" "sgml/dtd/docbook/")
+ (#$(this-package-input "docbook-dsssl-doc") "./" #:output "doc"))))
(inputs
(list docbook-dsssl-doc))
- (native-inputs
- (list bzip2 tar))
(home-page "https://docbook.org/")
(synopsis "DSSSL style sheets for DocBook")
(description "This package provides DSSSL style sheets for DocBook.")
- (license (license:non-copyleft "file://README"))))
+ (license (license:non-copyleft "file:/README"))))
;;; Private variable, used as the 'doc' output of the docbook-dsssl package.
(define docbook-dsssl-doc
@@ -560,7 +554,7 @@ (define docbook-dsssl-doc
(home-page "https://docbook.org/")
(synopsis "DocBook DSSSL style sheets documentation")
(description "Documentation for the DocBook DSSSL style sheets.")
- (license (license:non-copyleft "file://doc/LEGALNOTICE.htm"))))
+ (license (license:non-copyleft "file:/doc/LEGALNOTICE.htm"))))
(define-public docbook-sgml-4.2
(package
--
2.41.0
L
L
Liliana Marie Prikler wrote on 19 Oct 2023 11:46
Re: [PATCH core-updates 1/3] build: copy-build-system: Allow specifying different output labels.
c86eeee9162d8a2a693fb552dac6df93f9d228cf.camel@gmail.com
Hi Bruno,

Am Donnerstag, dem 12.10.2023 um 16:30 +0100 schrieb Bruno Victal:
Toggle quote (6 lines)
> [...]
> +@item When a package has multiple outputs the @code{#:output}
> argument
> +can be used to specify which output label the files should be
> installed
> +to.
This is perhaps extremely nitpicky, but there should be a comma before
"the @code{#:output} argument".

Toggle quote (10 lines)
> @@ -63,6 +64,9 @@ (define* (install #:key install-plan outputs
> #:allow-other-keys)
>        If both `#:include*` and `#:exclude*` are specified, the
> exclusion is done
>        on the inclusion list.
>  
> +- When a package has multiple outputs the `#:output` argument can be
> used
> +to specify which output label the files should be installed to.
> +
Same here.
Toggle quote (16 lines)
>  Examples:
>  
>  - `(\"foo/bar\" \"share/my-app/\")`: Install bar to \"share/my-
> app/bar\".
> @@ -72,7 +76,9 @@ (define* (install #:key install-plan outputs
> #:allow-other-keys)
>  - `(\"foo/\" \"share/my-app\" #:include (\"sub/file\"))`: Install
> only \"foo/sub/file\" to
>  \"share/my-app/sub/file\".
>  - `(\"foo/sub\" \"share/my-app\" #:include (\"file\"))`: Install
> \"foo/sub/file\" to
> -\"share/my-app/file\"."
> +\"share/my-app/file\".
> +- `(\"foo/doc\" \"share/my-app/doc\" #:output \"doc\")`: Install
> \"foo/doc\" to
> +\"share/my-app/doc\" for output labelled \"doc\"."
s/for output labelled/within the output named/
or
s/for output labelled \"doc\"/within the \"doc\" output/

Toggle quote (22 lines)
>    (define (install-simple source target)
>      "Install SOURCE to TARGET.
>  TARGET must point to a store location.
> @@ -133,8 +139,10 @@ (define* (install #:key install-plan outputs
> #:allow-other-keys)
>                                        (string-append target "/")))
>               file-list))))
>  
> -  (define* (install source target #:key include exclude include-
> regexp exclude-regexp)
> -    (let ((final-target (string-append (assoc-ref outputs "out") "/"
> target))
> +  (define* (install source target
> +                    #:key include exclude include-regexp exclude-
> regexp
> +                    (output "out"))
> +    (let ((final-target (string-append (assoc-ref outputs output)
> "/" target))
>            (filters? (or include exclude include-regexp exclude-
> regexp)))
>        (when (and (not (file-is-directory? source))
>                   filters?)
Otherwise LGTM. Note, however, that CI doesn't like this series.

Cheers
L
L
Liliana Marie Prikler wrote on 19 Oct 2023 11:47
Re: [PATCH core-updates 2/3] gnu: docbook-dsssl: Refactor install-plan.
e124ed381e2887fe90e73d24c23354f20c52e5f4.camel@gmail.com
Am Donnerstag, dem 12.10.2023 um 16:30 +0100 schrieb Bruno Victal:
Toggle quote (14 lines)
> Replace custom phase with copy-build-system newly added #:output
> parameter.
> Additionally remove extra slashes from license URIs and obsolete
> inputs.
>
> * gnu/packages/docbook.scm (docbook-dsssl)[source]: Remove empty
> directories from source using a snippet.
> [arguments]<#:phases>: Relocate 'install-doc logic into …
> <#:install-plan>: … here. Remove obsolete exclusion rules.
> [native-inputs]: Remove bzip2 and tar since these are already
> available by default.
> [license]: Remove extraneous slash.
> (docbook-dsssl-doc)[license]: Remove extraneous slash.
> ---
Are these extraneous slash removals really improving anything? I
personally type file URIs with three slashes, but that's outside the
Guix context.

Cheers
B
B
Bruno Victal wrote on 19 Oct 2023 17:25
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 66500@debbugs.gnu.org)
4790276a-ad1c-4425-b271-4ea320c17fe3@makinata.eu
On 2023-10-19 10:47, Liliana Marie Prikler wrote:
Toggle quote (4 lines)
> Are these extraneous slash removals really improving anything? I
> personally type file URIs with three slashes, but that's outside the
> Guix context.

It's mostly semantical improvements as I've explained in the
(unrelated) 1d07acb5f440cb3205b2336a213163ca4584d4f6 commit message [1].

Save for applications with broken or outdated URI handling (which would
be a bug), the single slash URIs work just the same as before.



--
Furthermore, I consider that nonfree software must be eradicated.

Cheers,
Bruno.
B
B
Bruno Victal wrote on 19 Oct 2023 17:37
[PATCH core-updates v2 0/3] Custom output labels for copy-build-system.
(address . 66500@debbugs.gnu.org)
cover.1697729341.git.mirai@makinata.eu
Notable changes since v1:
* Address documentation feedback.
* Rebased to solve potential merge conflicts.

Bruno Victal (3):
build: copy-build-system: Allow specifying different output labels.
gnu: docbook-dsssl: Refactor install-plan.
gnu: docbook-dsssl: Fix script installation path.

doc/guix.texi | 6 ++++++
gnu/packages/docbook.scm | 31 ++++++++++++++-----------------
guix/build/copy-build-system.scm | 18 +++++++++++++-----
3 files changed, 33 insertions(+), 22 deletions(-)


base-commit: d59653b7c9e43ebdbba20e2ca071429507f94c67
--
2.41.0
B
B
Bruno Victal wrote on 19 Oct 2023 17:38
[PATCH core-updates v2 2/3] gnu: docbook-dsssl: Refactor install-plan.
(address . 66500@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
6f1ceb31701a17a39d64f9e37d37db5a1d2a9949.1697729341.git.mirai@makinata.eu
Replace custom phase with copy-build-system newly added #:output parameter.
Additionally remove extra slashes from license URIs and obsolete inputs.

* gnu/packages/docbook.scm (docbook-dsssl)[source]: Remove empty directories
from source using a snippet.
[arguments]<#:phases>: Relocate 'install-doc logic into …
<#:install-plan>: … here. Remove obsolete exclusion rules.
[native-inputs]: Remove bzip2 and tar since these are already available by
default.
[license]: Remove extraneous slash.
(docbook-dsssl-doc)[license]: Remove extraneous slash.
---
gnu/packages/docbook.scm | 26 ++++++++++----------------
1 file changed, 10 insertions(+), 16 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index f7dff53808..07cb06059a 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -513,31 +513,25 @@ (define-public docbook-dsssl
name "-" version ".tar.bz2"))
(sha256
(base32
- "1g72y2yyc2k89kzs0lvrb9n7hjayw1hdskfpplpz97pf1c99wcig"))))
+ "1g72y2yyc2k89kzs0lvrb9n7hjayw1hdskfpplpz97pf1c99wcig"))
+ (snippet
+ #~(begin
+ ;; Remove empty directories.
+ (rmdir "doc")
+ (rmdir "docsrc")))))
(build-system copy-build-system)
(outputs '("out" "doc"))
(arguments
(list
#:install-plan
- #~`(("./" "sgml/dtd/docbook/"
- #:exclude ("doc" "docsrc")))
- #:phases
- #~(modify-phases %standard-phases
- ;; The doc output contains 1.4 MiB of HTML documentation.
- (add-after 'install 'install-doc
- (lambda* (#:key inputs #:allow-other-keys)
- (mkdir-p (string-append #$output:doc "/share/doc"))
- (symlink (assoc-ref inputs "docbook-dsssl-doc")
- (format #f "~a/share/doc/~a-~a"
- #$output:doc #$name #$version)))))))
+ #~`(("./" "sgml/dtd/docbook/")
+ (#$(this-package-input "docbook-dsssl-doc") "./" #:output "doc"))))
(inputs
(list docbook-dsssl-doc))
- (native-inputs
- (list bzip2 tar))
(home-page "https://docbook.org/")
(synopsis "DSSSL style sheets for DocBook")
(description "This package provides DSSSL style sheets for DocBook.")
- (license (license:non-copyleft "file://README"))))
+ (license (license:non-copyleft "file:/README"))))
;;; Private variable, used as the 'doc' output of the docbook-dsssl package.
(define docbook-dsssl-doc
@@ -560,7 +554,7 @@ (define docbook-dsssl-doc
(home-page "https://docbook.org/")
(synopsis "DocBook DSSSL style sheets documentation")
(description "Documentation for the DocBook DSSSL style sheets.")
- (license (license:non-copyleft "file://doc/LEGALNOTICE.htm"))))
+ (license (license:non-copyleft "file:/doc/LEGALNOTICE.htm"))))
(define-public docbook-sgml-4.2
(package
--
2.41.0
B
B
Bruno Victal wrote on 19 Oct 2023 17:38
[PATCH core-updates v2 1/3] build: copy-build-system: Allow specifying different output labels.
(address . 66500@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
776246775170b3e26211c28d52dffadc4c076ffc.1697729341.git.mirai@makinata.eu
* guix/build/copy-build-system.scm: Introduce '#:output' parameter to specify
which output label to use for a given rule.
* doc/guix.texi (Build Systems): Document it.
---
doc/guix.texi | 6 ++++++
guix/build/copy-build-system.scm | 18 +++++++++++++-----
2 files changed, 19 insertions(+), 5 deletions(-)

Toggle diff (84 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 4afe1af6c0..4f6c4ce67a 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -9460,6 +9460,9 @@ Build Systems
If both inclusions and exclusions are specified, the exclusions are done
on top of the inclusions.
@end itemize
+@item When a package has multiple outputs, the @code{#:output} argument
+can be used to specify which output label the files should be installed
+to.
@end itemize
In all cases, the paths relative to @var{source} are preserved within
@var{target}.
@@ -9476,6 +9479,9 @@ Build Systems
@file{share/my-app/sub/file}.
@item @code{("foo/sub" "share/my-app" #:include ("file"))}: Install @file{foo/sub/file} to
@file{share/my-app/file}.
+@item @code{("foo/doc" "share/my-app/doc" #:output "doc")}: Install
+@file{"foo/doc"} to @file{"share/my-app/doc"} within the @code{"doc"}
+output.
@end itemize
@end defvar
diff --git a/guix/build/copy-build-system.scm b/guix/build/copy-build-system.scm
index fb2d1db056..25d3f4c57a 100644
--- a/guix/build/copy-build-system.scm
+++ b/guix/build/copy-build-system.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,9 +41,9 @@ (define* (install #:key install-plan outputs #:allow-other-keys)
An install plan is a list of plans in the form:
- (SOURCE TARGET [FILTERS])
+ (SOURCE TARGET [FILTERS] [#:output OUTPUT])
-In the above, FILTERS are optional.
+In the above, FILTERS and OUTPUT are optional.
- When SOURCE matches a file or directory without trailing slash, install it to
TARGET.
@@ -63,6 +64,9 @@ (define* (install #:key install-plan outputs #:allow-other-keys)
If both `#:include*` and `#:exclude*` are specified, the exclusion is done
on the inclusion list.
+- When a package has multiple outputs, the `#:output` argument can be used
+to specify which output label the files should be installed to.
+
Examples:
- `(\"foo/bar\" \"share/my-app/\")`: Install bar to \"share/my-app/bar\".
@@ -72,7 +76,9 @@ (define* (install #:key install-plan outputs #:allow-other-keys)
- `(\"foo/\" \"share/my-app\" #:include (\"sub/file\"))`: Install only \"foo/sub/file\" to
\"share/my-app/sub/file\".
- `(\"foo/sub\" \"share/my-app\" #:include (\"file\"))`: Install \"foo/sub/file\" to
-\"share/my-app/file\"."
+\"share/my-app/file\".
+- `(\"foo/doc\" \"share/my-app/doc\" #:output \"doc\")`: Install \"foo/doc\" to
+\"share/my-app/doc\" within the \"doc\" output."
(define (install-simple source target)
"Install SOURCE to TARGET.
TARGET must point to a store location.
@@ -133,8 +139,10 @@ (define* (install #:key install-plan outputs #:allow-other-keys)
(string-append target "/")))
file-list))))
- (define* (install source target #:key include exclude include-regexp exclude-regexp)
- (let ((final-target (string-append (assoc-ref outputs "out") "/" target))
+ (define* (install source target
+ #:key include exclude include-regexp exclude-regexp
+ (output "out"))
+ (let ((final-target (string-append (assoc-ref outputs output) "/" target))
(filters? (or include exclude include-regexp exclude-regexp)))
(when (and (not (file-is-directory? source))
filters?)
--
2.41.0
B
B
Bruno Victal wrote on 19 Oct 2023 17:38
[PATCH core-updates v2 3/3] gnu: docbook-dsssl: Fix script installation path.
(address . 66500@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
c793b8c27356d81d2a1247c0e709b5dd73bfaba8.1697729341.git.mirai@makinata.eu
* gnu/packages/docbook.scm (docbook-dsssl)[source]: Fix script permission.
[arguments]<#:install-plan>: Install script and manpage correctly.
[inputs]: Add perl.
---
gnu/packages/docbook.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 07cb06059a..9445c86157 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -516,6 +516,7 @@ (define-public docbook-dsssl
"1g72y2yyc2k89kzs0lvrb9n7hjayw1hdskfpplpz97pf1c99wcig"))
(snippet
#~(begin
+ (chmod "bin/collateindex.pl" #o755)
;; Remove empty directories.
(rmdir "doc")
(rmdir "docsrc")))))
@@ -524,10 +525,12 @@ (define-public docbook-dsssl
(arguments
(list
#:install-plan
- #~`(("./" "sgml/dtd/docbook/")
+ #~`(("./" "sgml/dtd/docbook/" #:exclude ("bin"))
+ ("bin/collateindex.pl" "bin/")
+ ("bin/collateindex.pl.1" "share/man/man1/")
(#$(this-package-input "docbook-dsssl-doc") "./" #:output "doc"))))
(inputs
- (list docbook-dsssl-doc))
+ (list perl docbook-dsssl-doc))
(home-page "https://docbook.org/")
(synopsis "DSSSL style sheets for DocBook")
(description "This package provides DSSSL style sheets for DocBook.")
--
2.41.0
B
B
Bruno Victal wrote on 19 Oct 2023 17:36
Re: [PATCH core-updates 1/3] build: copy-build-system: Allow specifying different output labels.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 66500@debbugs.gnu.org)
798c0423-d685-47b9-b6a3-b209743ee28e@makinata.eu
Hi Liliana,

On 2023-10-19 10:46, Liliana Marie Prikler wrote:
Toggle quote (3 lines)
> This is perhaps extremely nitpicky, but there should be a comma before
> "the @code{#:output} argument".

Addressing this with v2.

Toggle quote (4 lines)
> s/for output labelled/within the output named/
> or
> s/for output labelled \"doc\"/within the \"doc\" output/

Likewise, went for the second choice here.

Toggle quote (2 lines)
> Otherwise LGTM. Note, however, that CI doesn't like this series.

Strange, the CI complains of a merge conflict yet I didn't encounter
any issues when rebasing this to the latest core-updates [1].


[1]: guix commit d59653b7c9e43ebdbba20e2ca071429507f94c67

--
Furthermore, I consider that nonfree software must be eradicated.

Cheers,
Bruno.
L
L
Ludovic Courtès wrote on 20 Dec 2023 22:10
Re: [bug#66500] [PATCH core-updates v2 0/3] Custom output labels for copy-build-system.
(name . Bruno Victal)(address . mirai@makinata.eu)
874jgch96c.fsf@gnu.org
Hi Bruno,

Bruno Victal <mirai@makinata.eu> skribis:

Toggle quote (4 lines)
> build: copy-build-system: Allow specifying different output labels.
> gnu: docbook-dsssl: Refactor install-plan.
> gnu: docbook-dsssl: Fix script installation path.

Applied, thanks!

Ludo’.
Closed
?