Navid Afkhami wrote 1 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
* gnu/packages/bioinformatics.scm (r-complexupset): New variable.
---
gnu/packages/bioinformatics.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Toggle diff (43 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index cb0bdf766e..bd936cd1e3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -810,6 +810,34 @@ (define-public r-codeandroll2
These functions are used by MarkdownReports, ggExpress, and SeuratUtils.")
(license license:gpl3))))
+(define-public r-complexupset
+ (let ((commit "bb3f10a35eb2033754620aacdedc1d52357f13e4")
+ (revision "1"))
+ (package
+ (name "r-complexupset")
+ (version (git-version "1.3.5" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/krassowski/complex-upset")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1yid15515yhfzmbs8z991kk62hzdrlgbz6p81aj6csg3db0xy2xc"))))
+ (properties `((upstream-name . "ComplexUpset")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-colorspace r-ggplot2 r-patchwork r-scales))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/krassowski/complex-upset")
+ (synopsis "Create complex upset plots using 'ggplot2' components")
+ (description
+ "@code{UpSet} plots improve set overlap visualizations over Venn Diagrams.
+Striving to bring the best of the @code{UpSetR} and ggplot2', this
+package offers a way to create complex overlap visualisations,
+using simple and familiar tools.")
+ (license license:expat))))
+
(define-public r-conospanel
(let ((commit "39e76b201a783b4e92fd615010a735a61746fbb9")
(revision "1"))
base-commit: 1328c4cca531318e3ed90c6aecb522a5b22a4bcc
--
2.34.1