[maintenance] hydra: build-package-metadata: Add boolean for Git submodules in sources.json.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Mathieu Othacehe
  • Simon Tournier
Owner
unassigned
Submitted by
Simon Tournier
Severity
normal
S
S
Simon Tournier wrote on 12 Oct 2023 14:39
(address . guix-patches@gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20231012123931.390137-1-zimon.toutoune@gmail.com
This format had been discussed in

* hydra/build-package-metadata.scm (origin->json)[resolve]: Add the keyword
'submodule' when the Git reference is recursive.
---
hydra/build-package-metadata.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Hi,

This patch helps on SWH side.

Nevertheless, if it is possible from your side to add a new boolean field in
the JSON file (submodules ?) indicating that submodules should be fetched to
compute the hash, this will simplify the processing from our side.


Cheers,
simon


Toggle diff (20 lines)
diff --git a/hydra/build-package-metadata.scm b/hydra/build-package-metadata.scm
index 0a75204..9f90c5e 100755
--- a/hydra/build-package-metadata.scm
+++ b/hydra/build-package-metadata.scm
@@ -182,7 +182,10 @@ superseded packages."
"recursive"))))
'())
,@(if (eq? method git-fetch)
- `(("git_ref" . ,(git-reference-commit uri)))
+ `(("git_ref" . ,(git-reference-commit uri))
+ ,@(if (git-reference-recursive? uri)
+ '(("submodule" . "true"))
+ '()))
'())
,@(if (eq? method svn-fetch)
`(("svn_revision" . ,(svn-reference-revision uri)))

base-commit: 8f703892a6d549d52eb0374deb11d6af734065d4
--
2.38.1
L
L
Ludovic Courtès wrote on 14 Oct 2023 19:23
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)(address . 66491@debbugs.gnu.org)
87sf6dce4e.fsf@gnu.org
Hi,

Simon Tournier <zimon.toutoune@gmail.com> skribis:

Toggle quote (6 lines)
> This format had been discussed in
> <https://gitlab.softwareheritage.org/swh/devel/swh-loader-git/-/issues/4751#note_150607>
>
> * hydra/build-package-metadata.scm (origin->json)[resolve]: Add the keyword
> 'submodule' when the Git reference is recursive.

[...]

Toggle quote (7 lines)
> ,@(if (eq? method git-fetch)
> - `(("git_ref" . ,(git-reference-commit uri)))
> + `(("git_ref" . ,(git-reference-commit uri))
> + ,@(if (git-reference-recursive? uri)
> + '(("submodule" . "true"))
> + '()))

I think you’ll want to make it #t instead of "true", so that it
translates to the Boolean true, not the string "true":

Toggle snippet (6 lines)
scheme@(guile-user)> (scm->json-string '((a . "true")))
$8 = "{\"a\":\"true\"}"
scheme@(guile-user)> (scm->json-string '((a . #true)))
$9 = "{\"a\":true}"

Otherwise LGTM!

Thanks,
Ludo’.
S
S
Simon Tournier wrote on 17 Oct 2023 13:58
[PATCH v2] hydra: build-package-metadata: Add boolean for Git submodules in sources.json.
(address . 66491@debbugs.gnu.org)(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
20231017115824.3369880-1-zimon.toutoune@gmail.com
This format had been discussed in

* hydra/build-package-metadata.scm (origin->json)[resolve]: Add the keyword
'submodule' when the Git reference is recursive.
---
hydra/build-package-metadata.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (20 lines)
diff --git a/hydra/build-package-metadata.scm b/hydra/build-package-metadata.scm
index 0a75204..6b862eb 100755
--- a/hydra/build-package-metadata.scm
+++ b/hydra/build-package-metadata.scm
@@ -182,7 +182,10 @@ superseded packages."
"recursive"))))
'())
,@(if (eq? method git-fetch)
- `(("git_ref" . ,(git-reference-commit uri)))
+ `(("git_ref" . ,(git-reference-commit uri))
+ ,@(if (git-reference-recursive? uri)
+ '(("submodule" . #true))
+ '()))
'())
,@(if (eq? method svn-fetch)
`(("svn_revision" . ,(svn-reference-revision uri)))

base-commit: 053839dc9457f95792d6dce2e2e73292b9584b30
--
2.38.1
S
S
Simon Tournier wrote on 17 Oct 2023 13:59
Re: [bug#66491] [maintenance] hydra: build-package-metadata: Add boolean for Git submodules in sources.json.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 66491@debbugs.gnu.org)
8734y9qx1w.fsf@gmail.com
Hi Ludo,

On Sat, 14 Oct 2023 at 19:23, Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (3 lines)
> I think you’ll want to make it #t instead of "true", so that it
> translates to the Boolean true, not the string "true":

Thanks, yeah that’s better and consistent.

I have sent v2 because I am not sure to be allowed to push to
maintenance (authorization all that :-)).

Cheers,
simon
M
M
Mathieu Othacehe wrote on 17 Oct 2023 14:29
Re: bug#66491: [maintenance] hydra: build-package-metadata: Add boolean for Git submodules in sources.json.
(name . Simon Tournier)(address . zimon.toutoune@gmail.com)
87fs29mnyv.fsf_-_@gnu.org
Toggle quote (3 lines)
> * hydra/build-package-metadata.scm (origin->json)[resolve]: Add the keyword
> 'submodule' when the Git reference is recursive.

Pushed, thanks!

Mathieu
Closed
?