[PATCH] gnu: emacs-mastodon: Update to 1.0.5.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andrew Tropin
  • Fabio Natali
Owner
unassigned
Submitted by
Fabio Natali
Severity
normal

Debbugs page

Fabio Natali wrote 1 years ago
(address . guix-patches@gnu.org)(name . Fabio Natali)(address . me@fabionatali.com)
9b0938f378b114fcddc4254c7df1def4ef6d3bbe.1696636426.git.me@fabionatali.com
* gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.5.
---
gnu/packages/emacs-xyz.scm | 62 ++++++++++++++++++--------------------
1 file changed, 29 insertions(+), 33 deletions(-)

Toggle diff (78 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cf1542955c..47bdc10685 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -32827,40 +32827,36 @@ (define-public emacs-wc-mode
(license license:gpl3+)))
(define-public emacs-mastodon
- ;; No release in ~1 year, hence this snapshot.
- (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
- (revision "1"))
- (package
- (name "emacs-mastodon")
- (version (git-version "1.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://codeberg.org/martianh/mastodon.el")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "15cfjny99yw5frdp8nlyazlwgscvfvbinsj0fbdfprxf50k2zjs6"))))
- (build-system emacs-build-system)
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- ;; Move the source files to the top level, which is included in
- ;; the EMACSLOADPATH.
- (add-after 'unpack 'move-source-files
- (lambda _
- (let ((el-files (find-files "./lisp" ".*\\.el$")))
- (for-each (lambda (f)
- (rename-file f (basename f)))
- el-files)))))))
- (propagated-inputs
- (list emacs-request emacs-ts emacs-persist))
- (home-page "https://codeberg.org/martianh/mastodon.el")
- (synopsis "Emacs client for Mastodon")
- (description "@code{mastodon.el} is an Emacs client for Mastodon, the
+ (package
+ (name "emacs-mastodon")
+ (version "1.0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/martianh/mastodon.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zjn3v3qfr034vz0ns7s9j7n4xzzqy5xiihc307mr3f6fcjgq0xd"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ ;; Move the source files to the top level, which is included in
+ ;; the EMACSLOADPATH.
+ (add-after 'unpack 'move-source-files
+ (lambda _
+ (let ((el-files (find-files "./lisp" ".*\\.el$")))
+ (for-each (lambda (f)
+ (rename-file f
+ (basename f))) el-files)))))))
+ (propagated-inputs (list emacs-request emacs-ts emacs-persist))
+ (home-page "https://codeberg.org/martianh/mastodon.el")
+ (synopsis "Emacs client for Mastodon")
+ (description "@code{mastodon.el} is an Emacs client for Mastodon, the
federated microblogging social network.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-ebdb
(package

base-commit: add2a22ad7bcca2521432e3f486460138401d5a5
--
2.41.0
Fabio Natali wrote 1 years ago
(address . guix-patches@gnu.org)
87o7h4ywk9.fsf@fabionatali.com
Hi All,

Please ignore the previous email:

[bug#66483] [PATCH] gnu: emacs-mastodon: Update to 1.0.5.

I must have had a stale buffer somewhere with a (now obsolete) patch
from a few days ago. The buffer must have thought that today was a good
day to send itself.

Then people talk about AI, when we have self-aware autonomous Emacs
buffers already - go figure.

Cheers, F.
Andrew Tropin wrote 1 years ago
877cnr7tz5.fsf@trop.in
On 2023-10-12 10:35, Fabio Natali wrote:

Toggle quote (82 lines)
> * gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.5.
> ---
> gnu/packages/emacs-xyz.scm | 62 ++++++++++++++++++--------------------
> 1 file changed, 29 insertions(+), 33 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index cf1542955c..47bdc10685 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -32827,40 +32827,36 @@ (define-public emacs-wc-mode
> (license license:gpl3+)))
>
> (define-public emacs-mastodon
> - ;; No release in ~1 year, hence this snapshot.
> - (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
> - (revision "1"))
> - (package
> - (name "emacs-mastodon")
> - (version (git-version "1.0.0" revision commit))
> - (source (origin
> - (method git-fetch)
> - (uri (git-reference
> - (url "https://codeberg.org/martianh/mastodon.el")
> - (commit commit)))
> - (file-name (git-file-name name version))
> - (sha256
> - (base32
> - "15cfjny99yw5frdp8nlyazlwgscvfvbinsj0fbdfprxf50k2zjs6"))))
> - (build-system emacs-build-system)
> - (arguments
> - (list #:phases
> - #~(modify-phases %standard-phases
> - ;; Move the source files to the top level, which is included in
> - ;; the EMACSLOADPATH.
> - (add-after 'unpack 'move-source-files
> - (lambda _
> - (let ((el-files (find-files "./lisp" ".*\\.el$")))
> - (for-each (lambda (f)
> - (rename-file f (basename f)))
> - el-files)))))))
> - (propagated-inputs
> - (list emacs-request emacs-ts emacs-persist))
> - (home-page "https://codeberg.org/martianh/mastodon.el")
> - (synopsis "Emacs client for Mastodon")
> - (description "@code{mastodon.el} is an Emacs client for Mastodon, the
> + (package
> + (name "emacs-mastodon")
> + (version "1.0.5")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://codeberg.org/martianh/mastodon.el")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "0zjn3v3qfr034vz0ns7s9j7n4xzzqy5xiihc307mr3f6fcjgq0xd"))))
> + (build-system emacs-build-system)
> + (arguments
> + (list
> + #:phases #~(modify-phases %standard-phases
> + ;; Move the source files to the top level, which is included in
> + ;; the EMACSLOADPATH.
> + (add-after 'unpack 'move-source-files
> + (lambda _
> + (let ((el-files (find-files "./lisp" ".*\\.el$")))
> + (for-each (lambda (f)
> + (rename-file f
> + (basename f))) el-files)))))))
> + (propagated-inputs (list emacs-request emacs-ts emacs-persist))
> + (home-page "https://codeberg.org/martianh/mastodon.el")
> + (synopsis "Emacs client for Mastodon")
> + (description "@code{mastodon.el} is an Emacs client for Mastodon, the
> federated microblogging social network.")
> - (license license:gpl3+))))
> + (license license:gpl3+)))
>
> (define-public emacs-ebdb
> (package
>
> base-commit: add2a22ad7bcca2521432e3f486460138401d5a5

Patch superseding this one is already applied in different thread,
closing the ticket.

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmUoDX4ACgkQIgjSCVjB
3rAMEA//ecUZMjoRT8YGXZbT08EOw8gHJEc0+IILviTN0RGOITzlaVU4mn8C8rLy
eQlfMqEipAqvXA8grYAQBpy15funDjCHkQetyKepPjvV+TsjZ/0e7vQ7WxF3KS4+
p9R85DLqz2DuNOPh6OrCLbBzI/xAXqWKH2Zzmo3df4/usYszgle7o1oGUj28d+4V
YM1rCMU398oM/cwGYb5+R37Q593Ob6TqicH7rD5Rn+1SlmbNUa5k8fUvgDUdI6th
JuGdDEjVR3n6Yr42mXlx4Ggwvb7Wl2mPYpDMjNbfpMwCmgYk2YLg+xuKhVLVpJby
GjVb39Ie6FLxoqvaUUu47aQU9BPUJCrc2Nt+iNlkXjR1si5H1ys9Sc8B0ioz1Moz
v/Ue27EHrBAp0RBMjcatfUGegWkulY5+XlZX2OlS0jIlmEyq34YXN06JCy2wXDWM
hPxDn/9/Ay4VLnAir+HDIELxrG1G+/tQ5dLSqUEcjN6g1MP3u66Y8OFkr5AQbH7i
EuCBJSkHVe0Ag8T9Bbp8tfZyCA7XqorKydRO4NOhdhReeYmTc+QxrrMKn0CWAMtJ
z8j1OsDiOoA0GJevB6i6m7W9Jw8ic1MW886Q3gnZS7+uA7I6//KPhhutbYrIfwLY
dfIvY1gQmwTu3qg2QgQXn+GsOemjGQlXI+OLKaBNp7TfUKmtpMk=
=+Hpu
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66483@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66483
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help