[PATCH 0/5] gnu: Add python-spectral-cube

  • Done
  • quality assurance status badge
Details
3 participants
  • Christopher Baines
  • Maxim Cournoyer
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 1 years ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
cover.1696987806.git.sharlatanus@gmail.com
Hi Guix!

New candidates to extend Astronomical collection (it would be 100 soon). As
usual let me know if I need to modify description or package styling.

Sharlatan Hellseher (5):
gnu: Add python-radio-beam.
gnu: Add python-pyavm.
gnu: Add python-pyregion.
gnu: Add python-aplpy.
gnu: Add python-spectral-cube.

gnu/packages/astronomy.scm | 204 +++++++++++++++++++++++++++++++++++++
1 file changed, 204 insertions(+)


base-commit: fc6c910f797ea232f6019c4ca5dbd105f78928df
--
2.41.0
Sharlatan Hellseher wrote 1 years ago
[PATCH 2/5] gnu: Add python-pyavm.
(address . 66454@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
31833510e2f57de80e4cd83373e88ae57dd44c1e.1696987806.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (python-pyavm): New variable.
---
gnu/packages/astronomy.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 726d4b8a5b..2f059236b9 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2161,6 +2161,29 @@ (define-public python-poppy
interest, and which require portability between platforms or ease of scripting.")
(license license:bsd-3)))
+(define-public python-pyavm
+ (package
+ (name "python-pyavm")
+ (version "0.9.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyAVM" version))
+ (sha256
+ (base32 "0vgjqvddq4a5lnmg8msm7fwqs3r6fc748xzvnhyvc387h0z8pdxk"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-astropy python-numpy))
+ (native-inputs
+ (list python-pillow python-pytest python-setuptools-scm))
+ (home-page "https://astrofrog.github.io/pyavm/")
+ (synopsis "Simple pure-python AVM meta-data handling")
+ (description
+ "PyAVM is a module to represent, read, and write metadata following the
+@acronym{AVM, Astronomy Visualization Metadata} standard provided by
+@url{https://www.virtualastronomy.org/avm_metadata.php, vamp} project.")
+ (license license:expat)))
+
(define-public python-pyvo
(package
(name "python-pyvo")
--
2.41.0
Sharlatan Hellseher wrote 1 years ago
[PATCH 1/5] gnu: Add python-radio-beam.
(address . 66454@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
101265d6eaec7ced3c208b58ad528d6efc7c1198.1696987806.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (python-radio-beam): New variable.
---
gnu/packages/astronomy.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 7c665cba4a..726d4b8a5b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3910,6 +3910,40 @@ (define-public python-rad
Grace Roman Space Telescope.")
(license license:bsd-3)))
+(define-public python-radio-beam
+ (package
+ (name "python-radio-beam")
+ (version "0.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "radio-beam" version))
+ (sha256
+ (base32 "0293hlbxb61h8js7yrvrbiw8108qn5s0rh2iy9rkhc012mzjacp0"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-astropy
+ python-matplotlib
+ python-numpy
+ python-scipy
+ python-six))
+ (native-inputs (list python-pytest-astropy))
+ (home-page "https://radio-beam.readthedocs.io/en/latest/")
+ (synopsis "Operations for radio astronomy beams with Astropy")
+ (description
+ "Radio Beam is a simple toolkit for reading beam information from FITS
+headers and manipulating beams.
+Some example applications include:
+@itemize
+@item Convolution and deconvolution
+@item Unit conversion (Jy to/from K)
+@item Handle sets of beams for spectral cubes with varying resolution between
+channels
+@item Find the smallest common beam from a set of beams
+@item Add the beam shape to a matplotlib plot
+@end itemize")
+ (license license:bsd-3)))
+
(define-public python-roman-datamodels
(package
(name "python-roman-datamodels")
--
2.41.0
Sharlatan Hellseher wrote 1 years ago
[PATCH 3/5] gnu: Add python-pyregion.
(address . 66454@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
e6932687c9c729614823ec5623632d146126213d.1696987806.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (python-pyregion): New variable.
---
gnu/packages/astronomy.scm | 40 ++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 2f059236b9..684324c589 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3449,6 +3449,46 @@ (define-public python-pynbody
N-Chilada and RAMSES AMR outputs.")
(license license:gpl3+)))
+(define-public python-pyregion
+ (package
+ (name "python-pyregion")
+ (version "2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyregion" version))
+ (sha256
+ (base32 "0l7qb7r8fnv46mdih4m5b8jaxixgpw6m7v37dpikjkblgh0vigaw"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'build-extensions
+ (lambda _
+ ;; Cython extensions have to be built before running the tests.
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
+ (propagated-inputs
+ (list python-astropy python-numpy python-pyparsing))
+ (native-inputs
+ (list python-cython
+ python-pytest
+ python-pytest-astropy-header
+ python-setuptools-scm))
+ (home-page "https://github.com/astropy/pyregion")
+ (synopsis "Python parser for ds9 region files")
+ (description
+ "@code{pyregion} is a python module to parse ds9 region files. It also
+supports ciao region files.
+Features:
+@itemize
+@item ds9 and ciao region files.
+@item (physical, WCS) coordinate conversion to the image coordinate.
+@item convert regions to matplotlib patches.
+@item convert regions to spatial filter (i.e., generate mask images)
+@end itemize")
+ (license license:expat)))
+
(define-public python-pysynphot
(package
(name "python-pysynphot")
--
2.41.0
Sharlatan Hellseher wrote 1 years ago
[PATCH 4/5] gnu: Add python-aplpy.
(address . 66454@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
4d47601842c64ade079c7b18c7620cf4a19aca68.1696987806.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (python-aplpy): New variable.
---
gnu/packages/astronomy.scm | 54 ++++++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)

Toggle diff (67 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 684324c589..15ab071ed7 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -493,6 +493,60 @@ (define-public cfitsio
(license (license:non-copyleft "file://License.txt"
"See License.txt in the distribution."))))
+(define-public python-aplpy
+ (package
+ (name "python-aplpy")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "aplpy" version))
+ (sha256
+ (base32 "0ph9jhv4q4i4z6nkqr6hjw9148kdlnayxsn83qgv5dqn0h3nc9r8"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-astropy
+ python-matplotlib
+ python-numpy
+ python-pillow
+ python-pyavm
+ python-pyregion
+ python-reproject
+ python-scikit-image
+ python-shapely))
+ (native-inputs
+ (list python-pytest-astropy
+ python-pytest-mpl
+ python-semantic-version))
+ (home-page "http://aplpy.github.io")
+ (synopsis "Astronomical Plotting Library in Python")
+ (description
+ "@acronym{APLpy, the Astronomical Plotting Library in Python} is a Python
+module aimed at producing publication-quality plots of astronomical imaging data
+in FITS format. The module uses @code{matplotlib}, a powerful and interactive
+plotting package. It is capable of creating output files in several graphical
+formats, including EPS, PDF, PS, PNG, and SVG.
+
+Main features:
+@itemize
+@item Make plots interactively or using scripts
+@item Show grayscale, colorscale, and 3-color RGB images of FITS files
+@item Generate co-aligned FITS cubes to make 3-color RGB images
+@item Make plots from FITS files with arbitrary WCS (e.g. position-velocity)
+@item Slice multi-dimensional FITS cubes
+@item Overlay any number of contour sets
+@item Overlay markers with fully customizable symbols
+@item Plot customizable shapes like circles, ellipses, and rectangles
+@item Overlay ds9 region files
+@item Overlay coordinate grids
+@item Show colorbars, scalebars, and beams
+@item Customize the appearance of labels and ticks
+@item Hide, show, and remove different contour and marker layers
+@item Pan, zoom, and save any view as a full publication-quality plot
+@item Save plots as EPS, PDF, PS, PNG, and SVG
+@end itemize")
+ (license license:expat)))
+
(define-public python-astroml
(package
(name "python-astroml")
--
2.41.0
Sharlatan Hellseher wrote 1 years ago
[PATCH 5/5] gnu: Add python-spectral-cube.
(address . 66454@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
59eee72e739f7348f149fae04f7e410b5c70729c.1696987806.git.sharlatanus@gmail.com
* gnu/packages/astronomy.scm (python-spectral-cube): New variable.
---
gnu/packages/astronomy.scm | 53 ++++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)

Toggle diff (66 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 15ab071ed7..e76e0b0952 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2524,6 +2524,59 @@ (define-public python-astral
elevation, solar azimuth, rahukaalam, and the phases of the moon.")
(license license:asl2.0)))
+(define-public python-spectral-cube
+ (package
+ (name "python-spectral-cube")
+ (version "0.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "spectral-cube" version))
+ (sha256
+ (base32 "1xyqdflnz084hdx1pbrqd1jrfyyc7f8v3564rww2v1hjylzgsnnh"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-astropy
+ python-aplpy
+ python-casa-formats-io
+ python-dask
+ python-distributed
+ python-fsspec
+ ;; python-glue-core ; Not packed http://glueviz.org/, optional.
+ python-joblib
+ python-matplotlib
+ python-numpy
+ python-radio-beam
+ python-reproject
+ python-scipy
+ python-six
+ ;; python-yt ; Not packed https://yt-project.org/, optional.
+ python-zarr))
+ (native-inputs
+ (list ;; XXX: Introduce cycle with pvextractor, listed as extra requiremnts
+ ;; in [noviz] option.
+ ;; python-pvextractor
+ python-pytest-astropy
+ python-regions
+ python-semantic-version))
+ (home-page "https://spectral-cube.readthedocs.io/en/latest/")
+ (synopsis "Library for reading and analyzing astrophysical spectral data cubes")
+ (description
+ "The spectral-cube package provides an easy way to read, manipulate,
+analyze, and write data cubes with two positional dimensions and one spectral
+dimension, optionally with Stokes parameters.
+
+It provides the following main features:
+@itemize
+@item A uniform interface to spectral cubes, robust to the wide range of conventions
+of axis order, spatial projections, and spectral units that exist in the wild.
+@item Easy extraction of cube sub-regions using physical coordinates.
+@item Ability to easily create, combine, and apply masks to datasets.
+@item Basic summary statistic methods like moments and array aggregates.
+@item Designed to work with datasets too large to load into memory.
+@end itemize")
+ (license license:bsd-3)))
+
(define-public python-spherical-geometry
(package
(name "python-spherical-geometry")
--
2.41.0
Sharlatan Hellseher wrote 1 years ago
(address . 66454@debbugs.gnu.org)
CAO+9K5pQCunXOEF=qWQKPJQk_=nyQ3qRLixq0iEAVGT4W1r0Gw@mail.gmail.com
Hi,

It looks like QA ignored this patch series of can't process it.
Attachment: file
Christopher Baines wrote 1 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 66454@debbugs.gnu.org)
87pm1f7nhx.fsf@cbaines.net
Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (2 lines)
> It looks like QA ignored this patch series of can't process it.

data.qa.guix.gnu.org just hasn't got around yet to processing this patch
series. Maybe it needs to be clearer, but this can be seen by looking at
[1] where it says "Yet to process revision".

-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmUsLkpfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xc36RAAqpnCA4uILi406KjA0mCGjryAd4qm9qU7
Q2400DJIbqe038F5aV8/34v8LFAc7YLYmhgIHF/MrlQAIgAJSlRODyeX0BNlRbzG
he3239XEcPjwRMMIEzAmFnShJ1B9s6Q7FSnxtz1Q3UMcLu9oTL1jdXsu5shjhRQL
M4aWjhSh13gil2scKcEPl69lUXy8ZOgRD6nxRboiBavP6mEukKbiZuX+0GWcY5m+
Rn+ZThqnA4JZs05Qddk6z82ZnjEJlXtD0CDTATb3hxyIaWAKI9LkoTFZ+mNYPRA6
uZM5ZyN38PxyHo4Wz2224vew5pAjjb4cB43JBJjnVtDD9omhiczdC3SFO217bMW8
NzxKcWL9yL2Na+ZUSKDIaQ88TQSmv0un6Rex8xgSht4QtgVvbunC4blOB0J+XQw3
oEEDhJL8dDZ6y9Rv8p6iXdsX1i1bxbgKCda42yr3E7gU746mpzCzls05reiGpMjK
2CGaboFrJdhF0trClxCvqpi6zF+D92+oFoAbRnfkFhiblEamKoZbKA4z4rImeGJX
4UG3ejPc2x7l+OnBLW07L41RacdEiC4L1zoTu4uj8Xj+Gh0lTcBfHV1KOQtygueg
9Q0SSkeHebqZairL76/iiZ9RYA+HxZWwD2hDEyEBxfiYgehr7yBgX+2iG/1fNHUd
rCRKuSVW3IE=
=jt1k
-----END PGP SIGNATURE-----

Sharlatan Hellseher wrote 1 years ago
(address . 66454@debbugs.gnu.org)(name . Christopher Baines)(address . mail@cbaines.net)
CAO+9K5qJy89Xwy4e1d7g_UhOirQZcykPoRK6J52ZuOSoLOYtmA@mail.gmail.com
Hi Guix!
Looks like QA has a green light on this patch series!
Thanks,
Oleg
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Sharlatan Hellseher wrote 1 years ago
(address . 66454@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
CAO+9K5rH9zzrc8TPPSe6nRJbX807LqqiVz8NsYXcMyzQhzyQ3g@mail.gmail.com
Hi,
A gentle ping on this issue. Let me know if it needs any modification.
Regards,
Oleg
--
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Maxim Cournoyer wrote 1 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 66454-done@debbugs.gnu.org)
875y2mr9oo.fsf@gmail.com
Hi!

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (4 lines)
> Hi,
>
> A gentle ping on this issue. Let me know if it needs any modification.

Nice series! Since you sent it, radio-beam and spectral-cube had a new
version, so I've updated them. I've also added 'python-setuptools-scm'
to their native inputs, otherwise the version metadata was missing from
their outputs and their version was incorrectly reported as '0.0.0'.

You have cumulated 579 commits thus far; I think you should apply to
become a committer; this way you could keep the various astrology
packages updated more easily.

I'd be happy to vouch for you; you clearly put a lot of efforts toward
producing high-quality packages.

--
Thanks,
Maxim
Closed
Sharlatan Hellseher wrote 1 years ago
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 66454-done@debbugs.gnu.org)
CAO+9K5rrPe+ExtasnXB2E8dkjSE19Gk20h3h_JJ_XLXGXSx6MA@mail.gmail.com
Hi Maxim,

I've sent October Astronomy updates in separate issue

Is there any formal process for commit access and do I need to apply? This
sounds like I can accelerate review process of astro soft an keep them
refreshed.

Regards,
Oleg

On Tue, 31 Oct 2023, 17:19 Maxim Cournoyer, <maxim.cournoyer@gmail.com>
wrote:

Toggle quote (24 lines)
> Hi!
>
> Sharlatan Hellseher <sharlatanus@gmail.com> writes:
>
> > Hi,
> >
> > A gentle ping on this issue. Let me know if it needs any modification.
>
> Nice series! Since you sent it, radio-beam and spectral-cube had a new
> version, so I've updated them. I've also added 'python-setuptools-scm'
> to their native inputs, otherwise the version metadata was missing from
> their outputs and their version was incorrectly reported as '0.0.0'.
>
> You have cumulated 579 commits thus far; I think you should apply to
> become a committer; this way you could keep the various astrology
> packages updated more easily.
>
> I'd be happy to vouch for you; you clearly put a lot of efforts toward
> producing high-quality packages.
>
> --
> Thanks,
> Maxim
>
Attachment: file
Closed
Maxim Cournoyer wrote 1 years ago
(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)(address . 66454-done@debbugs.gnu.org)
87wmv2npka.fsf@gmail.com
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

Toggle quote (5 lines)
> Hi Maxim,
>
> I've sent October Astronomy updates in separate issue
> https://issues.guix.gnu.org/66778

Thanks for the heads-up.

Toggle quote (4 lines)
> Is there any formal process for commit access and do I need to apply? This
> sounds like I can accelerate review process of astro soft an keep them
> refreshed.

See (info "(guix) Commit Access"). In a nutshell, you need to find 3
committers to vouch for you. The list of current committers is kept in
.guix-authorizations at the root of the project.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 66454@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 66454
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help